Can't compile rt2500 drivers

Issues Related to Networking (Wired and Wireless)

Moderator: Moderators

Post Reply
Baby Hen
Posts: 13
Joined: Mon Jan 22, 2007 13:49

Can't compile rt2500 drivers

Post by Sebokie » Tue Oct 09, 2007 22:33


I have removed and blacklisted rt2500pci, rt2x00pci and rt2x00lib.
I'm trying to compile the legacy drivers for my rt2500 wifi chip ( ... z?download)
but it does not compile and I don't really understand what it says:

Code: Select all

make[1]: entrant dans le répertoire « /usr/src/linux-2.6.22-sabayon »
  CC [M]  /home/sebokie/Desktop/rt2500-1.1.0-b4/Module/rtmp_main.o
Dans le fichier inclus à partir de /home/sebokie/Desktop/rt2500-1.1.0-b4/Module/rtmp_main.c:50:
/home/sebokie/Desktop/rt2500-1.1.0-b4/Module/rt_config.h:58:40: erreur: linux/config.h : Aucun fichier ou répertoire de ce type
/home/sebokie/Desktop/rt2500-1.1.0-b4/Module/rtmp_main.c: In function ‘RT2500_open’:
/home/sebokie/Desktop/rt2500-1.1.0-b4/Module/rtmp_main.c:343: attention : ‘deprecated_irq_flag’ is deprecated (declared at include/linux/interrupt.h:66)
/home/sebokie/Desktop/rt2500-1.1.0-b4/Module/rtmp_main.c:343: attention : passing argument 2 of ‘request_irq’ from incompatible pointer type
/home/sebokie/Desktop/rt2500-1.1.0-b4/Module/rtmp_main.c: In function ‘rt2500_resume’:
/home/sebokie/Desktop/rt2500-1.1.0-b4/Module/rtmp_main.c:947: attention : ignoring return value of ‘pci_enable_device’, declared with attribute warn_unused_result
/home/sebokie/Desktop/rt2500-1.1.0-b4/Module/rtmp_main.c: In function ‘rt2500_init_module’:
/home/sebokie/Desktop/rt2500-1.1.0-b4/Module/rtmp_main.c:1009: attention : implicit declaration of function ‘pci_module_init’
make[2]: *** [/home/sebokie/Desktop/rt2500-1.1.0-b4/Module/rtmp_main.o] Erreur 1
make[1]: *** [_module_/home/sebokie/Desktop/rt2500-1.1.0-b4/Module] Erreur 2
make[1]: quittant le répertoire « /usr/src/linux-2.6.22-sabayon »
rt2500.ko failed to build!
make: *** [module] Erreur 1

What's more, when I try to compile the utility (which i need to configure WPA wonnection) it gives me lots of error about problems with qt.
In sabayon 3.3 my wireless was recognized as ra0, I had RaConfig2500 and it worked. With 3.4f my wifi is wlan0 and I don't have Raconfig2500 and wpa_supplicant does not work.
Any help would be appreciated.

Baby Hen
Posts: 13
Joined: Mon Jan 22, 2007 13:49

Re: Can't compile rt2500 drivers

Post by Sebokie » Wed Oct 10, 2007 8:49

Nevermind, after some tweaking I got rt2500 driver from portage to work, so I don't need to compile anymore.
I don't remember all the things I've done, but that includes:
-emerge -C ndiswrapper
-rmmod rt2500pci (etc)
-nano /etc/modules.d/blacklist and /etc/modprobe.d/blacklist and add blacklist rt 2500pci (etc)
-emerge rt2500
-ifconfig wlan0 down (then up)
-download and compile rutilt from
-configure /etc/conf.d/net (I have static ip, I removed knetworkmanager)
-launch rutilt, create profile and connect.

I think I also deleted some .ko files in some kernel directory but I don't really know if it helped.
On my next Sabayon install I'll probably try to be more precise, anyway now it works.

Post Reply