Uninstalling Compiz/Reinstalling [Solved]

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

Re: Uninstalling Compiz/Reinstalling [Solved]

Postby wolfden » Mon Oct 08, 2007 0:02

Yes, you need to have the missing USE flags before installing stuff as they won't build properly.

The mini edition should have the missing USE flags fixed, but all the the 3.4 DVD's have the missing flags, which cause several headaches
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: Uninstalling Compiz/Reinstalling [Solved]

Postby lucknuts » Mon Oct 08, 2007 0:10

wolfden wrote:Yes, you need to have the missing USE flags before installing stuff as they won't build properly.

The mini edition should have the missing USE flags fixed, but all the the 3.4 DVD's have the missing flags, which cause several headaches



Awesome, thank you, will repost if everything works.

But on the USE Flags, I have the 3.4f mini and it did not have the USE flags. I downloaded it probably 2-3 weeks ago, (seems like anyways) maybe you have updated since then.
Yes, I'm new at this.
Will learn. WIll teach.
lucknuts
Growing Hen
 
Posts: 100
Joined: Fri Sep 28, 2007 6:48
Location: United States of America

Re: Uninstalling Compiz/Reinstalling [Solved]

Postby lucknuts » Mon Oct 08, 2007 6:15

So I did it in that order, and everything worked semi- ok...

I got fusion-icon to load.

Although now the compiz config settings does not open

when i run it fromt he command line it output is this.

Code: Select all
localhost Lucky # ccsm
Traceback (most recent call last):
  File "/usr/bin/ccsm", line 24, in <module>
    import gtk
  File "/usr/lib/python2.5/site-packages/gtk-2.0/gtk/__init__.py", line 48, in <module>
    from gtk import _gtk
ImportError: No module named cairo



This is the only error I get, I can't edit the configuration setting of compiz.
Otherwise it's working.

No clue what to do now... =[. Can't edit the options! say what!
Yes, I'm new at this.
Will learn. WIll teach.
lucknuts
Growing Hen
 
Posts: 100
Joined: Fri Sep 28, 2007 6:48
Location: United States of America

Re: Uninstalling Compiz/Reinstalling [Solved]

Postby wolfden » Mon Oct 08, 2007 7:46

well it looks like you updated python, did you run python-updater -i ?
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: Uninstalling Compiz/Reinstalling [Solved]

Postby lucknuts » Mon Oct 08, 2007 17:13

wolfden wrote:well it looks like you updated python, did you run python-updater -i ?



would have never thought to do that. thanks.

when I do that I get this error. (not really an error but masked packages)

Code: Select all
These are the packages that would be merged, in order:

Calculating dependencies /
!!! All ebuilds that could satisfy ">=x11-base/xorg-server-1.4" have been masked.
!!! One of the following masked packages is required to complete your request:
- x11-base/xorg-server-1.4-r1 (masked by: package.mask)
/etc/portage/package.mask:
#=media-sound/jack-audio-connection-kit-0.102.20

- x11-base/xorg-server-1.4-r2 (masked by: package.mask)

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.
(dependency required by "x11-drivers/xf86-video-mga-1.4.7" [ebuild])


So i'm guessing I would find #=media-sound/jack-audio-connection-kit-0.102.20 in package.mask, and put it in package.unmask?
If i'm correct. Not sure, brains a little foggy, just woke up.
Yes, I'm new at this.
Will learn. WIll teach.
lucknuts
Growing Hen
 
Posts: 100
Joined: Fri Sep 28, 2007 6:48
Location: United States of America

Re: Uninstalling Compiz/Reinstalling [Solved]

Postby wolfden » Mon Oct 08, 2007 22:07

you will just have to work your way throught it - there is posts already on this stuff too, so look around too.
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: Uninstalling Compiz/Reinstalling [Solved]

Postby lucknuts » Tue Oct 09, 2007 6:12

wolfden wrote:you will just have to work your way throught it - there is posts already on this stuff too, so look around too.



I just want to say thank you for all your help. Even though sometimes it may come across negative, but really your trying to get the point to people to get their arse out there and read more instead of posting bulletins to find their answers.

You pushed me and I have a very unique and sweet desktop enviroment now with no errors, very stable. I am very happy now.

Put a lot of work, only about a week, but maybe 40+ hours messing around with everything...I think I conquered compiz. lol...haha

Thanks again...


My solution was to just update everything in the list from running that command (update python -i) singly, 1 by 1, took about 15 minutes....

Everything is...voila.
Yes, I'm new at this.
Will learn. WIll teach.
lucknuts
Growing Hen
 
Posts: 100
Joined: Fri Sep 28, 2007 6:48
Location: United States of America

Re: Uninstalling Compiz/Reinstalling [Solved]

Postby wolfden » Tue Oct 09, 2007 9:35

Great to hear and I am sure you learned a lot too. As you have learned, this distro isn't for the lazy.

You did great and you will do great with this distro. Just got to continue to hang in there and it will just get easier and easier.

:D
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: Uninstalling Compiz/Reinstalling [Solved]

Postby lucknuts » Tue Oct 09, 2007 22:21

wolfden wrote:Great to hear and I am sure you learned a lot too. As you have learned, this distro isn't for the lazy.

You did great and you will do great with this distro. Just got to continue to hang in there and it will just get easier and easier.

:D


Indeed, and I would love for you to teach even more. I'm lovin this distro, I have everything to do work concluding burning cd,s playing dvds, flash on firefox, organizing all folders, web development, yet to get banshee and gimp working. I want to learn more though, so i've concluded to looking at my schools library for linux commands...although, i'm still unaware of the differences between, rpm, debian, tar.gz packages and all of that...haha-!

But I can learn quick...anyways. Rock on....I suggest drinking a sparks before and after every meal. God dang those things are good...

I am only 21...and If I ever got rich, I would donate a million to this distro. =] woot.
Yes, I'm new at this.
Will learn. WIll teach.
lucknuts
Growing Hen
 
Posts: 100
Joined: Fri Sep 28, 2007 6:48
Location: United States of America

Re: Uninstalling Compiz/Reinstalling [Solved]

Postby Shanghaied » Fri Oct 12, 2007 14:39

Yep,
Sabayon (or gentoo ) is a quite demanding distro. I did a lot of distro hopping and sometimes I have been thinking of leaving Sabayon as well (when you have to kids and working at a quite demanding contract abroad you're time is limited).
Anyway I really like Sab so I have stuck to it even if it has cost me days of recompiling KDE, OOO etc.
To get to the point why do you want to use Banshee I mean I actually have it installed but purely because there is a nasty bug in Amarok e.g. I download Lugradio's Podcast (one of my favourites) the time stops in the middle but you can still listen through the whole episode on amarok.
However when I sync it to my piece of shit Ipod (yeah I know the next one I buy will be the Cowoon Iaudio) it will stop in the middle.
I have tried to find a solution without success except installing Banshee (and all the Gnome deps) but so far only Banshee works.
Lucky,
Banshee should only be an Emerge away just make sure you have the gnome flags enabled (it is a gnome packages as far as I understand).
:lol:
Dell Inspiron XPS Gen2
Intel Pentium M 2.13Ghz, 1GB RAM, Nvidia Geforce Go 6800 Ultra 256 MB, 17" WUXGA, Intel Pro/Wireless 2200BG, Broadcom NetXtreme Gigabit Ethernet, Hitachi 60Gb 7200 rpm
Shanghaied
Young Hen
 
Posts: 33
Joined: Tue Jul 31, 2007 6:59
Location: Shanghai

PreviousNext

Return to 3D Desktops and Window Managers

Who is online

Users browsing this forum: No registered users and 1 guest

cron