Realtek ALC268 audio chipset. Will not work. no sound. nada.

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

Realtek ALC268 audio chipset. Will not work. no sound. nada.

Postby Jarerex » Thu Oct 04, 2007 5:18

Can anyone tell me how to fix this on my laptop? (A Compal IFL90/Sager2090). I have tried everything i could find on the web. I have updated alsa to the most recent version. Nothing works. Nothing. Its driving me insane.

Any help?
Jarerex
Baby Hen
 
Posts: 4
Joined: Wed Aug 29, 2007 5:16

Re: Realtek ALC268 audio chipset. Will not work. no sound. nada.

Postby WarraWarra » Thu Oct 04, 2007 5:40

Did you try "alsaconfig" or "alsaconf" as root in terminal and follow the options / let it finish + install the modules for you.
Usually this works.
Also check gentoo.org / forums / wiki or our own wiki top of this page for similar hardware. If no one else has this hardware and no one else used it in linux then likely no fix but several laptops uses the same sound cards / models even some desktops so best is to look possibly for 965 intel based motherboards or just google for the actual sound card part number and see what pops up then search for that motherboard / pc + linux and see what comes up.
Likely someone has fixes this already.

http://www.google.com/search?q=alc268+a ... =firefox-a
Uses intel HDA driver.
http://ubuntuforums.org/archive/index.php/t-540036.html

Last step: I added the line

options snd-hda-intel model=toshiba

to the /etc/modprobe.d/alsa-base


Might find a how-to for gentoo about the Intel HDA or download the source and
Code: Select all
sh ./configure
or
sh ./install
or
sh ./make

Once in the same extracted folder as this sound card drivers / source compressed / extracted folder.

Hope this helps.
Ask on irc on top of this page "chat" or desktop should still have online help / chat option icon there.
WarraWarra
Sagely Hen
 
Posts: 1989
Joined: Wed Jan 03, 2007 21:01
Location: 31.324270, -113.585511

Re: Realtek ALC268 audio chipset. Will not work. no sound. nada.

Postby Jarerex » Fri Oct 05, 2007 0:34

That would fix it. Fix it wonderfully. Except the problem that there IS NO ALSA-BASE file in /etc/modprobe.d!!!!

I re-installed Sabayon and ALSA, there is STILL no Alsa-Base file >_>

*is getting very pissy*
Jarerex
Baby Hen
 
Posts: 4
Joined: Wed Aug 29, 2007 5:16


Return to Hardware

Who is online

Users browsing this forum: No registered users and 2 guests

cron