bug: 3.4 mini no ipw3945 wireless

Issues Related to Networking (Wired and Wireless)

Moderator: Moderators

bug: 3.4 mini no ipw3945 wireless

Postby ndrwgn » Tue Sep 25, 2007 6:59

I'm pretty sure that there's something wrong with knetworkmanager. I got no prob trouble shooting myself, but w/ no internet, I'm dead in the water. And she looked so clean!
HP tx2500: Sabayon
Acer Aspire One 9": ubuntu 9.04/backtrack/linuxmint mix-mess (not multiboot)
Acer Aspire One 10": +1
ndrwgn
Young Hen
 
Posts: 27
Joined: Tue Jul 31, 2007 4:28

Re: bug: 3.4 mini no ipw3945 wireless

Postby Fitzcarraldo » Tue Sep 25, 2007 17:14

Which version of KNetworkManager have you got installed? net-misc/knetworkmanager or kde-misc/knetworkmanager?

You could try to unemerge the former and emerge the latter. as the kde-misc is a newer version.

EDIT: I'm assuming you've got wired Internet connection, of course, even if WiFi is not working. Actually, thinking about it, perhaps you could try doing this before installing SL to the HDD and see if the installed version stays as kde-misc/knetworkmanager after installation of SL to the HDD (I'm not sure if this would be the case, though).
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7984
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: bug: 3.4 mini no ipw3945 wireless

Postby ndrwgn » Wed Sep 26, 2007 0:05

Yeah, that was my initial idea too, I tried to use the version from 3.4f (which works fine), but they are the same. The emerge didn't make any difference, So I don't know.
HP tx2500: Sabayon
Acer Aspire One 9": ubuntu 9.04/backtrack/linuxmint mix-mess (not multiboot)
Acer Aspire One 10": +1
ndrwgn
Young Hen
 
Posts: 27
Joined: Tue Jul 31, 2007 4:28

Re: bug: 3.4 mini no ipw3945 wireless

Postby WarraWarra » Wed Sep 26, 2007 21:33

My Dell ipw3945 works well on my E1705 Dell.
Will install that wifi card again and try to see if I can find a problem. Using bcm4311mcg Dell 1390 as default.

I just right click knetwork thingy next to time top right and select the network or other wifi networks and add wpa2 type or auto + password then it connects.

Edit: I had to once "modprobe -r bcm43xx " module and then load it again with "modprobe bcm43xx" just to get the wifi light working , ipw3945 flickers and not continuesly on like broadcom dell 1390 .
WarraWarra
Sagely Hen
 
Posts: 1989
Joined: Wed Jan 03, 2007 21:01
Location: 31.324270, -113.585511

Re: bug: 3.4 mini no ipw3945 wireless

Postby Fitzcarraldo » Wed Sep 26, 2007 22:32

ndrwgn, are you trying to use unencrypted wireless, or to use WEP or WPA? If WPA, have you tried re-emerging wpa_supplicant-0.5.8?
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7984
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: bug: 3.4 mini no ipw3945 wireless

Postby WarraWarra » Thu Sep 27, 2007 1:23

Someone else with the 4965 updated the router firmware and they could then connect with nothing needed same as me nothing needed just work.

Cold booting internet devices:
Unplug all internet related modems / routers / wifi that has a cable conected inbetween them , not on your pc for 5 mins and let the static dissapate then power them up and try again this can help as most wifi routers / modem is poorly shielded against static / radio interference or can build up a charge same as the satellites during a solar flare and then issues happen.

On my side it happens as well but over OSX / xp pro / Lin etc and then the routers is to blame not a software / driver / hardware in the pc's.
WarraWarra
Sagely Hen
 
Posts: 1989
Joined: Wed Jan 03, 2007 21:01
Location: 31.324270, -113.585511

Re: bug: 3.4 mini no ipw3945 wireless

Postby ndrwgn » Thu Sep 27, 2007 6:50

Oh, yeah, the other thing I forgot to mention is that I don't even see any access points.
HP tx2500: Sabayon
Acer Aspire One 9": ubuntu 9.04/backtrack/linuxmint mix-mess (not multiboot)
Acer Aspire One 10": +1
ndrwgn
Young Hen
 
Posts: 27
Joined: Tue Jul 31, 2007 4:28

Re: bug: 3.4 mini no ipw3945 wireless

Postby WarraWarra » Thu Sep 27, 2007 8:44

Did you try as root in terminal "net-setup" ?

Is the wifi router even working properly.

Something is seriously wrong as 3.4e + 3.4f + 3.4 mini all works on live cd /dvd for my ipw3945 Dell card.

Did you have a look at the "before 3.4e ipw3945 ..." post in networking ?

Only you will be able to figure this out.
WarraWarra
Sagely Hen
 
Posts: 1989
Joined: Wed Jan 03, 2007 21:01
Location: 31.324270, -113.585511

Re: bug: 3.4 mini no ipw3945 wireless

Postby ndrwgn » Fri Oct 05, 2007 22:29

Yes, my router works (with most of the other live cd distros I have). when I boot up, it says that knetworkmanger isn't working. I'm clueless.
HP tx2500: Sabayon
Acer Aspire One 9": ubuntu 9.04/backtrack/linuxmint mix-mess (not multiboot)
Acer Aspire One 10": +1
ndrwgn
Young Hen
 
Posts: 27
Joined: Tue Jul 31, 2007 4:28

Re: bug: 3.4 mini no ipw3945 wireless

Postby WarraWarra » Fri Oct 05, 2007 22:46

About to clean install here and in live cd 3.4 32bit , right click knetworkmanager and select wifi = 28% then nothing 2 times = weard. Manual wifi and same happens , weard.

Then went to terminal as root and ran :
net-setup
Using all default for wireless and as applicable it connected and typing this now as result.
Knetworkmanager is still dead.

So likely Knetworkmanager is full of Microsoft LOL .

Might want to disable knetworkmanager from starting and then using the networking part of the forum and post = "before 3.4e ipw3945 ...." and links / info there to make it start by default at boot for wifi.

rc-update and kernel-2.6 is important for starting at boot.

This might help you. On bcm4311mcg dell 1390 now so not just the ipw3945 bug .
WarraWarra
Sagely Hen
 
Posts: 1989
Joined: Wed Jan 03, 2007 21:01
Location: 31.324270, -113.585511


Return to Networking and Wireless

Who is online

Users browsing this forum: No registered users and 1 guest

cron