Computer not registering with DNS automatically

Issues Related to Networking (Wired and Wireless)

Moderator: Moderators

Computer not registering with DNS automatically

Postby tachytrope » Tue Sep 25, 2007 14:03

Hey guys. I'm new to Sabayon, but have been running Gentoo for about 2 years now. I have run into an annoying problem. My computer will not register the hostname with the DNS server automatically. No matter how I set my /etc/conf.d/net file, it doesn't do the job. I tried setting dhcp_eth0 = "-h hostname.suffix.com" after a friend told me that is how he got his box working right, but it didn't do the job for me. However, if I kill dhcpcd and run it again with the -h hostname.suffix.com option, then the computer does register with the DNS server. Is there some other configuration I need to do for this to happen automatically?

Thanks for the help!
Eamon
tachytrope
Baby Hen
 
Posts: 2
Joined: Tue Sep 25, 2007 13:59

Re: Computer not registering with DNS automatically

Postby wolfden » Tue Sep 25, 2007 15:09

did you remove NetworkManager from start up too? That will wipe out DNS too
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: Computer not registering with DNS automatically

Postby tachytrope » Tue Sep 25, 2007 16:09

Well, I just did, and it appears to be working now. I just removed NetworkManager from the default runlevel and added net.eth0 instead. Thanks for the tip.

Out of curiosity, is there any way to get NetworkManager to register the hostname with the DNS server?

Eamon
tachytrope
Baby Hen
 
Posts: 2
Joined: Tue Sep 25, 2007 13:59


Return to Networking and Wireless

Who is online

Users browsing this forum: No registered users and 1 guest