Issues with DWL-G510 setup

Issues Related to Networking (Wired and Wireless)

Moderator: Moderators

Issues with DWL-G510 setup

Postby Aakhunaten » Sat Sep 15, 2007 7:36

I have been trying to setup this card with Sabayon 3.4e. I have been using this card with openSuse 10.2 with the drivers from both ralink and But when I use the default driver that comes with Sabayon, the link strength is always 0 and when I use NetworkManager, it is always stuck at 28%. When I use the drivers from those 2 sites, i get a inccorect module -1 or something like that.

Also, I see that the card is being recognized as RT2561/RT61 rev B, when my card is a rev C.

Can someone help me set this up with Sabayon? The only reason I will have to switch to another flavor of Linux would be the inability to connect to the internet wirelessly (which is the only option I have.

Baby Hen
Posts: 8
Joined: Thu Sep 13, 2007 19:25

Re: Issues with DWL-G510 setup

Postby WarraWarra » Wed Sep 19, 2007 7:38

Only thing I can think of is to try the windows driver + ndiswrapper for the time being or if you can get a cable from the modem / router to the pc for internet then possibly update the driver this way.
Someone else here had something similar with a usb belkin fd50??? using the same driver or ndiswrapper.

That post might have some answers for you. Also check out the wiki top right of this page or forums / wiki as likely someone there has gotten it to work as Sabayon is gentoo based the same instructions will work here as well.

Hope this help.
Sagely Hen
Posts: 1989
Joined: Wed Jan 03, 2007 21:01
Location: 31.324270, -113.585511

Return to Networking and Wireless

Who is online

Users browsing this forum: No registered users and 1 guest