No luck with 3D games!

A place where Linux Gamers can share their experience and help each other with Linux Games, native or emulated ;)

Moderator: Moderators

No luck with 3D games!

Postby Dingo » Sun Sep 16, 2007 9:21

I just got a new Intel Core 2 Duo E6850 2Gb Ram, 512MB Nvidia GF 8500 GT PCI-E graphics card. Just installed Sabayon 3.4f. Absolutely awsome!!
Unfortunately none of the 3D games open. Sauerbraten, Savage, Second Life etc. They are trying, but then nothing happens.
When I click on Nexuiz the resolution on the screen suddenly goes way down (normal 1680 x 1050) and I loose the mouse cursor. Only way out of this one is rebooting. :cry:
It is a bit annoying that I cannot use everything of my new OS. This is also the first time that I have a Nvidia card.
I am still relatively new to Linux and this is the first time that I have installed Sabayon. I have Ubuntu on our other computer. Please do not be too technical.
Many thanks in advance. :)
Dingo
Young Hen
 
Posts: 34
Joined: Mon Feb 12, 2007 2:52
Location: Australia

Re: No luck with 3D games!

Postby CCR » Sun Sep 16, 2007 12:19

Hi there..
The problem is missing use flags.
I quote Wolfden from another topic:
add it to your /etc/make.conf
opengl sdl png gif qt3 qt4 qt3support gtk <---make sure to remove the -gtk


After you added those words to use in make.conf just re-emerge your nvidia drivers and all should be working again :)
'Greets
/CCR
CCR
Simple Hen
 
Posts: 58
Joined: Fri Jun 01, 2007 5:47
Location: Svenljunga, SWEDEN

Re: No luck with 3D games!

Postby Dingo » Sun Sep 16, 2007 13:07

As I said in the previous post I am still a bit new to Linux. Could you please give me a step by step guide? :oops: Re-emerge nvidia drivers? I am glad that it is possible to fix this though. Sabayon really is a cool distro. Best looking around. Sorry about the hassle. :)
Dingo
Young Hen
 
Posts: 34
Joined: Mon Feb 12, 2007 2:52
Location: Australia

Re: No luck with 3D games!

Postby flick » Sun Sep 16, 2007 14:09

To add USE flags to /etc/make.conf do as root :

nano -w /etc/make.conf

then add the use flags in the part that starts with "USE="

Press Control and X, nano will prompt you for saving the changes, say yes if you're done, nano will prompt you to use the same filename, say yes.

then as root do :

emerge --sync

layman -S

emerge nvidia-drivers

Probably will want to reboot after that to make sure the newly-installed driver gets used.
flick
Growing Hen
 
Posts: 119
Joined: Wed Jan 03, 2007 15:09
Location: Milwaukee, WI

Re: No luck with 3D games!

Postby CCR » Sun Sep 16, 2007 15:14

Yes that's it :)
Sorry i did not write a full explanation..
Also if you wonder what "do as root" means.. you open a command console.. found at the top of favourites on your kicker menu..
Then you write su and then root as username and your chosen password when asked.
Thanx flick also for the help explaining better than i did at first :oops: :D
Hope things will work out for ya

/CCR
CCR
Simple Hen
 
Posts: 58
Joined: Fri Jun 01, 2007 5:47
Location: Svenljunga, SWEDEN

Re: No luck with 3D games!

Postby eshum » Sun Sep 16, 2007 20:00

Or you could use the gui- click menu-applications- settings-acceleration manager- aiglx- configure desktop acceleration.

ed
eshum
Technological Hen
 
Posts: 312
Joined: Tue Feb 20, 2007 20:42
Location: Oregon

Re: No luck with 3D games!

Postby CCR » Sun Sep 16, 2007 21:36

Not at all !!
The issue is missing stuff in a configuration file, and it will NOT help to use acceleration manager. 3.4e and 3.4f are the versions affected.
/CCR
CCR
Simple Hen
 
Posts: 58
Joined: Fri Jun 01, 2007 5:47
Location: Svenljunga, SWEDEN

Re: No luck with 3D games!

Postby Dingo » Mon Sep 17, 2007 3:22

I found the file.
I am now supposed to add this to the bottom of the file:
opengl sdl png gif qt3 qt4 qt3support gtk

This I do not understand:
<---make sure to remove the -gtk

I cannot see -gtk anywhere.
Sorry for being so thick, I am just a bit worried about breaking the system. I already have re-installed a lot of things lately. :lol:
Thanx again, this really is a great community
Jock
Dingo
Young Hen
 
Posts: 34
Joined: Mon Feb 12, 2007 2:52
Location: Australia

Re: No luck with 3D games!

Postby CCR » Mon Sep 17, 2007 10:06

Hello again :)
Best to add the words opengl sdl png gif qt3 qt4 qt3support gtk just after the word USE= in the file.
Also if your file does not have any -gtk you can just ignore that. Some has that word apparently, but not all. I could not find it myself :D
Hope this helps.. Otherwise perhaps it will be fixed by next release "wink wink at Lxnay" :D :D :D

Once again
/CCR
CCR
Simple Hen
 
Posts: 58
Joined: Fri Jun 01, 2007 5:47
Location: Svenljunga, SWEDEN

Re: No luck with 3D games!

Postby Dingo » Tue Sep 18, 2007 3:54

Sorry, but I do not seem to be able to write the changes into the right spot. Everything always ends up at the beginning. I realize I have to learn a lot and I am starting to feel a bit stupid. :oops:
Hope you still got a bit of patience left. :)
Cheers
Dingo
Young Hen
 
Posts: 34
Joined: Mon Feb 12, 2007 2:52
Location: Australia

Next

Return to The Gamers Shed

Who is online

Users browsing this forum: No registered users and 1 guest

cron