Anyone else having Emerge trouble? [Solved]

Anything that pertains to Portage

Moderator: Moderators

Anyone else having Emerge trouble? [Solved]

Postby krcrouse » Sun Sep 16, 2007 2:43

Just installed 3.4f and started to get the system to my necessary specs (including ntfs3g). Emerge won't find a single package. Not a single. No emacs. No ntfs3g. Is there something obvious here? It spews about for about 2 minutes checking all the hosts and comes back with

..... garbage garbage garbage.....
last error:

Resolving gentoo.osuosl.org... 64.50.238.52, 64.50.236.52
Connecting to gentoo.osuosl.org|64.50.238.52|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
20:33:19 ERROR 404: Not Found.

>>> Downloading 'ftp://cudlug.cudenver.edu/pub/mirrors/distributions/gentoo/distfiles/eselect-emacs-0.8.tar.bz2'
--20:33:19-- ftp://cudlug.cudenver.edu/pub/mirrors/d ... .8.tar.bz2
=> `/usr/portage/distfiles/eselect-emacs-0.8.tar.bz2'
Resolving cudlug.cudenver.edu... 132.194.22.137
Connecting to cudlug.cudenver.edu|132.194.22.137|:21... connected.
Logging in as anonymous ... Logged in!
==> SYST ... done. ==> PWD ... done.
==> TYPE I ... done. ==> CWD /pub/mirrors/distributions/gentoo/distfiles ...
No such directory `pub/mirrors/distributions/gentoo/distfiles'.

!!! Couldn't download 'eselect-emacs-0.8.tar.bz2'. Aborting.
* Fetch failed for 'app-admin/eselect-emacs-0.8-r1'

* Messages for package app-admin/eselect-emacs-0.8-r1:

* Fetch failed for 'app-admin/eselect-emacs-0.8-r1'


K
krcrouse
Young Hen
 
Posts: 22
Joined: Thu Jul 19, 2007 19:58
Location: St Louis, MO, USA

Re: Anyone else having Emerge trouble?

Postby WarraWarra » Sun Sep 16, 2007 4:38

Not here.
You did do the normal " emerge --sync ; emerge portage ; layman -S " and then installed + updated ? Emerge --regen is similar to emerge --sync except it does not redownload the new file lists stuff only local rebuild / regenerate function.

If this worked and is no longer working it could be some packages might have been damaged , fix = " revdep-rebuild -X " after you made sure the /etc/make.conf is close to what you want. Could also have to use " emerge --newuse package name here " , dep -w after /etc/make.conf adjust should help as well.

emerge portage could fix portage = clean install even if it is there already using this.

Hope something here helps.
WarraWarra
Sagely Hen
 
Posts: 1989
Joined: Wed Jan 03, 2007 21:01
Location: 31.324270, -113.585511

Re: Anyone else having Emerge trouble?

Postby krcrouse » Mon Sep 17, 2007 14:10

Yep, that was it. Thanks much.

K
krcrouse
Young Hen
 
Posts: 22
Joined: Thu Jul 19, 2007 19:58
Location: St Louis, MO, USA

Re: Anyone else having Emerge trouble? [Solved]

Postby eivindgl » Tue Sep 18, 2007 23:23

Hi

I`ve tried the posted solution but it doesn't work for me. I have synced portage and I've also previously installed a couple of packages using emerge. I got this error while trying to get the "emerge -u world' dependency check to pass.

I can't point out my last actions that lead up to this error, but I`d really appreciate some help. :)

revdep-rebuild fails since it can't download the packages needed. i have an internett connection.
eivindgl
Baby Hen
 
Posts: 1
Joined: Tue Sep 18, 2007 22:49


Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: No registered users and 0 guests