wireless stops at 28% and then fails to connect

Issues Related to Networking (Wired and Wireless)

Moderator: Moderators

Re: wireless stops at 28% and then fails to connect

Postby hunt_mat » Sat Sep 15, 2007 0:20

Hi,

I found out that this was due to a bug in KNetworkManager. I can see the network but I can't connect. I did a little research on the net and I was told that it is basically a bug within knetworkmanager. So I wondered when the net release is going to be released.

Mat
hunt_mat
Growing Hen
 
Posts: 158
Joined: Mon Mar 05, 2007 20:08

Re: wireless stops at 28% and then fails to connect

Postby mbmalone » Sat Sep 15, 2007 21:13

Thank you for telling me this is a bug. It ends up locking my notebook and pissing me off. This is the 2nd Sabayon DVD I have downloaded 3.4e and now 3.4f, with the identical problem. I get tired of downloading DVD's that keep locking up my system. I hope this is fixed and they post that it is fixed in the next release. 28% and holding, doesn't even ask me for the WEP key. :(
Michael
mbmalone
Baby Hen
 
Posts: 6
Joined: Sat Aug 25, 2007 16:59

Re: wireless stops at 28% and then fails to connect

Postby mdmarmer » Mon Sep 17, 2007 3:35

You could try emerging
wifi-radar

There's also
net-setup
(Sabayon script to set up your connection)
mdmarmer
Advanced Hen
 
Posts: 240
Joined: Thu Oct 19, 2006 1:46
Location: dayton OH usa

Re: wireless stops at 28% and then fails to connect

Postby hunt_mat » Tue Sep 18, 2007 17:06

Okay, wifi-radar installs fine and I can get the thing running and find a network. I get the following error message (I am setting the IP by DCHP)

wlan0 Failed to read scan data : Resource temporarily unavailable

wlan0 Failed to read scan data : Resource temporarily unavailable

Error for wireless request "Set Nickname" (8B1C) :
SET failed on device wlan0 ; Operation not supported.
SIOCSIFNETMASK: Cannot assign requested address
SIOCADDRT: Invalid argument
wlan0 Failed to read scan data : Resource temporarily unavailable

wlan0 Failed to read scan data : Resource temporarily unavailable

wlan0 Failed to read scan data : Resource temporarily unavailable

Is there a way to get this done as soon as the laptop boots up?

Mat
hunt_mat
Growing Hen
 
Posts: 158
Joined: Mon Mar 05, 2007 20:08

Re: wireless stops at 28% and then fails to connect

Postby WarraWarra » Wed Sep 19, 2007 2:27

:shock:
Does anyone in the post so far actually own a wifi card as no one bothered to mention what wifi cards they are using so no one can provide actual correct info to try and fix this bug if it is a bug.

Thanks for the guys trying to help so far.

If you want to chit chat about Sabayon use the general chat part of the forum if off topic / not Sabayon related use Off Topic part of the forum. If you are frustrated get a penthouse magazine and disappear for 20 secs or go to the gym and unload.

Currently it looks like no one posting is serious about finding a fix for their wifi problem. Come one guys throw the dog a freaking bone / info.

Knetworkmanager is working for sometime already likely from 3.4A if not before. It had bugs but has been fixed otherwise I would not be typing here now.
AS for drivers / firmware the latest ones should work but if they have bugs then the developers of that drivers is to blame not Sabayon , use the alternative drivers or ndiswrapper or manually connect iwconfig or similar ??

We just get the stuff from our local supermarket / gentoo.org / source code and put them together. If one item has a bug then gentoo can try and fix it or send the broken / info about broken back to the developer / maker of the product and we wait on them to fix it. Compiz /glx. See a post viewtopic.php?f=3&t=9595 .

If you say I have a dell 1390 wifi card and it looks like it might be bcm4311mcg card then hey we can help. If not posting this vital info we can not help you.

Right now I am typing this on 3.4f with bcm4311mcg and knetworkmanager using WPA2 + tkip + password and I connected to the internet.
This works in 3.4E and earlier version depending on version some minor tweaks had to be done to get it to work = buggy drivers = the normal stuff you do in any other linux / Os even in windows 5 hours later and 2 installs later , why all the complaining ? Even in PcLinuxOs2007 rpm distro the closest thing to Sabayon and 10milj times more advanced than Vista you have to install and update several thing and that is one of the few distro's that work of off the cd + some driver installs. Sabayon is less driver install needed but not tested on all hardware.

Has anyone tried this link ?
viewtopic.php?f=52&t=8933

Did anyone find the posts about dhcp and its bugs and checked your against this or updated it using a cable to your router to get internet if it is out of date ?

Come one guys get serious and stop fooling around. No one can help you if you do not read a bit or give hardware info. Also we have about 10 guys doing the development not 100 000 like windows so expect some bumps in the road. I had to fix several thing myself and learned a lot why not anyone else. Also if it is a bug and it can done again with same results then it can be fixed or blocked from next release but we would not know if the hardware info or how you got to this bug is not posted ??

mbmalone :roll:
If you have tried to find the bug then you would have seen the readme file on the iso / dvd and then used this cheat codes or searched the forums / wiki top right side of this page for answers.
Chill mate the guys doing this to help us is doing it for free and if you donated then it is for the servers to host this webpage so say thanks and use the search function. No one is getting payed for this work you are complaining about.
Do yourself a favor and just get the gentoo live cd or dvd and then you would cry or build your own linux from source using the gentoo how-to pages ? O it takes close to 20+ hours enjoy. The you still have to GCC and KDE and Office by the 3rd day you will be angry if new to this.
I posted close to if not more than 20 times about cheat codes have you tried them ?
If you do not understand something say hey guys I have a problem it gets stuck during boot, reply = have you checked the md5 of the download ? Did you try in windows + virtualbox to run the iso file and test it is it working in there , if yes then good iso , next is the dvd good again virtualbox + dvd disk boot = good or not as nero does have a bug and tehy promised me they would be fixing it.

Once you have a good working disk then try the cheat codes.

We are here to help but just chill mate. We are not the enemy.
WarraWarra
Sagely Hen
 
Posts: 1989
Joined: Wed Jan 03, 2007 21:01
Location: 31.324270, -113.585511

Re: wireless stops at 28% and then fails to connect

Postby ibendiben » Wed Oct 03, 2007 6:05

With me, the problem was the wep passphrase. I had to select HEX! Then after two times it will connect properly.
The thing is every time I reboot I get the same problem, I select my network, fill in the wep and change to HEX! But the first time it hangs at 28% or 57% then it fails. When I try the second time it works :|
ibendiben
Baby Hen
 
Posts: 8
Joined: Mon Oct 01, 2007 10:34

Re: wireless stops at 28% and then fails to connect

Postby ibendiben » Wed Oct 03, 2007 12:48

Ok I've been fiddling around yet more. And crossed a couple of advises on this forum for previous versions of sabayon.
This is what worked for me:

Go to knetworkmanager and quit it, when it asks if you still want to start it automatically at boot choose no. (never again!)
Then run a root shell and type:

net-setup

A wizard will be started. Choose your wireless device and fill in you ssid and encryption if needed. When your done type:

rc-update add net.eth1 default <----------- make sure you change eth1 in your device name if needed!

To start the default network automatically at boot.
Now restart the computer... and start your browser. Hopefully you start page is loaded...
ibendiben
Baby Hen
 
Posts: 8
Joined: Mon Oct 01, 2007 10:34

Re: wireless stops at 28% and then fails to connect

Postby WarraWarra » Thu Oct 04, 2007 5:22

To make it permanent after reboot see the networking part of the forum " before 3.4e ipw3945 ...." sticky on top and in there is link if not the actual way to get it permanent .

Rc-update and kernel-2.6 I think is the key to make it permanent and autostart .

This should help.

I think the linux drivers while still in testing / unstable but working format need a bit of fine tunning to be able to performa the same as the windows ones but that would happen at each of their developers with our help / input.
Case = windows now connected to wifi in hotel but switch over to linux the noise / signal is too much for a stable connection = drivers. It does not clear up the signal as good as in windows but they are likely fixing it.

Weard that you can not just right click knetwork and conenct + wep / wpa /wpa2 + passphrase but depends on channel / noise with the signal.
WarraWarra
Sagely Hen
 
Posts: 1989
Joined: Wed Jan 03, 2007 21:01
Location: 31.324270, -113.585511

Re: wireless stops at 28% and then fails to connect

Postby bifrost » Thu Oct 04, 2007 9:08

I had a problem that looked just like this. The solution was that my security key was in Hex. Eventually, I thought it through and, when the box asked for a WEP key, I chose the Hex option instead and 'it just worked'.
...just an idea!

bifrost (still fluffy and yellow)
bifrost
Baby Hen
 
Posts: 5
Joined: Sun Mar 11, 2007 20:43

Previous

Return to Networking and Wireless

Who is online

Users browsing this forum: No registered users and 1 guest