layman.config error [Solved]

Anything that pertains to Portage

Moderator: Moderators

layman.config error [Solved]

Postby neofax » Wed Sep 05, 2007 16:10

I have been trying to update my system for two days and I have run into one problem after the other, but have fixed them so far using the forums. This one I cannot find a solution to:

Traceback (most recent call last):
File "/usr/bin/layman", line 23, in <module>
from layman.config import Config
ImportError: No module named layman.config

I have checked and there is no layman.config file. The closest is layman.cfg in /etc. I tried changing the file to pint to this layman.cfg and receive the same error. Where should I look for these module files? Thanks!
neofax
Young Hen
 
Posts: 20
Joined: Tue Sep 04, 2007 19:21

Re: layman.config error

Postby DontPanic » Wed Sep 05, 2007 17:41

Have you tried re-emerging layman yet ? I'd start there.
Code: Select all
emerge --ask -v layman
Gigabyte GA-P35-DS3L - Intel(R) Core(TM)2 Duo CPU E6750@ 2.66GHz
nVidia GeForce 7600 GS
2 GB RAM
DontPanic
Old Dear Hen
 
Posts: 742
Joined: Mon Jul 09, 2007 20:29
Location: Mobile, AL, USA

Re: layman.config error

Postby neofax » Wed Sep 05, 2007 19:06

OK, I have figured out the underlying cause to this problem. During my emerge -e system, python-2.5 has been installed. OK, so I go to run python-updater as stated elsewhere on these forums. Now I have a problem with Coherence. It is installed as 0.2.1 version, but that ebuild is no longer available. What do I do to correct this?
neofax
Young Hen
 
Posts: 20
Joined: Tue Sep 04, 2007 19:21

Re: layman.config error

Postby BlueJayofEvil » Wed Sep 05, 2007 19:31

I had that problem awhile back. I unmerged then re-emerged layman. Didn't give me any problems after that.
BlueJayofEvil
Growing Hen
 
Posts: 183
Joined: Tue Jun 12, 2007 3:30
Location: Minnesota, USA

Re: layman.config error

Postby DontPanic » Wed Sep 05, 2007 20:07

Re: Coherence

It sounds like you need to rebuild your Sabayon overlay.

dev-python/Coherence-0.2.1 is available in the Sabayon overlay.

Try (note the capital 'S'):
Code: Select all
layman -S


If that doesn't work, delete and rebuild the Sabayon overlay.
Code: Select all
layman -d sabayon
layman -a sabayon
Gigabyte GA-P35-DS3L - Intel(R) Core(TM)2 Duo CPU E6750@ 2.66GHz
nVidia GeForce 7600 GS
2 GB RAM
DontPanic
Old Dear Hen
 
Posts: 742
Joined: Mon Jul 09, 2007 20:29
Location: Mobile, AL, USA

Re: layman.config error

Postby neofax » Wed Sep 05, 2007 20:43

Thanks DontPanic!!! That got me further down the road. Now vte is erroring out with:

--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE = "/var/log/sandbox/sandbox-x11-libs_-_vte-0.16.8-1585.log"

unlink: /usr/share/pygtk/2.0/codegen/argtypes.pyc
unlink: /usr/share/pygtk/2.0/codegen/definitions.pyc
unlink: /usr/share/pygtk/2.0/codegen/defsparser.pyc
unlink: /usr/share/pygtk/2.0/codegen/scmexpr.pyc
unlink: /usr/share/pygtk/2.0/codegen/override.pyc
unlink: /usr/share/pygtk/2.0/codegen/reversewrapper.pyc
--------------------------------------------------------------------------------

How do I fix this?
neofax
Young Hen
 
Posts: 20
Joined: Tue Sep 04, 2007 19:21

Re: layman.config error

Postby DontPanic » Wed Sep 05, 2007 20:52

It looks like those files are part of the pygtk package. Try re-emerging that package.
Code: Select all
emerge --ask -v dev-python/pygtk
Gigabyte GA-P35-DS3L - Intel(R) Core(TM)2 Duo CPU E6750@ 2.66GHz
nVidia GeForce 7600 GS
2 GB RAM
DontPanic
Old Dear Hen
 
Posts: 742
Joined: Mon Jul 09, 2007 20:29
Location: Mobile, AL, USA

Re: layman.config error

Postby neofax » Wed Sep 05, 2007 21:30

OK, I did that and I receive the following warnings:

* Messages for package dev-python/pygtk-2.10.4:

* Unable to establish /usr/lib/python2.5/site-packages/pygtk.py symlink
* Unable to establish /usr/lib/python2.5/site-packages/pygtk.pth symlink
* GNU info directory index is up-to-date.

How do I create the symlinks?
neofax
Young Hen
 
Posts: 20
Joined: Tue Sep 04, 2007 19:21

Re: layman.config error

Postby DontPanic » Wed Sep 05, 2007 22:58

I did a basic google on:
Unable to establish /usr/lib/python2.5/site-packages/pygtk.py symlink


and came across the following gentoo discussion: http://forums.gentoo.org/viewtopic-t-575963-start-0-postdays-0-postorder-asc-highlight-pygtk.html

They suggest re-emerging pygobject.
Gigabyte GA-P35-DS3L - Intel(R) Core(TM)2 Duo CPU E6750@ 2.66GHz
nVidia GeForce 7600 GS
2 GB RAM
DontPanic
Old Dear Hen
 
Posts: 742
Joined: Mon Jul 09, 2007 20:29
Location: Mobile, AL, USA

Re: layman.config error

Postby neofax » Thu Sep 06, 2007 0:51

This is going to be the longest thread ever! OK, little further along the update trail. This makes me feel stupid. I have been using Linux for forever and this takes the cake on getting to know your system. Here is the new dilemma:

* Cannot find $EPATCH_SOURCE! Value for $EPATCH_SOURCE is:
*
* /usr/portage/gnome-base/gnome-session/files/gnome-session-2.17.90-no-asserts.patch
* ( gnome-session-2.17.90-no-asserts.patch )

*
* ERROR: gnome-base/gnome-session-2.18.3 failed.
* Call stack:
* ebuild.sh, line 1654: Called dyn_unpack
* ebuild.sh, line 768: Called qa_call 'src_unpack'
* ebuild.sh, line 44: Called src_unpack
* gnome-session-2.18.3.ebuild, line 52: Called epatch '/usr/portage/gnome-base/gnome-session/files/gnome-session-2.17.90-no-asserts.patch'
* eutils.eclass, line 161: Called die

I have tried just downloading the file by emerge -f gnome-session, which didn't work. Tried deleting the gnome-session directory and emerge --sync. I am almost bald now. Any help please??? :evil:

SOLVED this portion
Just needed to do layman -S to pull in some overlay.
neofax
Young Hen
 
Posts: 20
Joined: Tue Sep 04, 2007 19:21


Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: No registered users and 2 guests

cron