new laptop: getting compiz working

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

Post Reply
Baby Hen
Posts: 2
Joined: Mon Sep 03, 2007 1:31

new laptop: getting compiz working

Post by slade » Mon Sep 03, 2007 2:26

I've been a linux user for a year or two but this is my first time using gentoo or sabayon (successfully, and outside of vmware). I'm completely new to portage, so I don't know all that much about the package management, but I'm learning. anyway, the sabayon live dvd worked fine and had desktop acceleration, but I can't get it working on the install. I emerged beryl, as ~6 months ago it was better than compiz, then I realized beryl was merged back into compiz so i got rid of it. however, I can't start compiz. if I enter compiz-start into a terminal I get a window that says "compiz issues" and then:

Code: Select all

Compiz cannot be started. Please check that you have a working and supported Video Card, OpenGL functionality or visit Sabayon Linux Support forum at:

Current Graphics Processing Unit
nVidia Corporation Unknown device 040c (rev a1)
I would post the exact nvidia card but honestly, I don't know what it is. this is a lenovo T61p workstation laptop with a WUXGA screen. I got it right when the T61p shipped, and apparently they discontinued the WUXGA screen and its related 512 mb video card. the WSXGA+ related card comes with, according to their site, a "NVIDIA Quadro FX 570M (256MB Open GL)"

I would post this in the thread "if XGL/AIGLX don't work, write here.", but I don't know if this videocard is supported (I would assume so because its nvidia, and the livecd worked) and I don't know if I'm missing something obvious.

if it helps, I'm using sabayon 3.4e.

Code: Select all

localhost ~ # eselect opengl show
and remember, if you're going to say RTFM

Code: Select all

...or visit Sabayon Linux Support forum at:
i did read the manual, and it told me to ask you guys <.<

User avatar
Young Hen
Posts: 34
Joined: Sun Aug 19, 2007 22:34

Re: new laptop: getting compiz working

Post by Belial » Mon Sep 03, 2007 2:43

have you used the acceleration manager to select the method of desktop composition, can you also paste the content of your /etc/xorg.conf file here :)

Edit: pasting all the infromation thats requested here would be helpful ... =53&t=2444

Post Reply