error trying to do world update

Anything that pertains to Portage

Moderator: Moderators

error trying to do world update

Postby pajamabama » Sun Sep 02, 2007 4:03

I'm attempting to follow the instructions on the wiki regarding doing world update. I get to the point of trying to do the world update and get this
Code: Select all
Oberon ~ # emerge -uN --world
>>> cfg-update-1.8.0-r6: No new packages have been emerged, checksum index OK!
Calculating world dependencies -
!!! Ebuilds for the following packages are either all
!!! masked or don't exist:
media-plugins/gst-plugins-dts media-plugins/gst-plugins-mikmod media-libs/gst-plugins media-plugins/gst-plugins-dvdnav

... done!

!!! Error: the <app-accessibility/festival-1.96_beta package conflicts with another package;
!!!        the two packages cannot be installed on the same system together.
!!!        Please use 'emerge --pretend' to determine blockers.

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked

Oberon ~ # 

I've tried masking that app-accessibility package but that doesn't seem to help. Anyone got any ideas what's going on here?

Thanks.
HP dv6000t
SabayonLinux 5.5 - x86_64

www.pedorro.com
pajamabama
Growing Hen
 
Posts: 161
Joined: Sun Jan 07, 2007 22:05
Location: In another time's forgotten space.

Re: error trying to do world update

Postby wolfden » Sun Sep 02, 2007 6:03

moved to correct forum

do as it tells ya
Please use 'emerge --pretend' to determine blockers.


take care of the blockers
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: error trying to do world update

Postby multi » Sun Sep 02, 2007 6:46

as easy as that eh?
Code: Select all
These are the packages that would be merged, in order:

Calculating world dependencies -
!!! All ebuilds that could satisfy ">=app-text/poppler-bindings-0.5.91" have been masked.
!!! One of the following masked packages is required to complete your request:
- app-text/poppler-bindings-0.5.91 (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Stefan Schweizer <genstef@gentoo.org> (31 May 2007)
# release candidate


For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.
(dependency required by "app-text/evince-0.9.3" [ebuild])



!!! Problem resolving dependencies for app-text/evince
!!! Depgraph creation failed.

I have tried adding
>=app-text/poppler-bindings-0.5.91
to the .keywords file

no change

I have tried

emerge -C app-text/evince

I see it unmerge but this changes nothing

even after a revdep rebuild , no change

ok ... I have always had problems with this damn package
off and on for at least the last year

any advice?




edit:
Missing keyword

If portage says: "masked by: missing keyword" while emerging, it means that the packages isn't available for your architecture yet, i.e. you are running x86_64 and the package has for instance "x86" keyword only. If you really need that package, then you can try: echo "category/package x86 ~x86" >> /etc/portage/package.keywords to override it for package in a category. (Note: I've used the unstable "~x86" since the rest of Sabayon is running with unstable keywords anyway). As Gentoo is source based there's good chance of package compiling and working without modifications.

More info here: http://gentoo-wiki.com/Masked
_______________________
/etc/portage/package.keywords

This file is used to run unstable packages on stable systems or ebuilds that haven't been tested on your platform. This file isn't that important to Sabayon users, but gentoo-wiki.com has more information if you are interested.


ok sorry I missed that bit..

but what to do with (masked by: package.mask)
multi
Baby Hen
 
Posts: 11
Joined: Fri Aug 24, 2007 4:21

Re: error trying to do world update

Postby wolfden » Sun Sep 02, 2007 16:27

you should just be able to add to package.unmask
>=app-text/poppler-bindings-0.5.91
=app-text/poppler-0.5.91
=app-text/evince-0.9.3

Like it says:
http://gentoo-wiki.com/Masked
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: error trying to do world update

Postby pajamabama » Sun Sep 02, 2007 16:44

So I'm not sure what this means. I'm getting the same problem with another package (I unmerged and remerged the first problem one and that somehow fixed it). When I --pretend it, this is what I get:

Code: Select all
Oberon ~ # emerge -uN --world
>>> cfg-update-1.8.0-r6: Building checksum index... (takes a few seconds) done!
Calculating world dependencies -
!!! Ebuilds for the following packages are either all
!!! masked or don't exist:
media-plugins/gst-plugins-dts media-plugins/gst-plugins-mikmod media-libs/gst-plugins media-plugins/gst-plugins-dvdnav

... done!

!!! Error: the <net-print/hplip-1.7.4a-r1 package conflicts with another package;
!!!        the two packages cannot be installed on the same system together.
!!!        Please use 'emerge --pretend' to determine blockers.

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked

Oberon ~ # emerge -p hplip
>>> cfg-update-1.8.0-r6: No new packages have been emerged, checksum index OK!

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] net-print/hplip-1.6.10
Oberon ~ # emerge -up net-print/hplip
>>> cfg-update-1.8.0-r6: No new packages have been emerged, checksum index OK!

These are the packages that would be merged, in order:

Calculating dependencies... done!
Oberon ~ #


In the world update it wants to move it to a new version and gives me conflicts. If I just try to update that package it says there's nothing to do. Notice world update refers to v1.7.4a-r1 while otherwise it refers to v-1.6.10, which is already installed.

Code: Select all
Oberon ~ # emerge -s hplip
>>> cfg-update-1.8.0-r6: No new packages have been emerged, checksum index OK!
Searching...
[ Results for search key : hplip ]
[ Applications found : 1 ]

*  net-print/hplip
      Latest version available: 1.6.10
      Latest version installed: 1.6.10
      Size of files: 10,410 kB
      Homepage:      http://hplip.sourceforge.net/
      Description:   HP Linux Imaging and Printing System. Includes net-print/hpijs, scanner drivers and service tools.
      License:       GPL-2


Oberon ~ # 


what does this mean? Why doesn't the normal upgrade see the new version? I can't see what's blocking it.

ps. sorry about posting to the wrong forum
HP dv6000t
SabayonLinux 5.5 - x86_64

www.pedorro.com
pajamabama
Growing Hen
 
Posts: 161
Joined: Sun Jan 07, 2007 22:05
Location: In another time's forgotten space.

Re: error trying to do world update

Postby wolfden » Sun Sep 02, 2007 16:54

weird, could try equery depends hplip to see what pulls it

you could just try masking anything higher than your current version too. It might than spit out what needs that version. I don't need hplip since I don't have a hp printer so I just emerge -C hplip from the very get go.
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: error trying to do world update

Postby pajamabama » Sun Sep 02, 2007 17:11

well, looking on the gentoo wiki, it appears that I could use the more limited package hpijs instead. This might be a simple way around, if not really a solution. I only print maybe 3 pages a year but it is an HP. Although I hate the idea of limiting functionality that should be there (even if I never use it :mrgreen: ). I have a lappy, I like to know I can take it places and make it work.
HP dv6000t
SabayonLinux 5.5 - x86_64

www.pedorro.com
pajamabama
Growing Hen
 
Posts: 161
Joined: Sun Jan 07, 2007 22:05
Location: In another time's forgotten space.

Re: error trying to do world update

Postby wolfden » Sun Sep 02, 2007 18:27

well keep in mind to with portage, it's always changing. A emerge --sync tomorrow can make a lot of problems go away too, of course it can add more too.
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: error trying to do world update

Postby multi » Mon Sep 03, 2007 14:46

wolfden wrote:you should just be able to add to package.unmask
>=app-text/poppler-bindings-0.5.91
=app-text/poppler-0.5.91
=app-text/evince-0.9.3

Like it says:
http://gentoo-wiki.com/Masked


Thanks!
multi
Baby Hen
 
Posts: 11
Joined: Fri Aug 24, 2007 4:21


Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: No registered users and 1 guest