emerge --sync breaks my system [Solved]

Anything that pertains to Portage

Moderator: Moderators

emerge --sync breaks my system [Solved]

Postby kodfish » Sat Sep 01, 2007 19:18

So, as the first thing i did after installing Sabyon was to update portage, via an emerge --sync. then, instead the usual emerge portage blah blah updates whoo i get this fine and dandy error.

!!! ARCH is not set... Are you missing the '/etc/make.profile' symlink?
!!! Is the symlink correct? Is your portage tree complete?

i've checked, and this looks to be in order:

Constantine kod # ls -l /etc/make.profile
lrwxrwxrwx 1 root root 48 2007-09-01 03:09 /etc/make.profile -> ../usr/portage/profiles/default-linux/x86/2006.0

well, i just managed to fix it in the middle of my post, let me show you what i did:

Constantine kod # rm /etc/make.profile
Constantine kod # ln -s /usr/portage/profiles/default-linux/x86/2007.0/ /etc/make.profile

notice it points to 2007.0 now. hmm. i don't know why i didn't try that last night... >:\ i ended up reinstalling
Baby Hen
Posts: 4
Joined: Sat Sep 01, 2007 19:10

Re: emerge --sync breaks my system [Solved]

Postby Belial » Sun Sep 02, 2007 22:20

the recommended way to do this would have been to
Code: Select all
eselect profile list
then choosing your profile (usually 2007.0) and replacing the # with the approriate number
Code: Select all
eselect profile set #

User avatar
Young Hen
Posts: 34
Joined: Sun Aug 19, 2007 22:34

Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: No registered users and 1 guest