Sabayon v3.4e - Problems with gimp [Solved]

Anything that pertains to Portage

Moderator: Moderators

Sabayon v3.4e - Problems with gimp [Solved]

Postby tekwyzrd » Mon Aug 20, 2007 3:39

I installed gimp v2.3.19. and now am unable to open .png or .jpg files. Odd. It worked fine in Sabayon v3.3 I googled for a possible answer and the only thing suggested was the possibility that png and jpeg flags might be missing in the ebuild. The flags are there. Then I tried v2.4-rc1. Emerge failed as follows:

jpegqual.o: In function `main':
jpegqual.c:(.text+0x5ae): undefined reference to `jpeg_std_error'
jpegqual.c:(.text+0x5c4): undefined reference to `jpeg_CreateDecompress'
jpegqual.c:(.text+0x5d2): undefined reference to `jpeg_stdio_src'
jpegqual.c:(.text+0x5dc): undefined reference to `jpeg_read_header'
jpegqual.c:(.text+0x8aa): undefined reference to `jpeg_destroy_decompress'
collect2: ld returned 1 exit status
make[3]: *** [jpegqual] Error 1
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2
*
* ERROR: media-gfx/gimp-2.4.0_rc1 failed.
* Call stack:
* ebuild.sh, line 1654: Called dyn_compile
* ebuild.sh, line 990: Called qa_call 'src_compile'
* ebuild.sh, line 44: Called src_compile
* gimp-2.4.0_rc1.ebuild, line 99: Called die
*
* emake failed
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/tmp/portage/media-gfx/gimp-2.4.0_rc1/temp/build.log'.

Downgraded gimp to v2.2.17 with the same results as v2.3.19. Unable to open or save .jpg or .png. :(

Suggestions?
Last edited by tekwyzrd on Mon Aug 20, 2007 9:08, edited 1 time in total.
Former Sabayon user (2005 - 2013) and current Arch user.
I liked Sabayon until it switched to Rigo and becoming the gentoo equivalent of Ubuntu. Extreme browsing? Extreme gaming? Extreme work? Extreme development? Like, totally gnarly, dude!
tekwyzrd
Technological Hen
 
Posts: 331
Joined: Tue Aug 22, 2006 23:56
Location: Northeastern Ohio

Re: Sabayon v3.4e - Problems with gimp

Postby wolfden » Mon Aug 20, 2007 4:58

what does

emerge -pv gimp show for flags?

here is mine

Code: Select all
wolfden wolfden # emerge -pv gimp

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] media-gfx/gimp-2.4.0_rc1  USE="aalib alsa dbus gnome jpeg mng pdf png python svg tiff wmf (-altivec) -curl -debug -doc -gtkhtml -lcms -mmx -smp -sse" 0 kB
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: Sabayon v3.4e - Problems with gimp

Postby tekwyzrd » Mon Aug 20, 2007 7:16

Code: Select all
# emerge -pv gimp

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ] media-gfx/gimp-2.4.0_rc1 [2.2.17] USE="aalib alsa%* dbus%* gnome%* mmx mng pdf%* python svg tiff wmf (-altivec) -curl% -debug -doc -gtkhtml -jpeg -lcms -png -smp -sse (-gimpprint%*) (-hardened%)" 0 kB

Total: 1 package (1 upgrade), Size of downloads: 0 kB


If I'm interpreting this correctly something is telling it NOT to use jpeg and png. I don't understand why.
Former Sabayon user (2005 - 2013) and current Arch user.
I liked Sabayon until it switched to Rigo and becoming the gentoo equivalent of Ubuntu. Extreme browsing? Extreme gaming? Extreme work? Extreme development? Like, totally gnarly, dude!
tekwyzrd
Technological Hen
 
Posts: 331
Joined: Tue Aug 22, 2006 23:56
Location: Northeastern Ohio

Re: Sabayon v3.4e - Problems with gimp

Postby wolfden » Mon Aug 20, 2007 8:33

missing use flags in the /etc/make.conf

try adding the png jpeg to it than try
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: Sabayon v3.4e - Problems with gimp

Postby tekwyzrd » Mon Aug 20, 2007 9:06

wolfden wrote:missing use flags in the /etc/make.conf

try adding the png jpeg to it than try


Thanks. I just finished doing that and was writing a message to post when I opened another tab and saw this. After my previous post I did some more googling and in the process it occurred to me that there might be a problem with make.conf. After adding jpeg and png to /etc/make.conf (shouldn't it be there already?) emerge was successful and I now have a working gimp v2.4 able to open .png and .jpg files.
Former Sabayon user (2005 - 2013) and current Arch user.
I liked Sabayon until it switched to Rigo and becoming the gentoo equivalent of Ubuntu. Extreme browsing? Extreme gaming? Extreme work? Extreme development? Like, totally gnarly, dude!
tekwyzrd
Technological Hen
 
Posts: 331
Joined: Tue Aug 22, 2006 23:56
Location: Northeastern Ohio

Re: [SOLVED]Sabayon v3.4e - Problems with gimp

Postby wolfden » Mon Aug 20, 2007 9:09

yes it should be there, but for some reason 3.4 went out the door missing critical use flags. I always copy over my same use flags from install to install.
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: [SOLVED]Sabayon v3.4e - Problems with gimp

Postby tekwyzrd » Mon Aug 20, 2007 9:15

wolfden wrote:yes it should be there, but for some reason 3.4 went out the door missing critical use flags. I always copy over my same use flags from install to install.


I'll have to remember that. Thanks for the help, and the tip.
Former Sabayon user (2005 - 2013) and current Arch user.
I liked Sabayon until it switched to Rigo and becoming the gentoo equivalent of Ubuntu. Extreme browsing? Extreme gaming? Extreme work? Extreme development? Like, totally gnarly, dude!
tekwyzrd
Technological Hen
 
Posts: 331
Joined: Tue Aug 22, 2006 23:56
Location: Northeastern Ohio

Re: Sabayon v3.4e - Problems with gimp [Solved]

Postby multi » Sat Aug 25, 2007 12:50

yeh.. good one
that helped a lot

not keen on many of the changes made to this program since 2.2

why take color adjustment out of the layer options

script fu has practically vanished
wth..

can someone tell me if gimpshop is available through portage
(I cant seem to find it)

the best way to install it in this Linux?
:cyclops:
multi
Baby Hen
 
Posts: 11
Joined: Fri Aug 24, 2007 4:21

Re: Sabayon v3.4e - Problems with gimp [Solved]

Postby eshum » Sat Aug 25, 2007 19:04

Gimp shop would be a nice addition to Sabayon.
ed
eshum
Technological Hen
 
Posts: 312
Joined: Tue Feb 20, 2007 20:42
Location: Oregon

Re: Sabayon v3.4e - Problems with gimp [Solved]

Postby BlueJayofEvil » Sun Sep 02, 2007 3:23

multi wrote:can someone tell me if gimpshop is available through portage
(I cant seem to find it)


It's available in the zugaina overlay. You can find a list of ebuilds in that overlay ->here<-
BlueJayofEvil
Growing Hen
 
Posts: 183
Joined: Tue Jun 12, 2007 3:30
Location: Minnesota, USA


Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: No registered users and 1 guest