Make widgets (karamba) appear on all desktops + extras ...

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

Make widgets (karamba) appear on all desktops + extras ...

Postby dave_p_b » Sun Aug 12, 2007 1:03

Hi

Just thought I would share this tip with you all as it's been bugging me for weeks.

I had two problems regarding superkaramba widgets and compiz-fusion.
1) My Superkaramba widgets would only display on desktop one.
2) If I clicked on the Show Desktop icon, my widgets would minimize them selves along with all other windows.

Solution:

1) Open up CompizConfig Settings Manager (ccsm)
2) Ensure that the Regex Matching plugin is enabled in the Utility group.
3) Enable the Window Rules plugin in the Window Management group and click on it. You will then be presented with a tab called "Matches" and lots of empty values.
4) Enter the value "class=Superkaramba & type=dock" (without quotes) into the following three boxes: Below, Sticky and non minimizable Windows


You should now have your superkaramba widgets on all four desktops, and when you click the Show Desktop icon, they wont disappear.

Note: This can be done for Gnome widgets too. You can find the original thread here.

All the best

Dave
dave_p_b
Old Dear Hen
 
Posts: 607
Joined: Fri Dec 15, 2006 1:39
Location: Exeter, UK

Re: Make widgets (karamba) appear on all desktops + extras ...

Postby Lucidor » Mon Aug 20, 2007 17:31

That worked like a charm!

Did you also find a way to make it autostart in combination with Compiz Fusion? Before I switched to Sabayon, the method I used was to simply check the "restore previous session", but as far as I understand, it is not recommended.
Lucidor
Young Hen
 
Posts: 25
Joined: Sun Jul 29, 2007 18:25
Location: Solna, Sweden

Re: Make widgets (karamba) appear on all desktops + extras ...

Postby PAdu92 » Mon Aug 20, 2007 17:50

thanks!
PAdu92
Simple Hen
 
Posts: 41
Joined: Fri Aug 17, 2007 14:03

Re: Make widgets (karamba) appear on all desktops + extras ...

Postby ashley194 » Mon Aug 20, 2007 21:39

Your advice worked perfectly, many thanks 8)
ashley194
Technological Hen
 
Posts: 321
Joined: Mon Feb 19, 2007 21:54
Location: Manchester, UK.

Re: Make widgets (karamba) appear on all desktops + extras ...

Postby Lucidor » Fri Aug 24, 2007 18:15

So... no comments on the launching?

How do you guys start SuperKaramba, by manual or do you have a way to automate it? My problem is that I know how to automagically start programs in general, but this fellow needs to be started after the 3D desktop thingy, which makes things more complicated.

Any advice would be appreciated! Should I initiate a new thread?
Lucidor
Young Hen
 
Posts: 25
Joined: Sun Jul 29, 2007 18:25
Location: Solna, Sweden

Re: Make widgets (karamba) appear on all desktops + extras ...

Postby keteflips » Tue Oct 02, 2007 19:40

Thanks it works perfect :mrgreen:
keteflips
Growing Hen
 
Posts: 147
Joined: Mon Mar 19, 2007 19:24

Re: Make widgets (karamba) appear on all desktops + extras ...

Postby Stupot » Wed Oct 03, 2007 0:24

c0nv1ct wrote:Taken from the Superkaramba Handbook:

How do I set up my themes to run automatically on startup?
Turn on KDE session support in the KDE Control Center. When session
support is enabled, any theme that is left running when you logout will
automatically start on startup. For some themes you will also need to
right mouse button click and reload the theme at least once after running
it so that the config file will get written to your home directory.Another
solution is to create a desktop config file in the KDE autostart directory.To
create a desktop config file, open an editor and enter the following:

[ Desktop Entry ]
Exec = superkaramba { location of theme file }. theme
Name ={ theme name }
Type = Application
X -KDE - StartupNotify = false
Then save it as themename.desktop into the autostart directory at $KDE-
HOME/Autostart/.
Stupot
Sagely Hen
 
Posts: 1537
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: Make widgets (karamba) appear on all desktops + extras ...

Postby frankifol » Sun Nov 11, 2007 1:36

Lucidor wrote:That worked like a charm!

Did you also find a way to make it autostart in combination with Compiz Fusion? Before I switched to Sabayon, the method I used was to simply check the "restore previous session", but as far as I understand, it is not recommended.



I have the same problem....lokk my last post here "http://www.sabayonlinux.org/forum/viewtopic.php?f=53&t=10692&p=65892#p65892". Maybe it could help
frankifol
Simple Hen
 
Posts: 52
Joined: Thu Nov 30, 2006 13:43


Return to 3D Desktops and Window Managers

Who is online

Users browsing this forum: No registered users and 1 guest

cron