Amarok - xine-lib error during compile [Solved]

Anything that pertains to Portage

Moderator: Moderators

Amarok - xine-lib error during compile [Solved]

Postby Zinden » Mon Aug 13, 2007 21:00

here is a part of the error message:
Code: Select all
In file included from ffmpeg_encoder.c:44:
/usr/include/ffmpeg/avcodec.h:2252: warning: 'ImgReSampleContext' is deprecated
/usr/include/ffmpeg/avcodec.h:2258: warning: 'ImgReSampleContext' is deprecated
ffmpeg_encoder.c: In function 'dxr3_encoder_init':
ffmpeg_encoder.c:79: error: 'mpeg1video_encoder' undeclared (first use in this function)
ffmpeg_encoder.c:79: error: (Each undeclared identifier is reported only once
ffmpeg_encoder.c:79: error: for each function it appears in.)
make[4]: *** [xineplug_decode_ff_la-ffmpeg_encoder.lo] Fel 1
make[4]: *** Inväntar oavslutade jobb...
make[3]: *** [all-recursive] Fel 1
make[2]: *** [all-recursive] Fel 1
make[1]: *** [all-recursive] Fel 1
make: *** [all] Fel 2

!!! ERROR: media-libs/xine-lib-1.1.7 failed.
Call stack:
  ebuild.sh, line 1621:   Called dyn_compile
  ebuild.sh, line 973:   Called qa_call 'src_compile'
  ebuild.sh, line 44:   Called src_compile
  xine-lib-1.1.7.ebuild, line 175:   Called die

!!! emake failed.
!!! If you need support, post the topmost build error, and the call stack if relevant.
!!! A complete build log is located at '/var/tmp/portage/media-libs/xine-lib-1.1.7/temp/build.log'.


This was when i tried to install latest Amarok. Then i tried to install only xine-lib-1.1.7 but failed too.

Any suggestions?
Last edited by Zinden on Tue Aug 14, 2007 7:43, edited 2 times in total.
Zinden
Baby Hen
 
Posts: 18
Joined: Wed Aug 08, 2007 13:05
Location: Sweden

Postby zouzou85 » Mon Aug 13, 2007 21:33

you need to downgrade ffmpeg-0.4.9_p20070330 first then upgrade amarok.
it may be helpful to mask any newer versions of ffmpeg cuz it will want to upgrade.
Ignorance is not shameful. Arrogantly ignoring and denying your ignorance is.
All men are capable of learning, except two: The Arrogant and The Shy.
zouzou85
Growing Hen
 
Posts: 104
Joined: Tue Mar 27, 2007 5:12
Location: West Coast, North Africa, South America

Postby Zinden » Tue Aug 14, 2007 7:42

Well, was going to try your suggestion. So i went to portato and marked that version of mpeg and forgot to mask newer versions. After it was done i had newest version available.

(First time Amarok needed 10 files, some got installed except last 3 files.)


And i thought...lets try to install amarok again. 2 files needed to install now instead of 3, as i already installed mpeg.

Started with: xine-lib-1.1.7
And i got installed, and amarok started to install.....and went ok too.


I didnt had amarok installed, as i installed a clean sabayon without any extra program.
Zinden
Baby Hen
 
Posts: 18
Joined: Wed Aug 08, 2007 13:05
Location: Sweden


Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: No registered users and 2 guests