Error: sys-apps/hal-0.5.9.1-r7 failed [Solved]

Anything that pertains to Portage

Moderator: Moderators

Error: sys-apps/hal-0.5.9.1-r7 failed [Solved]

Postby wolfger » Thu Aug 09, 2007 10:24

Code: Select all
checking for libparted == 1.7.1, 1.8.0, 1.8.1, 1.8.2, 1.8.6... Found libparted 1.8.7configure: error: *** Requires libparted == 1.7.1/1.8.0/1.8.1/1.8.2 or 1.8.6

I figure this is simple... I'll just mask the 1.8.7 version of libparted, right? But when I try 'emerge -p libparted' it says there are not ebuilds. Anybody know which ebuild gives libparted?
Last edited by wolfger on Fri Aug 10, 2007 13:09, edited 1 time in total.
wolfger
Baby Hen
 
Posts: 19
Joined: Sun May 13, 2007 17:31
Location: New Baltimore, MI

Postby voxiac » Thu Aug 09, 2007 15:48

Perhaps sys-apps/parted ?
I reckon there should be a tool somewhere in gentoolkit, which tells you which ebuild owns a given file...
voxiac
Advanced Hen
 
Posts: 218
Joined: Sat Feb 10, 2007 17:05
Location: Denmark

Postby wolfden » Thu Aug 09, 2007 17:21

downgrade parted to 1.8.6

emerge =parted-1.8.6
wolfden
Sharecropper
 
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Postby wolfger » Fri Aug 10, 2007 13:11

That's the trick. Actually, I put sys-apps/parted-1.8.7 into package.mask and now all is well, and I'm working on finishing this monster -NuD world (and dealing with other problems) :D
wolfger
Baby Hen
 
Posts: 19
Joined: Sun May 13, 2007 17:31
Location: New Baltimore, MI


Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: No registered users and 1 guest

cron