HELP -- I killed Kuroo

Anything that pertains to Portage

Moderator: Moderators

HELP -- I killed Kuroo

Postby diamond » Sat Aug 04, 2007 19:49

I somehow managed to hose Kuroo, and now it crashes every time I try to open it. When I run it from the command line, it appears briefly, then I get the following output:

Code: Select all
kbuildsycoca running...
kded: WARNING: [KDEDModule* Kded::loadModule(const KService*, bool)] Could not load library. [ libavahi-qt3.so.1: cannot open shared object file: No such file or directory ]
kded: WARNING: [KDEDModule* Kded::loadModule(const KService*, bool)] Could not load library. [ Library files for "libkded_dnssdwatcher.la" not found in paths. ]
QMultiInputContext::changeInputMethod(): index=0, slave=xim
QMultiInputContext::changeInputMethod(): index=0, slave=xim
KCrash: Application 'kuroo' crashing...
kio (KIOConnection): ERROR: Header read failed, errno=104
kio (KIOConnection): ERROR: Header has invalid size (-1)
QMultiInputContext::changeInputMethod(): index=0, slave=xim


And Kuroo goes away and the KDE crash handler appears.

What have I done? How can I fix this? I can still run emerge from the command line, but there are times when I find Kuroo useful. I'd like to have it back.
diamond
Baby Hen
 
Posts: 12
Joined: Fri Jul 06, 2007 5:47

Postby phzi » Sat Aug 04, 2007 20:18

Looks like some of the required libs can't be found. Have you tried unmerging and re-emerging kuroo?
phzi
Simple Hen
 
Posts: 48
Joined: Thu Jul 19, 2007 18:39

Postby diamond » Sun Aug 05, 2007 0:33

phzi wrote:Looks like some of the required libs can't be found. Have you tried unmerging and re-emerging kuroo?


Yeah, I tried that. No change.
diamond
Baby Hen
 
Posts: 12
Joined: Fri Jul 06, 2007 5:47

Postby phzi » Sun Aug 05, 2007 1:00

What changes did you recently make to your system?

From a bit of research around the web, is it possible you just messed up avahi?

unmerge and re-emerge avahi maybe? However, that still leaves the issue with the kded lib... if your kde daemon is messed... then well, I don't know.

Hopefully I'm just on the wrong track and it's something simple, but I'm not seeing it. Maybe some more information about what changes you made to cause this might help.
phzi
Simple Hen
 
Posts: 48
Joined: Thu Jul 19, 2007 18:39

Postby diamond » Sun Aug 05, 2007 2:04

phzi wrote:What changes did you recently make to your system?

From a bit of research around the web, is it possible you just messed up avahi?

unmerge and re-emerge avahi maybe? However, that still leaves the issue with the kded lib... if your kde daemon is messed... then well, I don't know.

Hopefully I'm just on the wrong track and it's something simple, but I'm not seeing it. Maybe some more information about what changes you made to cause this might help.


OK, from what I recall, the last thing I did was an attempt to re-install avahi in order to resolve the conflict between it and mDNSResponder. That didn't work, so I removed avahi entirely.

Now I can't seem to re-install it. It fails when trying to build gtkhtml. Here is the error message:

Code: Select all
grep: /usr/lib/libavahi-glib.la: No such file or directory
/bin/sed: can't read /usr/lib/libavahi-glib.la: No such file or directory
libtool: link: `/usr/lib/libavahi-glib.la' is not a valid libtool archive
make[2]: *** [libgtkhtml-3.8.la] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2
 *
 * ERROR: gnome-extra/gtkhtml-3.12.3 failed.
 * Call stack:
 *   ebuild.sh, line 1648:   Called dyn_compile
 *   ebuild.sh, line 988:   Called qa_call 'src_compile'
 *   ebuild.sh, line 44:   Called src_compile
 *   ebuild.sh, line 1328:   Called gnome2_src_compile
 *   gnome2.eclass, line 71:   Called die
 *
 * compile failure
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/gnome-extra/gtkhtml-3.12.3/temp/build.log'.
 *

 * Messages for package gnome-extra/gtkhtml-3.12.3:

 *
 * ERROR: gnome-extra/gtkhtml-3.12.3 failed.
 * Call stack:
 *   ebuild.sh, line 1648:   Called dyn_compile
 *   ebuild.sh, line 988:   Called qa_call 'src_compile'
 *   ebuild.sh, line 44:   Called src_compile
 *   ebuild.sh, line 1328:   Called gnome2_src_compile
 *   gnome2.eclass, line 71:   Called die
 *
 * compile failure
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/gnome-extra/gtkhtml-3.12.3/temp/build.log'.
 *
diamond
Baby Hen
 
Posts: 12
Joined: Fri Jul 06, 2007 5:47

Postby Raqua » Mon Aug 06, 2007 13:39

Remove msdnresponder and compile avahi with correct flag to emulate msdnresponder .. I don't remember it exactly right now, but search for my name and avahi and you should find post where I solved this problem with avahi. I don't know if it helps with yhe update problem, but it might solve avahi problem.

EDIT: Here is the thread http://www.sabayonlinux.org/forum/viewt ... highlight=
Raqua
Growing Hen
 
Posts: 175
Joined: Sun Apr 22, 2007 10:17


Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: albfneto and 1 guest