I killed Amarok [Solved]

Anything that pertains to Portage

Moderator: Moderators

I killed Amarok [Solved]

Postby Lucidor » Sat Aug 04, 2007 21:23

Being music enthusiast, I updated to a new version of FLAC that was available in portage. Now, when I start Amarok (or actually amarokapp) I get the following error:

amarokapp: symbol lookup error: /usr/lib/libamarok.so.0: undefined symbol: _ZN9QGLWidget16setMouseTrackingEb

It used to run just fine! Silly me, why did I upgrade. A quick Google did not give anything substantial on the matter. And revdep-rebuild has no objection to my system.

Ideas? Should I downgrade FLAC? I'm not even sure to which version.
Last edited by Lucidor on Sun Aug 05, 2007 21:49, edited 1 time in total.
Lucidor
Young Hen
 
Posts: 25
Joined: Sun Jul 29, 2007 18:25
Location: Solna, Sweden

Postby FrozenFox » Sun Aug 05, 2007 1:19

The one my system (flac unchanged, sab 3.4a) is 1.1.2, if that helps any. try emerge -c flac then emerge 1.1.2.
FrozenFox
Simple Hen
 
Posts: 40
Joined: Fri May 18, 2007 23:18

Postby BlueJayofEvil » Sun Aug 05, 2007 2:16

Do any of your other media apps work (e.g. Kaffeine)?

EDIT: Ok, I just updated FLAC to the latest (1.1.4), and at the end this message was displayed:
* Messages for package media-libs/flac-1.1.4:

* If you've upgraded from a previous version of flac, you may need to re-emerge
* packages that linked against flac by running revdep-rebuild


Have you tried running revdep-rebuild like it suggests?
BlueJayofEvil
Growing Hen
 
Posts: 183
Joined: Tue Jun 12, 2007 3:30
Location: Minnesota, USA

Postby phzi » Sun Aug 05, 2007 9:57

Lucidor wrote:And revdep-rebuild has no objection to my system.

BlueJayofEvil wrote:Have you tried running revdep-rebuild like it suggests?


lol.
phzi
Simple Hen
 
Posts: 48
Joined: Thu Jul 19, 2007 18:39

Postby Lucidor » Sun Aug 05, 2007 17:29

My revdep-rebuild did compile a few packages after the FLAC upgrade and as mentioned earlier, was happy after.

I found a report in an Arch forum on identical problems with Amarok as I experience. There seem to be a strong dependance on QT version, so I updated that and now I'm in a seemingly infinite loop of new dependency-enforced updates. As my computer is not the fastest, it has been compiling for close to 24 hours now. Every now and then, emerge stops and tells me that some library needs to be recompiled with some additional use flag. So it goes on. Looks like I'll have a complete update world when (and if) I'm done!

BlueJayofEvil, did you tried Amarok after the FLAC update? Does it run?
Lucidor
Young Hen
 
Posts: 25
Joined: Sun Jul 29, 2007 18:25
Location: Solna, Sweden

Postby Lucidor » Sun Aug 05, 2007 21:46

It eventually finished compiling (after 24 hours!) and it was still possible to reboot and everything looked fine, except that Amarok still didn't start. In a final attempt I reinstalled Amarok, and much to my surprise, it ran just fine!

I'm amazed that this dependancy hell could actually be sorted by reading the information from emerge and following it's guidance. I was on the verge of wiping the whole system clean with a fresh install when suddenly all parts fell into place. I still need to play around a bit to ensure that nothing else got broken in the process, but it looks very promising. :D
Lucidor
Young Hen
 
Posts: 25
Joined: Sun Jul 29, 2007 18:25
Location: Solna, Sweden

Re: I killed Amarok [Solved]

Postby BlueJayofEvil » Tue Aug 21, 2007 20:01

Just a warning about the latest version of FLAC (I also posted this in my thread about my Sound Juicer problem):
The API underwent fundamental changes in the version 1.1.3 which break the compilation of all existing players using libFLAC. Nobody knows how fast developers can or will adapt to these changes.

Link to quote

So until audio programs are updated to support FLAC 1.1.3 and later, avoid upgrading if possible. Sabayon comes with 1.1.2, which is the version before the major change.
BlueJayofEvil
Growing Hen
 
Posts: 183
Joined: Tue Jun 12, 2007 3:30
Location: Minnesota, USA


Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: No registered users and 1 guest

cron