Unknown USE component: env.d [Solved]

Anything that pertains to Portage

Moderator: Moderators

Unknown USE component: env.d [Solved]

Postby Red Knuckles » Fri Aug 03, 2007 4:19

When running 'dep -w' I'm getting something I've never seen before:

Unknown USE component: env.d

I've run 'env-update' and am still getting this error. How to fix??
Last edited by Red Knuckles on Wed Aug 08, 2007 14:31, edited 1 time in total.
SL 3.4a AMD64, Gentoo2007.0 AMD64 - ASUS M2NPV-VM - AMD64 X2 4800+ 2.5 Ghz - 4X1GB DDR2 800 - GeForce 6150 256MB - 2X320GB
Red Knuckles
Growing Hen
 
Posts: 104
Joined: Wed Jan 10, 2007 3:16
Location: Colorado, USA

Postby Red Knuckles » Fri Aug 03, 2007 4:23

I don't see anything related to this in '/etc/portage/package.use'. Here's emerge --info:

# emerge --info
Portage 2.1.3.1 (default-linux/amd64/2007.0, gcc-4.2.0, glibc-2.6-r0, 2.6.22-sabayon x86_64)
=================================================================
System uname: 2.6.22-sabayon x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 4800+
Gentoo Base System release 1.12.10
Timestamp of tree: Thu, 02 Aug 2007 15:32:01 +0000
distcc 2.18.3 x86_64-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [enabled]
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python: 2.4.4-r4
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache: 2.4-r7
sys-apps/sandbox: 1.2.18.1
sys-devel/autoconf: 2.13, 2.61-r1
sys-devel/automake: 1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils: 2.17-r1
sys-devel/gcc-config: 1.3.16
sys-devel/libtool: 1.5.24
virtual/os-headers: 2.6.22-r2
ACCEPT_KEYWORDS="amd64 ~amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-Os -march=x86-64 -pipe -fPIC"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/share/config/kdm /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-Os -march=x86-64 -pipe -fPIC"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/dis ... ons/gentoo"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--enable-new-dtags -Wl,--sort-common -s"
LINGUAS="en"
MAKEOPTS="-s -j7"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/sabayon"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="7zip X a52 aac aalib accessibility acl acpi ada aiglx alsa amd64 arts artswrappersuid asterisk audiofile avahi beagle berkdb bitmap-fonts bluetooth browserplugin bzip2 cairo canvas cdda cdr cjk cli commercial cracklib crypt css cups dbox2 dbus dga divx4linux djvu dlloader dri dts dv dvb dvd dvdr dvdread dvi evo exif exscalibar fat ffmpeg firefox flac foomatic-db fortran freetype fuse gcj gdbm gimpprint glitz glut gnokii gnome gnutls gphoto2 gpm gsm gtk2 hal hfs iconv ieee1394 ipod ipv6 irda isdnlog jack java jfs jingle joystick jpeg jpeg2k kde kdeenablefinal kdehiddenvisibility kdgraphics kerberos kig-scripting kipi ladspa lame lcd ldap libcaca libg++ libnotify lirc live livecd lm_sensors logitech-mouse mad mbrola midi mikmod mmx mono moznocompose moznoirc moznomail mozsvg mp3 mp3rtp mpeg mudflap musepack musicbrainz nautilus ncurses nls nntp nptl nptlonly nsplugin ntfs nvidia ogg oggvorbis ole on-the-fly-crypt openexr openmp pam pam_chroot pam_timestamp pcmcia pcre pda pdf perforce perl povray ppds pppd pulseaudio pwdb python qt rdesktop readline reflection reiser4 reiserfs remote rtsp ruby samba scanner session shout skins sms sndfile soundtouch speedo speex spl sse sse2 ssl startup-notification stats stream svg symlink tcpd theora tiff timidity truetype truetype-fonts type1-fonts udev unichrome unicode usb v4l v4l2 vcd visualization vlm vorbis wifi wxwindows x264 xfs xine xinerama xml xml2 xorg xprint xscreensaver xv xvid xvmc zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse acecad aiptek calcomp citron digitaledge dmc dynapro elo2300 elographics fpit hyperpen jamstudio joystick magellan microtouch mutouch palmax penmount spaceorb summa synaptics tek4957 wacom ur98 vmmouse void wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" LIRC_DEVICES="audio audio_alsa" USERLAND="GNU" VIDEO_CARDS="apm ark chips cirrus cyrix dummy fbdev fglrx glint i128 i810 mach64 mga neomagic nv r128 radeon rendition s3 s3virge savage siliconmotion sis sisusb tdfx tga trident tseng v4l vesa vga via vmware voodoo epson nvidia"
Unset: CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
SL 3.4a AMD64, Gentoo2007.0 AMD64 - ASUS M2NPV-VM - AMD64 X2 4800+ 2.5 Ghz - 4X1GB DDR2 800 - GeForce 6150 256MB - 2X320GB
Red Knuckles
Growing Hen
 
Posts: 104
Joined: Wed Jan 10, 2007 3:16
Location: Colorado, USA

Postby Red Knuckles » Fri Aug 03, 2007 4:26

Here's 'nano /etc/portage/package.use':

sys-data/sabayon-version x86_64
net-misc/openssh -ldap
www-client/mozilla -java
net-wireless/wpa_supplicant madwifi gsm
x11-wm/enlightenment xrandr
www-client/epiphany -dbus
media-gfx/inkscape effects inkjar jabber
kde-base/kdelibs acl -pertty jpeg2k
sys-kernel/sabayon-sources symlink
media-plugins/alsa-plugins libsamplerate pulseaudio
net-dialup/ppp atm dhcp radius
net-print/hplip snmp
x11-base/xorg-x11 intel
app-text/evince -dvi
media-gfx/splashutils mng
media-gfx/gimp mng wmf
media-gfx/digikam -linguas_bn -linguas_eu -linguas_km
dev-libs/boost threads
media-sound/rosegarden -arts
x11-base/xorg-server -ipv6
net-fs/samba acl oav
dev-lang/python tk
media-sound/amarok ifp njb mtp musicbrainz
net-misc/vnc server
kde-base/kopete addbookmarks alias autoreplace connectionstatus contactnotes gadu groupwise highlight history jingle netmeeti$
x11-drivers/ati-drivers distribution
x11-drivers/nvidia-drivers distribution
<x11-libs/qt-4 -pertty
net-misc/nxnode prebuilt vnc
net-misc/nxclient prebuilt
net-wireless/btsco ao skype
dev-util/subversion -java -apache2
www-client/mozilla-firefox xforms mozbranding filepicker -linguas_en_GB -linguas_es_AR -linguas_es_ES -linguas_fy -linguas_fy$
www-client/seamonkey -linguas_en_GB -linguas_es_AR -linguas_es_ES -linguas_fy -linguas_fy_NL -linguas_ga -linguas_ga_IE -ling$
mail-client/mozilla-thunderbird -linguas_en_GB -linguas_es_AR -linguas_es_ES -linguas_fy -linguas_fy_NL -linguas_ga -linguas_$
media-video/mplayer x264 dvdnav mp2 openal mmxext radio rtc rar tga tivo zoran cpudetection cddb cdparanoia 3dnow 3dnowext ss$
kde-base/kicker -kdehiddenvisibility
net-www/mplayerplug-in divx gmedia realmedia wmp gtk quicktime win32codecs nsplugin firefox xvid
x11-themes/sabayonlinux-artwork symlink
>=media-sound/soundkonverter-0.2.90-r1 kdeenablefinal lame
app-misc/ddccontrol -gtk -gnome
dev-java/swt cairo
net-p2p/azureus source
kde-base/kdesktop pertty
x11-wm/aquamarine -kdeenablefinal
xfce-base/xfdesktop thunar-vfs
xfce-base/thunar thumbnail
media-tv/mythtv -xvmc
app-office/openoffice -linguas_af -linguas_ar -linguas_bg -linguas_bn -linguas_bs -linguas_ca -linguas_cs -linguas_cy -lingua$
net-p2p/ktorrent -linguas_eu -linguas_km -linguas_mk -linguas_nb
net-wireless/wpa_supplicant madwifi
media-video/dvdrip subtitles mplayer fping
sys-fs/ntfs3g suid
dev-scheme/guile deprecated regex
>=x11-libs/qt-4.0 qt3support
=x11-libs/qt-4.3.0 qt3support
net-im/pidgin bonjour console gadu groupwise meanwhile msn prediction qq sasl
net-dns/avahi howl-compat mdnsresponder-compat gtk qt3 qt4
media-gfx/gimp smp
net-libs/libgadu -ssl
sys-apps/hwdata-gentoo binary-drivers
x11-wm/beryl emerald
app-misc/sabayon-version x86_64_release
games-fps/warsow irc openal
media-libs/openexr -video_cards_nvidia
app-cdr/cdrdao -gnome
app-mobilephone/gnokii -X
app-laptop/pommed -gtk
sys-devel/gcc -gcj -fPIC
app-misc/mc -unicode
sys-apps/pciutils -zlib
#portato update#
=dev-java/blackdown-jdk-1.4.2.03-r16 nsplugin
app-text/poppler-bindings gtk qt3
app-crypt/pinentry gtk
app-emulation/libvir qemu
SL 3.4a AMD64, Gentoo2007.0 AMD64 - ASUS M2NPV-VM - AMD64 X2 4800+ 2.5 Ghz - 4X1GB DDR2 800 - GeForce 6150 256MB - 2X320GB
Red Knuckles
Growing Hen
 
Posts: 104
Joined: Wed Jan 10, 2007 3:16
Location: Colorado, USA

Postby WarraWarra » Fri Aug 03, 2007 6:23

Getting the same here and just did clean complete install "nognome"
Code: Select all
p-portage/ufed
app-shells/tcsh
!!! Unknown USE component: env.d
app-text/a2ps
!!! Unknown USE component: env.d
!!! Unknown USE component: env.d
!!! Unknown USE component: env.d
!!! Unknown USE component: env.d
!!! Unknown USE component: env.d
!!! Unknown USE component: env.d
!!! Unknown USE component: env.d
app-text/docbook-xml-simple-dtd
app-text/dos2unix
!!! Unknown USE component: env.d
app-text/ghostscript-esp


Someone that knows what is going on will post.
WarraWarra
Sagely Hen
 
Posts: 1989
Joined: Wed Jan 03, 2007 21:01
Location: 31.324270, -113.585511

Postby xaz0r » Tue Aug 07, 2007 4:38

I had the same problem so I did a little investigating based on a suspicion. It is caused by the newer versions of portage. I believe the problem started with version 2.1.3.1 but I didn't do any thorough investigation of the exact version where it starts, it's definitely somewhere around there though. I'll have to look into the changes that caused this at some point when I get some time. As far as I can tell, you can safely ignore the errors, it still seems to work fine for now. I just ran across this because I was receiving the same error, but I use Gentoo, not Sabayon. I'll post here as soon as I get more information. If you really want the message to go away then downgrade to an earlier version of portage.
xaz0r
Baby Hen
 
Posts: 2
Joined: Sat Aug 04, 2007 20:47

Postby xaz0r » Wed Aug 08, 2007 6:46

Yesterday I filed a bug report on Gentoo's bugzilla. The problem is now fixed, at least for Gentoo. As long as Sabayon uses the same portage tree (which I'm fairly certain it would have to), just do the following and it'll work wonderfully:

1. emerge --sync
2. emerge udept

That's it!
xaz0r
Baby Hen
 
Posts: 2
Joined: Sat Aug 04, 2007 20:47


Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: No registered users and 0 guests

cron