emerge portage hangs after 3.3 to 3.4 upgrade

Anything that pertains to Portage

Moderator: Moderators

Post Reply
Baby Hen
Posts: 15
Joined: Mon Mar 19, 2007 10:16

emerge portage hangs after 3.3 to 3.4 upgrade

Post by Learnincurve » Mon Jul 30, 2007 8:53


I just upgraded Sabayonlinux 3.3 to 3.4 using the standard upgrade option from the installer (removing packages not present on the medium).

Everything looks okay apart from 2 problems:

1. Not a portage problem, but I'll post here in case it's related:

Init hangs at "Loading Key mappings" and I have to escape it each time it is calles to continue the boot process. I have no problem with the keyboard once the system is loaded.

2. I did "# emerge --sync" and as portage has been updated I tried "# emerge portage"
This hangs at "Regenerating GNU directory index..."

I see no error messages. It just hangs without disk activity.

Any ideas on what might be causing this?

I'm posting the key mappings problem in another post.


Old Dear Hen
Posts: 742
Joined: Mon Jul 09, 2007 20:29
Location: Mobile, AL, USA

Post by DontPanic » Wed Aug 01, 2007 23:11

Did you ever fix this problem?

Have you added the '-v' option to get more verbose output when running the emerge commands? Although I don't usually get much additional output when I use '-v' in emerge, it's something to try.

Baby Hen
Posts: 15
Joined: Mon Mar 19, 2007 10:16

"solved" with fresh install

Post by Learnincurve » Thu Aug 02, 2007 9:45

In the end I just did a fresh install (not upgrade). I have /home on a seperate partition so had no problems. System came up with the user data intact, and the machine is happily crunching away doing a world update whilst I'm at work.

I also had problems with key mappings after the upgrade, and saw that other users had also had problems with these after upgrading.

Maybe the repair option would have worked, but with a /home partition I don't really see the advantage of an upgrade. I can re-edit my conf scripts much quicker than the extra time an upgrade takes over an install (it had deleted my net startup config anyway ;-) ).

Thanks for posting back!

Post Reply