qt compilation error in sabayon 3.4

Installer Issues via Installer -- Not for global upgrades or upgrading individual packages -- ONLY ISSUES WITH INSTALLATION OF THE OS -- Can't get Sabayon installed, than post here, otherwise use correct forums

Moderator: Moderators

qt compilation error in sabayon 3.4

Postby gallienus » Sun Jul 29, 2007 6:21

I've upgraded from sabayon 3.3 to 3.4. I'm trying to build mythtv using this howto http://gentoo-wiki.com/HOWTO_Setup_MythTV. I've downloaded and installed both the 32-bit and 64-bit versions of sabayon and I get the same error on both when I try to emerge qt3.

This is the error.
Code: Select all
usr/X11R6/lib/libXft.so: undefined reference to `FT_Library_SetLcdFilter'
collect2: ld returned 1 exit status
make[3]: *** [../../../bin/uic] Error 1
make[2]: *** [sub-uic] Error 2
make[1]: *** [sub-designer] Error 2
make: *** [sub-tools] Error 2
 *
 * ERROR: x11-libs/qt-3.3.4-r8 failed.
 * Call stack:
 *   ebuild.sh, line 1648:   Called dyn_compile
 *   ebuild.sh, line 988:   Called qa_call 'src_compile'
 *   ebuild.sh, line 44:   Called src_compile
 *   qt-3.3.4-r8.ebuild, line 184:   Called die
 *
 * (no error message)


Does anyone have any idea of how to get around this? And if it's not possible can I get some advice on downgrading back to 3.3 I've already tried reverting back to 3.3 but when I try to emerge the qt libraries it tells me qt3.3.6 can not be found.
gallienus
Growing Hen
 
Posts: 101
Joined: Thu Jan 18, 2007 23:37

Postby cheater1034 » Mon Jul 30, 2007 0:22

Make a package.keywords entry to use the latest QT (not 4, but the latest 3, I think it's 3.3.6)
cheater1034
Baby Hen
 
Posts: 5
Joined: Mon Jul 30, 2007 0:14

Postby gallienus » Mon Jul 30, 2007 1:44

Using Portato I just checked to see what qt version is installed. And according to portato qt 3.3.8-r2 is installed. I think I need to read up on portage, I should only have to re-emerge qt 3.3.8-r2 with mysql support and it should work
gallienus
Growing Hen
 
Posts: 101
Joined: Thu Jan 18, 2007 23:37

SOLVED

Postby gallienus » Mon Jul 30, 2007 4:18

this has been solved
gallienus
Growing Hen
 
Posts: 101
Joined: Thu Jan 18, 2007 23:37


Return to Installer Issues - Calamares **Not for Package Manager Stuff**

Who is online

Users browsing this forum: No registered users and 1 guest