Unable to boot XP

Installer Issues via Installer -- Not for global upgrades or upgrading individual packages -- ONLY ISSUES WITH INSTALLATION OF THE OS -- Can't get Sabayon installed, than post here, otherwise use correct forums

Moderator: Moderators

Unable to boot XP

Postby mfker » Sat Jul 28, 2007 20:16

I have XP on my second drive sdb and just installed sabayon onto the first drive sda. When I tried to boot XP through grub it just hangs. Booted sabayon instead and out of curiosity checked out my second drive and found that almost all of my data had gone, including windows!
I made sure to select the right drive during sabayon install.
Surely this isn't possible as windows was on a seperate drive unrelated to sabayon, as a noob to all this I am unsure whether this is a grub issue or I lost all of my data :(
Baby Hen
Posts: 10
Joined: Tue Jul 17, 2007 15:00
Location: UK

Postby wolfden » Sat Jul 28, 2007 20:57

I have never lost any data from installing SL - I have WinXP, Vista, SL x86, SL x86_64, SL BE all booting fine on the same computer and never has it ever touched any of the other partitions
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Postby mfker » Sat Jul 28, 2007 21:43

I'm not crazy, at least I think so :P .
There's clearly a relationship between me installing Sabayon and losing information on the seperate drive.
I suspect the information is still there but something mysterious has happened.

EDIT: Is it possible that grub has somehow damaged the MBR on my second drive?
Could that damage my XP file system?!
Is the moon made of cheese?
Baby Hen
Posts: 10
Joined: Tue Jul 17, 2007 15:00
Location: UK

Postby Eden » Sat Jul 28, 2007 22:42

How are you trying to boot XP? if grub os on sda (the drive with Sabayon), and XP is on sdb and your trying to boot XP via grub you need to make sure Sabayon mapped windows properly. Loop1 didn't setup grub right to boot XP on a second hdd, I had to manually add the correct parameters.

heres my grub.conf for XP.

Code: Select all
title Windows XP 64bit
   rootnoverify (hd1,0)
   chainloader +1
   map (hd0) (hd1)
   map (hd1) (hd0)

It basically fools XP into thinking its the first hdd and first to boot.
Growing Hen
Posts: 176
Joined: Fri May 18, 2007 16:44
Location: Scotland, UK

Postby mfker » Sat Jul 28, 2007 23:10

Got a little further by using that mapping trick but then it hangs again, HD indicator stays lit but no HD activity can be heard. There may possibly be a corruption/hardware issue that only shows up when trying to install a second OS as this has happened twice now. Install linux and loss of data on second drive. It's certainly a strange one :?

I only really need to recover my login details from roboform, any recommendations on a linux based fat32 recovery program :lol:
Baby Hen
Posts: 10
Joined: Tue Jul 17, 2007 15:00
Location: UK

Postby 2ny » Sun Jul 29, 2007 2:15

Correctly mapping the drives is a possible solution - the easiest way out for you, I believe is to keep your XP on the first bootable disk and re-install Linux and have it put Grub onto the MBR, this will automatically put evrything in one place. The only caveat is that you cannot re-install, or repair XP without disturbing Linux - but even that is manageable.

Tony. . .
Simple Hen
Posts: 75
Joined: Wed Sep 06, 2006 15:08
Location: Denmark

Re: Unable to boot XP

Postby hulkyboy » Mon Jul 30, 2007 15:04

Ah ha! Funnily enough, something odd happened to my XP install also. This was after I installed openSuse 10.2. The partition table changed, so that the linux partition was marked as bootable (grub does this). This was enough to trigger windows into trying to rename its drives. So, what was once the XP system on "J:" had become "C:" and so forth. Unfortunately, windows tries to assign drive letters to partitions it doesn't understand, although you never see them. By the time I had noticed what had happened, it was too late. Removing the bootable flag did not help, as windows had already "seen" the change. No matter what I did, I couldn't get it to boot (even to safe mode), it would just hang. Eventually fixed by backing up the non-windows partitions and changing them all to FAT32 (and this was after a reinstall of windows too!). Then you use the drive rename utility in windows to reassign all the drives, and put things back the way they were.

In retrospect, I think there is some place in the registry that maintains these assignments. I'm sure I saw something when I was fishing about. So, for future occurrences, the wine registry editor could be a valuable tool.
Baby Hen
Posts: 10
Joined: Fri Jul 20, 2007 17:33

Postby darkscot » Tue Jul 31, 2007 14:43

mfker wrote:EDIT: Is it possible that grub has somehow damaged the MBR on my second drive?
Could that damage my XP file system?!
Is the moon made of cheese?

What I would do in your position is:
Boot up from your Windows XP disk and choose the Repair option. At the dot prompt enter:
Code: Select all

This will, unsurprisingly, fix your MBR.
You should then be able to boot into XP but Sabayon will have apparently gone (but it hasn't really).
Then boot up from your Sabayon disk and go through the install again. At some point (I can never remember where) it gives you the option of repairing Grub. You can then put Grub on your MBR and all will be well :?:
Desktop1: Sabayon 3.4e, WinXP | Desktop2: Sabayon 3.4e, WinME |
Advanced Hen
Posts: 249
Joined: Thu Mar 15, 2007 9:41
Location: Yorkshire, UK

Postby ashley194 » Wed Aug 01, 2007 8:43

I've had the same problem since last weekend, got XP Pro x86 on my 80GB SATA & SL x86-64 on my 160GB SATA :? Choosing XP brings-up

rootnoverify (hd1,0)
chainloader +1

& from there it just hangs, I have to ctl+alt+del to be able to choose SL. After that, SL boots fine. I've tried the live DVD of SL 3.4 x86-64, & attempting to repair grub without any success :cry: Originally, I had my XP install on the 160GB & SL on the 80GB. I'll try to fixmbr tonight then, any other thoughts?

Thanks :)
Technological Hen
Posts: 321
Joined: Mon Feb 19, 2007 21:54
Location: Manchester, UK.

Return to Installer Issues - Calamares **Not for Package Manager Stuff**

Who is online

Users browsing this forum: No registered users and 1 guest