Resolucion baja + error de conf. XKB

Conversaciones generales alrededor Sabayon Linux

Moderator: Moderators

Resolucion baja + error de conf. XKB

Postby memosh » Sat Mar 03, 2007 5:34

Uso Sabayon 3.25c en una IBM Thinkpad R60e con video Intel 950GM, resolución 1024x768, y cuando arranco con mi usuario me baja la resolucion a 640x480 y me manda este error:

Error al activar la configuración XKB.

Podría deberse a varias circunstancias:
- un fallo en la biblioteca libxklavier.
- un fallo en el servidor X (utilidades xkbcomp, xmodmap)
- Un servidor X con una implementación incompatible con libxkbfile

Datos de la versión del servidor X:
The X.Org Foundation
70199903

Si informa de esta situación como un fallo, por favor incluya:
- El resultado de xprop -root | grep XKB
- El resultado de gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd


Los resultados de los comandos que pide enviar son:

$ xprop -root | grep XKB

_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc105", "la-latin1", "", ""
_XKB_RULES_NAMES(STRING) = "xorg", "pc105", "la-latin1", "", ""


$ gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd

layouts = [la-latin1]
model =
options = [grp grp:alts_toggle]
overrideSettings = true


pero cuando abro las opiones de aceleracion de escritorio aparece "OpenGL status: Working"

y si puedo usar beryl muy bien y todo, solo que en 640x480.


Otra observacion es que si entro a la sesion root si me deja ponerle la resolucion de 1024x768 y no me marca ningun error.


Espero que alguien pueda ayudarme, gracias de antemano.
memosh
Baby Hen
 
Posts: 2
Joined: Sat Mar 03, 2007 5:23

Postby Apokalyptica79 » Wed Apr 18, 2007 22:48

Hola muy raro lo que te pasa. No se si podré ayudarte pero tedejo acá mi configuración a ver si te sirve.
Es una Acer Aspire 5003WLCi AMD Turion.


Section "Files"


#FontPath "/usr/share/fonts/local/"
FontPath "/usr/share/fonts/misc/"
FontPath "/usr/share/fonts/Type1/"
FontPath "/usr/share/fonts/TTF/"
FontPath "/usr/share/fonts/75dpi/"
FontPath "/usr/share/fonts/100dpi/"
FontPath "/usr/share/fonts/corefonts"

EndSection

# **********************************************************************
# Module section -- this is an optional section which is used to specify
# which run-time loadable modules to load when the X server starts up.
# **********************************************************************

Section "Module"

Load "dbe"
Load "i2c"
Load "glx"
Load "ddc"
Load "type1"
Load "freetype"
Load "extmod"
Load "synaptics"
Load "vbe"
Load "dri"

EndSection


# **********************************************************************
# Server flags section. This contains various server-wide Options.
# **********************************************************************

Section "ServerFlags"

Option "AllowMouseOpenFail" "true"

EndSection

# **********************************************************************
# Input devices
# **********************************************************************

# **********************************************************************
# Core keyboard's InputDevice section
# **********************************************************************

Section "InputDevice"
Identifier "Synaptics1"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
Option "SHMConfig" "on"
# For ALPS TouchPads
#Option "MaxSpeed" "0.7"
#Option "MinSpeed" "0.18"
#Option "AccelFactor" "0.08"
#Option "TopEdge" "120"
#Option "LeftEdge" "120"
#Option "BottomEdge" "830"
#Option "RightEdge" "650"
#Option "FingerLow" "25"
#Option "FingerHigh" "30"
# Do you keep moving the mouse while typing? Try this trick.
#synclient TouchpadOff=1 disable your synaptics touchpad
#synclient TouchpadOff=0 enable your synaptics touchpad
EndSection


Section "InputDevice"

Identifier "Keyboard1"
Driver "kbd"

Option "AutoRepeat" "500 5"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
Option "XkbRules" "xorg"

EndSection


Section "InputDevice"
Driver "wacom"
Identifier "wacom1"
Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "wacom2"
Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "wacom3"
Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection


# **********************************************************************
# Core Pointer's InputDevice section
# **********************************************************************

Section "InputDevice"

# Identifier and driver

Identifier "Mouse1"
Driver "mouse"

Option "Device" "/dev/psaux"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"

EndSection

Section "InputDevice"
Identifier "Mouse2"
Driver "mouse"
Option "Protocol" "ImPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
EndSection


# **********************************************************************
# Monitor section
# **********************************************************************

# Any number of monitor sections may be present

Section "Monitor"

Identifier "Generic Monitor"
#Option "DPMS"

VertRefresh 43 - 60
HorizSync 28 - 80

EndSection

# **********************************************************************
# Graphics device section
# **********************************************************************

# Any number of graphics device sections may be present

Section "Device"
Identifier "VESA"
Driver "sis" # do not remove vesa
#Option "RenderAccel" "on"
#Option "XAANoOffscreenPixmaps"
#Option "BusType" "PCI"
#Option "ColorTiling" "on"
#Option "EnablePageFlip" "on"
EndSection


# **********************************************************************
# Screen sections.
# **********************************************************************

Section "Screen"

# The Identifier, Device and Monitor lines must be present

Identifier "Screen 1"
Device "VESA"
Monitor "Generic Monitor"
#Option "AddARGBGLXVisuals" "true"

# The favoured Depth and/or Bpp may be specified here

DefaultDepth 24

SubSection "Display"
Depth 8
ViewPort 0 0
Modes "1024x768" "800x600" "640x480"
EndSubsection

SubSection "Display"
Depth 16
ViewPort 0 0
Modes "1024x768" "800x600" "640x480"
EndSubsection

SubSection "Display"
Depth 24
ViewPort 0 0
Modes "1024x768" "800x600" "640x480"
EndSubsection


EndSection


Section "ServerLayout"
# The Identifier line must be present

Identifier "Main Layout"
Screen 0 "Screen 1"
InputDevice "Mouse1" "CorePointer"
InputDevice "Mouse2" "SendCoreEvents"
InputDevice "Synaptics1" "SendCoreEvents"
#InputDevice "wacom1" "SendCoreEvents"
#InputDevice "wacom2" "SendCoreEvents"
#InputDevice "wacom3" "SendCoreEvents"
InputDevice "Keyboard1" "CoreKeyboard"

EndSection

Section "DRI"
Mode 0666
EndSection

Section "Extensions"
#Option "Composite" "Enable"
EndSection

Espero puedas solucionarlo. Sino vemos que se hace.
Apokalyptica79
Old Dear Hen
 
Posts: 577
Joined: Wed Dec 13, 2006 21:15
Location: Argentina


Return to Spanish

Who is online

Users browsing this forum: No registered users and 2 guests

cron