Wine installation unter Sabayon

Allgemeine Gespräche hinsichtlich Sabayon Linux

Moderator: Moderators

Postby Jesterhead » Wed Mar 07, 2007 21:28

Warnungen während dem kompilieren sind normal nicht weiter schlimm.
Ich tipp mal das du Wine 0.9.31 installiert hast (oder 0.9.30).
Die beiden Versionen haben bekanntermassen probleme (insbesondere mit Steam-Games).
mach einfach
layman -S && emerge --sync && emerge wine
um auf 0.9.32 upzudaten.

Das Problem mit den Alsa-Fehlermeldungen kannst du mittles
wineconf
(als User ausführen!) beheben.
Spiel ein bisschen da mit den Settings zu dem Ausgabegerät.
Möglicherweise löuft ein Soundserver im Hintergrund, und blockiert den Audio-Zugriff für Wine.
Schau mal mittels dem
ksysguard
Tool nach ESD oder ARTS.
Und kill die beiden Prozesse.
Jesterhead
Old Dear Hen
 
Posts: 642
Joined: Thu Dec 14, 2006 14:13

Postby bifi5590 » Wed Mar 07, 2007 22:54

Hm... Das installieren hat geklappt...

wenn ich wine --verison ausführe bekomm ich: wine-0.9.32

also hat das update schonmal geklappt...

als Prozess läuft nur der artsd... hab den gekillt aber bleibt alles beim alten...

wenn ich nun aber winecfg eintippe bekomme ich wieder:
Code: Select all
winecfg
ALSA lib conf.c:3939:(snd_config_expand) Unknown parameters 0
ALSA lib control.c:910:(snd_ctl_open_noupdate) Invalid CTL default:0
ALSA lib conf.c:3939:(snd_config_expand) Unknown parameters 1
ALSA lib control.c:910:(snd_ctl_open_noupdate) Invalid CTL default:1
Speicherzugriffsfehler


Wenn ich nun wineboot eintippe, dann dauert das erst ne weile und dann kann ich winecfg starten, genauso wie alle anderen exe Dateien...

Im Audio Menü von winecfg kann ich leider gar nichts einstellen...
Alles was ich erhalte ist en Fenster mit dem Namen Fixme und dem Text: "Launching audio control panel not implemented yet!"

Wenn ich nun etwas starte habe ich aber trotzdem sound.. scheint also trotz der Fehlermeldungen zu funktionieren.

Fazit: Funzt nun. Ist nur etwas nervig weil ich nach jedem system start einmal wineboot ausführen muss und das dauert immer so 5mins... (AMD 3200+ also sooo schwach dürfte der ja noch nich sein ^^)
Bei Source games zickt es noch rum aber das ist eher Sache von den ati treibern dies ja leider nicht als quellcode sondern nur fertig gibt *grml*

Danke für die schnelle und direkte Hilfe
:D

Mfg BiFi
bifi5590
Baby Hen
 
Posts: 4
Joined: Wed Mar 07, 2007 19:21

Postby bifi5590 » Thu Mar 08, 2007 14:33

Hi.
Hab nochmal ein neues Problem.

Gestern Abend ist der Rechner beim ausführen einr exe hängen geblieben. Nach 30min hing er immer noch an der selben stelle.. -> Power on Reset

beim Starten von einer exe weterhin:
Code: Select all
wine DirtBike.exe
ALSA lib conf.c:3939:(snd_config_expand) Unknown parameters 0
ALSA lib control.c:910:(snd_ctl_open_noupdate) Invalid CTL default:0
ALSA lib conf.c:3939:(snd_config_expand) Unknown parameters 1
ALSA lib control.c:910:(snd_ctl_open_noupdate) Invalid CTL default:1
Speicherzugriffsfehler


Das konnte ich ja mit wineboot beheben...

Nun kommt aber folgendes:
Code: Select all
 wineboot
err:wineboot:runCmd Failed to run command L"" (6)
err:wineboot:ProcessRunKeys Error running cmd #0 (6)


Was ist das nun wieder? :(
bifi5590
Baby Hen
 
Posts: 4
Joined: Wed Mar 07, 2007 19:21

Postby Tails2k » Thu Mar 08, 2007 16:11

also ich bin kein experte oder so aber stell mal deine wine config auf win 98

das macht mich da etwas stutzig bei "Error running cmd"
Also versuch macht klug :-)
User avatar
Tails2k
Growing Hen
 
Posts: 136
Joined: Wed Nov 22, 2006 14:28
Location: Niedersachsen

Postby bifi5590 » Thu Mar 08, 2007 17:34

Danke für den tipp aber die Meldung bleibt die gleiche nach dem umstellen. Scheint aber momentan nicht weiter schlimm zu sein.

Die .exe files die ich probiert habe, liefen einwandfrei.

Steam startet auch komplett, sofern ich es von der Konsole aus starte...
Die Probs bei source könnten mit meiner ati graka zusammenhängen, aber hauptsache wine startet wieder exe dateien ^^
bifi5590
Baby Hen
 
Posts: 4
Joined: Wed Mar 07, 2007 19:21

Previous

Return to German

Who is online

Users browsing this forum: No registered users and 0 guests

cron