webapp-config error blockt software-installationen

Allgemeine Gespräche hinsichtlich Sabayon Linux

Moderator: Moderators

webapp-config error blockt software-installationen

Postby Vecha » Fri Mar 02, 2007 15:18

Ich hab mir vor ein paar Wochen mal per Sabayon meine Kiste neu aufgesetzt und wollt heut nun mal'n bissle mit verschiedenen Web-Apps rumspielen.

MySQL, apache und php sind ja schon installiert, dann dacht ich mir, ich hau mal phpmyadmin drauf und schau dann mal was joomla so kann ...
Was mir aber gleich in die Quere kam, hat mir garnicht gefallen:
Code: Select all
>>> Emerging (1 of 1) dev-db/phpmyadmin-2.10.0.1 to /
 * phpMyAdmin-2.10.0.1-all-languages-utf-8-only.tar.bz2 MD5 ;-) ...                       [ ok ]
 * phpMyAdmin-2.10.0.1-all-languages-utf-8-only.tar.bz2 RMD160 ;-) ...                    [ ok ]
 * phpMyAdmin-2.10.0.1-all-languages-utf-8-only.tar.bz2 SHA1 ;-) ...                      [ ok ]
 * phpMyAdmin-2.10.0.1-all-languages-utf-8-only.tar.bz2 SHA256 ;-) ...                    [ ok ]
 * phpMyAdmin-2.10.0.1-all-languages-utf-8-only.tar.bz2 size ;-) ...                      [ ok ]
 * checking ebuild checksums ;-) ...                                                      [ ok ]
 * checking auxfile checksums ;-) ...                                                     [ ok ]
 * checking miscfile checksums ;-) ...                                                    [ ok ]
 * checking phpMyAdmin-2.10.0.1-all-languages-utf-8-only.tar.bz2 ;-) ...                  [ ok ]
* Fatal error:
* Fatal error: There is a problem with your configuration file.
* Fatal error: webapp-config tried to read the variable "config_protect"
* Fatal error: and received the following error:
* Fatal error:
* Fatal error: Bad value substitution:
* Fatal error:  section: [USER]
* Fatal error:  option : config_protect
* Fatal error:  key    : nxdir
* Fatal error:  rawval : /etc ${NXDIR}/home /etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/share/config/kdm/ /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config
* Fatal error:
* Fatal error: Please note that webapp-config is not written in bash anymore
* Fatal error: and that you cannot use the bash scripting features.
* Fatal error(s) - aborting

!!! ERROR: dev-db/phpmyadmin-2.10.0.1 failed.
Call stack:
  ebuild.sh, line 1630:   Called dyn_setup
  ebuild.sh, line 702:   Called qa_call 'pkg_setup'
  ebuild.sh, line 38:   Called pkg_setup
  phpmyadmin-2.10.0.1.ebuild, line 21:   Called webapp_pkg_setup
  webapp.eclass, line 364:   Called webapp_read_config
  webapp.eclass, line 54:   Called die

!!! Could not read settings from webapp-config!
!!! If you need support, post the topmost build error, and the call stack if relevant.
!!! A complete build log is located at '/var/tmp/portage/dev-db/phpmyadmin-2.10.0.1/temp/build.log'.
Bei joomla, phpbb und so kommt überall das gleiche ..
Bin echt aufgeschmissen jetzt, weil von den web-apps garnix geht (^__^)"

Achja .. und webapp-config selbst macht au nix anderes:
Code: Select all
webapp-config -I phpmyadmin 2.10.0.1
* Fatal error:
* Fatal error: There is a problem with your configuration file.
* Fatal error: webapp-config tried to read the variable "config_protect"
* Fatal error: and received the following error:
* Fatal error:
* Fatal error: Bad value substitution:
* Fatal error:  section: [USER]
* Fatal error:  option : config_protect
* Fatal error:  key    : nxdir
* Fatal error:  rawval : /etc ${NXDIR}/home /etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/share/config/kdm/ /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config
* Fatal error:
* Fatal error: Please note that webapp-config is not written in bash anymore
* Fatal error: and that you cannot use the bash scripting features.
* Fatal error(s) - aborting


Hab schon die Info gefunden, dass das Problem wohl was mit deamontools-scripts oder so zu tun hat
-- gibt aber nix mit deamontools was auf dem Rechner installiert wär

Auch, dass man den Fehler ganz leicht beheben könnt wenn man die "CONFIG_PROTECT="-Zeile in /etc/env.d/50nxpaths löscht, oder ${NXDIR} aus der "CONFIG_PROTECT="-Zeile in /etc/profile.env rausschmeisst
-- funktioniert alles net


edit:
Hab Bug-Reports bei bugs.gentoo.org gefunden: 167343 bzw 153100 befasst sich auch mit dem Problem
-- bringt mich allerdings alles net weiter

Hab auch schon nxserver, nxclient und nxnode unmerged, hatte aber null Effekt

.. :cry:
Vecha
Baby Hen
 
Posts: 6
Joined: Fri Mar 02, 2007 11:15

Postby R2D2 » Sun Mar 04, 2007 18:37

In /etc/make.conf gibt es auch nochmal den Eintrag "CONFIG_PROTECT=".

Lösche den auch, und anschliesend reboot.

So gings bei mir.
R2D2
Baby Hen
 
Posts: 8
Joined: Sat Dec 23, 2006 14:52
Location: Stuttgart Germany


Return to German

Who is online

Users browsing this forum: No registered users and 0 guests