Post LiveUSB problems here.

Discussion in general that pertains to Sabayon Linux - Must Pertain to Sabayon Linux

Moderator: Moderators

Post LiveUSB problems here.

Postby johnnyhay » Fri Jan 26, 2007 22:03

Post your LiveUSB problems here.

Tutorials on making a Sabayon liveUSB here.
Code: Select all
http://www.sabayonlinux.org/forum/viewtopic.php?t=3008&postdays=0&postorder=asc&start=0


Right now, I'm not too sure on how to get emerge and the liveDVD working but everything else should work.
johnnyhay
Technological Hen
 
Posts: 304
Joined: Sun Oct 08, 2006 8:54
Location: Google's main DNS

Postby Kos » Sat Jan 27, 2007 10:43

For Live version on HD USB use on the step 2

this command (windows user)
Then Start->Run->Type CMD
Type: C:\syslinux-3.31\win32\syslinux.exe -maf X:
X is the drive letter for your flash drive. For an example E:

for make MBR...
Kos
Baby Hen
 
Posts: 9
Joined: Sat Jan 20, 2007 17:09

Postby johnnyhay » Sat Jan 27, 2007 18:32

Thanks for the correction!!!
johnnyhay
Technological Hen
 
Posts: 304
Joined: Sun Oct 08, 2006 8:54
Location: Google's main DNS

Postby Kos » Sat Jan 27, 2007 19:27

I have a proposal, a full installation Sabayon linux on external device (with large memory).
Please help me with your ideas.
Thanks
Kos
Baby Hen
 
Posts: 9
Joined: Sat Jan 20, 2007 17:09

hard drive mount madness!!

Postby anthortic » Mon Feb 12, 2007 22:47

i have successfully made a live usb on my second attempt!! well i was impressed anyway. it is on a cheap but large 2 gig flash drive.

But my problem.

I cannot open the local drive, which is ntfs and the error reads something along the lines of "cannot find /newroot/mnt/cdrom".

Now this makes no sense to me because why would it mount sda1 to the cdrom folder? and to make it more complicated (for me :oops: ) when i look at the properties of the drive (that is called 71g media) it states that it is 1.92 gig. in other words,

1. the name is the size of the drive,
2. but it loads it in the /newroot/mnt/cdrom (where is this mythical /newroot anyway?)
3. AND it reads the properties of my usb drive (apart from the line /dev/sda1 cos the usb is sdb1)

i normally assume i have done something wrong but i followed the guide to the letter and it lead to this situation. also i would like to point out as a reminder that for xsistence to work, you need an empty "xsistence-mode" named file. took me ages to figure that one out for in the guide it suggests you only need type "sabayon xsistence" and all is good.

still any help or comments will be well received :arrow: :arrow: thanks again
anthortic
Baby Hen
 
Posts: 5
Joined: Mon Nov 20, 2006 18:17
Location: United Kingdom

Re: hard drive mount madness!!

Postby martytin » Thu Feb 15, 2007 18:37

anthortic wrote:I cannot open the local drive, which is ntfs and the error reads something along the lines of "cannot find /newroot/mnt/cdrom".


what program gives you the error message?

Mounting local ntfs drives works fine from my usb sabayon-live! They can be mounted easily with konqueror in system storage media.
martytin
Young Hen
 
Posts: 25
Joined: Wed Jan 10, 2007 17:25

Postby anthortic » Mon Feb 19, 2007 18:54

the konquerer file browser gives this message, in the properties of the ntfs drive in system:media it is mounted to /newroot/mnt/cdrom, and i dont know how to change it
anthortic
Baby Hen
 
Posts: 5
Joined: Mon Nov 20, 2006 18:17
Location: United Kingdom

Works almost perfectly...

Postby Basnoff » Tue Mar 27, 2007 19:36

Hello,

I followed the tut posted here: http://www.sabayonlinux.org/forum/viewtopic.php?t=3008&postdays=0&postorder=asc&start=0

And it works beautifully! Extremely fast boot! :)

2 minor problems:

1) Somehow I can't get a menu. I renamed the isolinux.cfg to syslinux.cfg and changed the pathnames like the tutorial said, and I added a menu-item that is similar to "sabayon", named "basnoff". On the "boot:" prompt I can type Basnoff, and it works as intended, but there's no menu. I read somewhere that I had to run "syslinux /dev/sdb1" after editing the cfg, but that didn't help...
2) I'm doing something wrong with Xsistence; it searches USB-drives for 10 seconds, and complains about not being able to find a suitable device.

I'm using a OCZ Rally2 4gig USB-stick (64 MB FAT32, rest is Ext3) and the 3.3 x86 DVD.

I can definitely live with the way it works now, but it would be nice if anyone could tell me what I'm doing wrong here! :)

My syslinux.cfg:
Code: Select all
DEFAULT sabayon
GFXBOOT bootlogo
GFXBOOT-BACKGROUND 0xB63E3A
APPEND  root=/dev/ram0 initrd=sabayon.igz unionfs init=/linuxrc cdroot looptype=squashfs max_loop=64 loop=/livecd.squashfs splash=silent,theme:sabayon vga=791 CONSOLE=/dev/tty1 quiet dodmraid pci=nomsi --

LABEL sabayon
  menu label Start SabayonLinux 3.3
  kernel sabayon
  append root=/dev/ram0 initrd=sabayon.igz unionfs init=/linuxrc cdroot looptype=squashfs max_loop=64 loop=/livecd.squashfs splash=silent,theme:sabayon vga=791 CONSOLE=/dev/tty1 quiet dodmraid pci=nomsi music --

LABEL basnoff
  menu label Start SabayonLinux 3.3 - Basnoff's Way
  kernel sabayon
  append root=/dev/ram0 initrd=sabayon.igz unionfs init=/linuxrc cdroot looptype=squashfs max_loop=64 loop=/livecd.squashfs splash=silent,theme:sabayon vga=791 CONSOLE=/dev/tty1 quiet dodmraid pci=nomsi xsistence noaccelmanager nonxserver lang=nl_NL

LABEL nomusic
  menu label Start without Music
  kernel sabayon
  append root=/dev/ram0 initrd=sabayon.igz unionfs init=/linuxrc cdroot looptype=squashfs max_loop=64 loop=/livecd.squashfs splash=silent,theme:sabayon vga=791 CONSOLE=/dev/tty1 quiet dodmraid pci=nomsi --
LABEL tor
  menu label Anonymous Internet Browsing
  kernel sabayon
  append root=/dev/ram0 initrd=sabayon.igz unionfs init=/linuxrc cdroot looptype=squashfs max_loop=64 loop=/livecd.squashfs splash=silent,theme:sabayon vga=791 CONSOLE=/dev/tty1 quiet dodmraid pci=nomsi tor --
LABEL install
  menu label Start Graphical ^Installation
  kernel sabayon
  append root=/dev/ram0 initrd=sabayon.igz unionfs init=/linuxrc cdroot looptype=squashfs max_loop=64 loop=/livecd.squashfs splash=silent,theme:sabayon vga=791 CONSOLE=/dev/tty1 quiet dodmraid pci=nomsi installer-gui --
LABEL text-install
  menu label Start Text ^Installation
  kernel sabayon
  append root=/dev/ram0 initrd=sabayon.igz unionfs init=/linuxrc cdroot looptype=squashfs max_loop=64 loop=/livecd.squashfs splash=silent,theme:sabayon vga=791 CONSOLE=/dev/tty1 quiet dodmraid pci=nomsi installer-text nox --

LABEL sauerbraten
  menu label Play with Sa^uerbraten
  kernel sabayon
  append root=/dev/ram0 initrd=sabayon.igz unionfs init=/linuxrc cdroot looptype=squashfs max_loop=64 loop=/livecd.squashfs splash=silent,theme:sabayon vga=791 CONSOLE=/dev/tty1 quiet dodmraid pci=nomsi sauerbraten --

LABEL coldwar
  menu label Play with C^oldWar (demo)
  kernel sabayon
  append root=/dev/ram0 initrd=sabayon.igz unionfs init=/linuxrc cdroot looptype=squashfs max_loop=64 loop=/livecd.squashfs splash=silent,theme:sabayon vga=791 CONSOLE=/dev/tty1 quiet dodmraid pci=nomsi coldwar --

LABEL genuine
  menu label Start in safe ^mode
  kernel sabayon
  append root=/dev/ram0 initrd=sabayon.igz unionfs init=/linuxrc cdroot looptype=squashfs max_loop=64 loop=/livecd.squashfs splash=silent,theme:sabayon vga=788 noproprietary genuine res=1024x768 refresh=60 hsync=43-51 pci=routeirq irqpoll noddc CONSOLE=/dev/tty1 quiet dodmraid pci=nomsi --
LABEL console
  menu label Start in ^Console mode
  kernel sabayon
  append root=/dev/ram0 initrd=sabayon.igz unionfs init=/linuxrc cdroot looptype=squashfs max_loop=64 loop=/livecd.squashfs splash=silent,theme:sabayon vga=791 nox CONSOLE=/dev/tty1 quiet dodmraid pci=nomsi --

LABEL internetkiosknx
  menu label Start in ^Internet Kiosk NX mode
  kernel sabayon
  append root=/dev/ram0 initrd=sabayon.igz unionfs init=/linuxrc cdroot looptype=squashfs max_loop=64 loop=/livecd.squashfs splash=silent,theme:sabayon vga=791 internetkiosk nxclient CONSOLE=/dev/tty1 quiet dodmraid pci=nomsi --

LABEL geexbox
  menu label St^art GeeXboX Media Center
  kernel /GEEXBOX/boot/vmlinuz
  append initrd=/GEEXBOX/boot/initrd.gz root=/dev/ram0 rw init=linuxrc boot=cdrom splash=silent vga=788 video=vesafb:ywrap,mtrr quiet dodmraid pci=nomsi --
LABEL mediacenter
  menu label Start Free^vo Media Center
  kernel sabayon
  append root=/dev/ram0 initrd=sabayon.igz unionfs init=/linuxrc cdroot looptype=squashfs max_loop=64 loop=/livecd.squashfs splash=silent,theme:sabayon vga=791 CONSOLE=/dev/tty1 quiet dodmraid pci=nomsi mediacenter res=800x600 --


LABEL debug
  menu label Deb^ug mode
  kernel sabayon
  append root=/dev/ram0 initrd=sabayon.igz unionfs init=/linuxrc cdroot looptype=squashfs max_loop=64 loop=/livecd.squashfs CONSOLE=/dev/tty1 --

LABEL memtest
  menu label Memory ^test
  kernel memtest86
  append -

LABEL hd
  menu label ^Boot from first hard disk
  localboot 0x80
  append -

DISPLAY isolinux.txt
TIMEOUT 300
PROMPT 1
F1 f1.txt
F2 f2.txt
F3 f3.txt
F4 f4.txt
F5 f5.txt
F6 f6.txt
F7 f7.txt
F8 f8.txt
Basnoff
Young Hen
 
Posts: 36
Joined: Wed Apr 05, 2006 20:40
Location: Netherlands

1 down...

Postby Basnoff » Tue Mar 27, 2007 21:27

Fixed number 2 from previous post by creating a third partition and creating xsistence-mode there...

That leaves only the missing menu! :)
Basnoff
Young Hen
 
Posts: 36
Joined: Wed Apr 05, 2006 20:40
Location: Netherlands

Postby xdre » Wed Apr 25, 2007 16:08

Hi, I've tried this tutorial but no luck. I keep getting this error:

Code: Select all
>> Loading unionfs module
>> Mounting ramdisk to /memory for unionfs support...
>> Attemption to mount media:- /dev/sr0
>> Attempting to mount media:- /dev/sda
>> Attempting to mount media:- /dev/sda1
>> No bootable medium found.  Waiting for new devices...
>> Attemption to mount media:- /dev/sr0
>> Attempting to mount media:- /dev/sda
>> Attempting to mount media:- /dev/sda1
umount: Couldn't umount /newroot: Invalid argument
!! Could not find CD to boot, something else needed!
>> Determining root device...
!! The root block device is unspecified or not detected.
   Please specify a device to boot, or "shell" for a shell...
boot() ::


At first I thought it was because the usb stick was not settling fast enough, but I tried it again in emulation so that it would "see" the stick as a normal hard drive with the same results. Even dropping to the shell and trying to mount /dev/sda1, mount gives back an invalid argument error. Any ideas or suggestions?
xdre
Baby Hen
 
Posts: 7
Joined: Thu Mar 15, 2007 14:50

Next

Return to Sabayon Linux General Discussion

Who is online

Users browsing this forum: No registered users and 2 guests