Xgl e due schede video

Tutto ciò che è pertinente a Sabayon Linux, indipendentemente dall'architettura e dall'ambiente grafico

Moderator: Moderators

Xgl e due schede video

Postby Benna » Sun Apr 09, 2006 16:58

ciao a tutti,
ho scaricato l'ultima versione di RR64 e ho dei problemi con il server x e xgl;
nel mio pc ci sono due schede video: una ati x800 AGP come primaria e una 3dfx Voodoo5 PCI come secondaria,
inserendo il livecd e boottando con "gentoo xgl" riconosce la ati e installa le opengl adatte, poi configura correttamente x e xgl ma nell'avviare x ritorna alla shell; provando a digitare "startx" fa un tentativo e poi esce un errore del tipo "no screen found"
da cosa pu? dipendere?
dato che i driver ATI per linux non sono il massimo sarebbe eventualmente possibile avviare xgl con la 3dfx?
grazie per l'attenzione
Benna
Baby Hen
 
Posts: 6
Joined: Fri Apr 07, 2006 19:22

Postby Benna » Mon Apr 10, 2006 16:34

:(
Benna
Baby Hen
 
Posts: 6
Joined: Fri Apr 07, 2006 19:22

Postby scoppy » Mon Apr 10, 2006 17:52

con le ati no parte

con la voodoo5 defi fana prova forzando l'eselet opengl (ma non so nemmeno se la supporta)

al momento tutte le non ati e non nvidia ( parte qualte intel) fanno strani effetti a xgl)

ps per assurdo la voodoo 5 parte a prima botta ? un miracolo della 3dfx
scoppy
Young Hen
 
Posts: 28
Joined: Tue Jan 03, 2006 3:24

Postby Benna » Tue Apr 11, 2006 13:03

e come si fa a forzare l'eselet opengl?
ma soprattutto come faccio a indicare a x che voglio usare la 3dfx (secondaria) e non la ati (primaria)? devo modificare l'impostazione nel bios?
Benna
Baby Hen
 
Posts: 6
Joined: Fri Apr 07, 2006 19:22

Postby lxnay » Tue Apr 11, 2006 14:32

Sui parametri di boot:

gentoo opengl=ati

per esempio. Oppure opengl=nvidia o opengl=xorg-x11
lxnay
Land Owner
 
Posts: 3596
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Postby Benna » Fri Apr 14, 2006 12:29

ho riprovato forzando xorg-x11 al boot, entrato nella shell ho digitato startx e mi si ? aperto xterm; per? non sono riuscito ad avviare ne kde (scrivendo kdm non succede nulla) ne gnome (scrivendo gdm mi da un errore dicendo che x non ? attivo)
Benna
Baby Hen
 
Posts: 6
Joined: Fri Apr 07, 2006 19:22

Postby lxnay » Fri Apr 14, 2006 17:37

gentoo xgl opengl=xorg-x11
lxnay
Land Owner
 
Posts: 3596
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Postby Benna » Wed Apr 19, 2006 17:39

è quello che ho scritto al boot
Benna
Baby Hen
 
Posts: 6
Joined: Fri Apr 07, 2006 19:22

Postby Benna » Sat Apr 29, 2006 15:29

alle tante sono riuscito a far partire kde e gnome con rr4 e la voodoo5 (con rr64 non ho ancora provato), inizialmente il server x sembra partire ma poi torna alla console, a quel punto scrivo startx e mi si apre xterm, scrivendo in xterm startkde o gnome-session si avviano le due interfacce grafiche che però sono visualizzate come finestre di xterm; in ogni modo xgl non funziona :cry:
Benna
Baby Hen
 
Posts: 6
Joined: Fri Apr 07, 2006 19:22


Return to Sabayon Linux Discussioni Generali

Who is online

Users browsing this forum: No registered users and 0 guests

cron