Pas d'accélération avec carte ati

Conversations générales au sujet de Sabayon Linux

Moderator: Moderators

Pas d'accélération avec carte ati

Postby alexajaccio » Tue Feb 06, 2007 14:07

Salut tout le monde,

Je n'arrive pas a activé l'acceleration graphique, j'ai essayer tout plein de modification mais rien a faire.
Pas pratique pour les jeux video :)
quelqu'un a la Solution?
Merci
alexajaccio
Baby Hen
 
Posts: 7
Joined: Fri Feb 02, 2007 14:48

Postby turquoise » Tue Feb 06, 2007 14:17

Commence par nous donner ton modele de carte et une liste de ce que tu as essaye...
Ma philosophie d'apprentissage : essayer, et si ça casse, essayer de réparer.
My learning philosophy: try it, and if it breaks, try to fix it.
Image
turquoise
Old Dear Hen
 
Posts: 719
Joined: Wed Nov 15, 2006 1:14
Location: Abitibi-Témiscamingue!

Postby alexajaccio » Tue Feb 06, 2007 15:42

oui c mieu lol

Une ATI X600 SE.

J'ai reussi a récupérer un xorg.conf pour qui correspond a mon pc portable. ce xorg.conf a deja fonctioné avec une gentoo, mais ne veut pas fonctioné sur sabayon, quand je le met et que je lance xdm, j'ai l'impression de regarder canal +. Avec la conf d'origine tout marche bien sauf qu'il n'ya pas d'acceleration.
Merci turquoise de ton aide.
Je te donne le xorg que j'essaye de mettre en place.


# **********************************************************************
# DRI Section
# **********************************************************************
Section "dri"
Mode 0666
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

# **********************************************************************
# Module section -- this section is used to specify
# which dynamically loadable modules to load.
# **********************************************************************
#
Section "Module"

# This loads the DBE extension module.

Load "dbe" # Double buffer extension

# This loads the miscellaneous extensions module, and disables
# initialisation of the XFree86-DGA extension within that module.
SubSection "extmod"
Option "omit xfree86-dga" # don't initialise the DGA extension
EndSubSection

# This loads the Type1 and FreeType font modules
Load "type1"
Load "freetype"

# This loads the GLX module
Load "glx" # libglx.a
Load "dri" # libdri.a

EndSection

# **********************************************************************
# Files section. This allows default font and rgb paths to be set
# **********************************************************************

Section "Files"
InputDevices "/dev/ttyS0"
InputDevices "/dev/ttyS1"
InputDevices "/dev/ttyS2"
InputDevices "/dev/ttyS3"
InputDevices "/dev/ttyS4"
InputDevices "/dev/ttyS5"
InputDevices "/dev/ttyS6"
InputDevices "/dev/ttyS7"
InputDevices "/dev/ttyS8"
InputDevices "/dev/psaux"
InputDevices "/dev/logibm"
InputDevices "/dev/sunmouse"
InputDevices "/dev/atibm"
InputDevices "/dev/amigamouse"
InputDevices "/dev/atarimouse"
InputDevices "/dev/inportbm"
InputDevices "/dev/gpmdata"
InputDevices "/dev/mouse"
InputDevices "/dev/usbmouse"
InputDevices "/dev/adbmouse"
InputDevices "/dev/input/mice"
InputDevices "/dev/input/event0"
InputDevices "/dev/pointer0"
InputDevices "/dev/pointer1"
InputDevices "/dev/pointer2"
InputDevices "/dev/pointer3"
EndSection


Section "ServerFlags"
Option "AllowMouseOpenFail"
EndSection

# **********************************************************************
# Input devices
# **********************************************************************

Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "fr"
Option "XkbModel" "pc105"
Option "XkbRules" "xfree86"
EndSection

Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Device" "/dev/input/mice"
Option "Name" "PS/2 Mouse"
# Option "Protocol" "explorerps/2"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Vendor" "Sysp"
EndSection

Section "InputDevice"
Driver "synaptics"
Identifier "Mouse[3]"
Option "AccelFactor" "0.01"
Option "BottomEdge" "650"
Option "CircScrollDelta" "0.1"
Option "CircScrollTrigger" "2"
Option "CircularScrolling" "1"
Option "Device" "/dev/input/mice"
Option "EdgeMotionMaxSpeed" "15"
Option "EdgeMotionMinSpeed" "15"
Option "Emulate3Buttons" "on"
Option "EmulateMidButtonTime" "75"
Option "FingerHigh" "15"
Option "FingerLow" "14"
Option "HorizScrollDelta" "20"
Option "LeftEdge" "120"
Option "MaxSpeed" "0.5"
Option "MaxTapMove" "110"
Option "MaxTapTime" "180"
Option "MinSpeed" "0.2"
Option "Name" "Touchpad"
Option "Protocol" "auto-dev"
Option "RightEdge" "830"
Option "SHMConfig" "on"
Option "TopEdge" "120"
Option "UpDownScrolling" "1"
Option "Vendor" "ALPS"
Option "VertScrollDelta" "20"
Option "ZAxisMapping" "4 5"
EndSection


# **********************************************************************
# Monitor section
# **********************************************************************

# Any number of monitor sections may be present

Section "Monitor"
Identifier "Monitor0"
EndSection


# **********************************************************************
# Graphics device section
# **********************************************************************

# Any number of graphics device sections may be present

# Standard VGA Device:

Section "Device"
Identifier "Standard VGA"
VendorName "Unknown"
BoardName "Unknown"

# The chipset line is optional in most cases. It can be used to override
# the driver's chipset detection, and should not normally be specified.

# Chipset "generic"

# The Driver line must be present. When using run-time loadable driver
# modules, this line instructs the server to load the specified driver
# module. Even when not using loadable driver modules, this line
# indicates which driver should interpret the information in this section.

Driver "vga"
# The BusID line is used to specify which of possibly multiple devices
# this section is intended for. When this line isn't present, a device
# section can only match up with the primary video device. For PCI
# devices a line like the following could be used. This line should not
# normally be included unless there is more than one video device
# installed.

# BusID "PCI:0:10:0"

# VideoRam 256

# Clocks 25.2 28.3

EndSection

# === ATI device section ===

Section "Device"
Identifier "ATI Graphics Adapter"
Driver "fglrx"
# ### generic DRI settings ###
# === disable PnP Monitor ===
#Option "NoDDC"
# === disable/enable XAA/DRI ===
Option "no_accel" "no"
Option "no_dri" "no"
# === misc DRI settings ===
Option "mtrr" "off" # disable DRI mtrr mapper, driver has its own code for mtrr
# ### FireGL DDX driver module specific settings ###
# === Screen Management ===
Option "DesktopSetup" "clone"
Option "ScreenOverlap" "0"
# === TV-out Management ===
Option "TVFormat" "PAL-I"
Option "TVStandard" "NTSC-M"
Option "TVHSizeAdj" "0"
Option "TVVSizeAdj" "0"
Option "TVHPosAdj" "0"
Option "TVVPosAdj" "0"
Option "TVHStartAdj" "0"
Option "TVColorAdj" "0"
Option "GammaCorrectionI" "0x06419064"
Option "GammaCorrectionII" "0x06419064"
# === OpenGL specific profiles/settings ===
Option "Capabilities" "0x00000000"
Option "CapabilitiesEx" "0x00000000"
# === Video Overlay for the Xv extension ===
Option "VideoOverlay" "on"
# === OpenGL Overlay ===
# Note: When OpenGL Overlay is enabled, Video Overlay
# will be disabled automatically
Option "OpenGLOverlay" "off"
# === Center Mode (Laptops only) ===
Option "CenterMode" "off"
# === Pseudo Color Visuals (8-bit visuals) ===
Option "PseudoColorVisuals" "off"
# === QBS Management ===
Option "Stereo" "off"
Option "StereoSyncEnable" "1"
# === FSAA Management ===
Option "FSAAEnable" "no"
Option "FSAAScale" "1"
Option "FSAADisableGamma" "no"
Option "FSAACustomizeMSPos" "no"
Option "FSAAMSPosX0" "0.000000"
Option "FSAAMSPosY0" "0.000000"
Option "FSAAMSPosX1" "0.000000"
Option "FSAAMSPosY1" "0.000000"
Option "FSAAMSPosX2" "0.000000"
Option "FSAAMSPosY2" "0.000000"
Option "FSAAMSPosX3" "0.000000"
Option "FSAAMSPosY3" "0.000000"
Option "FSAAMSPosX4" "0.000000"
Option "FSAAMSPosY4" "0.000000"
Option "FSAAMSPosX5" "0.000000"
Option "FSAAMSPosY5" "0.000000"
# === Misc Options ===
Option "UseFastTLS" "0"
Option "BlockSignalsOnLock" "on"
Option "UseInternalAGPGART" "yes"
Option "ForceGenericCPU" "no"
# BusID "PCI:1:0:0" # no device found at config time
Screen 0
ChipID 0x3150
EndSection

# **********************************************************************
# Screen sections
# **********************************************************************

# Any number of screen sections may be present. Each describes
# the configuration of a single screen. A single specific screen section
# may be specified from the X server command line with the "-screen"
# option.
Section "Screen"
Identifier "Screen0"
Device "ATI Graphics Adapter"
Monitor "Monitor0"
DefaultDepth 24
#Option "backingstore"

Subsection "Display"
Depth 24
Modes "1280x800"
ViewPort 0 0 # initial origin if mode is smaller than desktop
# Virtual 1280 1024
EndSubsection
EndSection

# **********************************************************************
# ServerLayout sections.
# **********************************************************************

# Any number of ServerLayout sections may be present. Each describes
# the way multiple screens are organised. A specific ServerLayout
# section may be specified from the X server command line with the
# "-layout" option. In the absence of this, the first section is used.
# When now ServerLayout section is present, the first Screen section
# is used alone.

Section "ServerLayout"

# The Identifier line must be present
Identifier "Server Layout"

# Each Screen line specifies a Screen section name, and optionally
# the relative position of other screens. The four names after
# primary screen name are the screens to the top, bottom, left and right
# of the primary screen.

Screen "Screen0"

# Each InputDevice line specifies an InputDevice section name and
# optionally some options to specify the way the device is to be
# used. Those options include "CorePointer", "CoreKeyboard" and
# "SendCoreEvents".

InputDevice "Mouse[1]" "CorePointer"
InputDevice "Mouse[3]" "SendCoreEvents"
InputDevice "Keyboard[0]" "CoreKeyboard"

EndSection

### EOF ###
alexajaccio
Baby Hen
 
Posts: 7
Joined: Fri Feb 02, 2007 14:48

Postby turquoise » Sat Feb 10, 2007 17:35

Ok, utilises-tu les pilotes libres ou propriétaires? En principe, ta carte est supportée par les pilotes propriétaires, donc tu pourrais essayer de les installer si ce n'est pas déjà fait et utiliser aticonfig pour configurer ta carte.

Tu peux aussi essayer eselect opengl set ati pour activer opengl. Dans le cas des pilotes libres, il se peut que ce soit eselect opengl set xorg, mais je n'en suis pas certaine...

Désolée pour le delai, mais j'ai trouvé un (autre) moyen pour bousiller mon installation de Sabayon...
Ma philosophie d'apprentissage : essayer, et si ça casse, essayer de réparer.
My learning philosophy: try it, and if it breaks, try to fix it.
Image
turquoise
Old Dear Hen
 
Posts: 719
Joined: Wed Nov 15, 2006 1:14
Location: Abitibi-Témiscamingue!

Postby alexajaccio » Sun Feb 11, 2007 11:23

Salut

Les drivers proprio sont installer avec sabayon je crois car quand je regarde le xorg.conf apres l'install, il utilise déja les drivers fglrx.
J'ai aussi utiliser la commande eselect opengl set ati pour activer opengl comme tu me la dit.
Mais j'ai toujour:
direct rendering: No

J'espere que ta resolu le probléme avec ton pc. moi pour l'instant ca va, j'ai fait juste deux install.
une 3.25 et l'autre 3.26 donc c'est ok pour. je voudrais juste resoudre le "probleme" de la carte video.

Merci a toi
alexajaccio
Baby Hen
 
Posts: 7
Joined: Fri Feb 02, 2007 14:48

Postby jay73 » Fri Mar 02, 2007 4:27

Section "Extensions"
Option "'Composite" "Disable"
EndSection

Section "ServerFlags"
Option "AIGLX" "off"
EndSection
jay73
Young Hen
 
Posts: 36
Joined: Tue Feb 13, 2007 23:59
Location: Belgium

Postby Terneuv » Sun Mar 04, 2007 20:41

Salut ,
J'ai une ATI X800GT . Avec la 3.26 en live , il me propose la "3D" , aucun souci .
Il y a deux modes , dont un est dédié a ATI et l'autre a NVIDIA .
Si un "maitre" pouvait nous éclairer , merci :wink:

Oups , je viens de voir cela :
http://www.sabayonlinux.org/forum/viewtopic.php?t=1843
Terneuv
Baby Hen
 
Posts: 15
Joined: Mon Jan 15, 2007 12:57

Postby turquoise » Tue Mar 06, 2007 15:20

Le support des cartes ATI est assez particulier, certaines cartes doivent etre utilisées avec les pilotes open source et d'autres avec les pilotes propriétaires et encore, il faut avior la bonne version des pilotes, car les pilotes fournis par ATI sont moins universels que ceux fournis pour les cartes NVIDIA...

D'ailleurs, s'il y a quelqu'un qui s'y connait un peu, ce serait sympa d'avoir un tuto détaillé, parce que je veux bien essayer d'aider les gens a trouver des solutions, mais je n'y connais que dalle.
Ma philosophie d'apprentissage : essayer, et si ça casse, essayer de réparer.
My learning philosophy: try it, and if it breaks, try to fix it.
Image
turquoise
Old Dear Hen
 
Posts: 719
Joined: Wed Nov 15, 2006 1:14
Location: Abitibi-Témiscamingue!


Return to French

Who is online

Users browsing this forum: No registered users and 2 guests

cron