Firewall - after restarting the system returns to the previous setting (inactive) [Solved]

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :)

Moderator: Moderators

Post Reply
kris-kris
Young Hen
Posts: 24
Joined: Mon May 04, 2020 19:45
Location: Poland, Warsaw

Firewall - after restarting the system returns to the previous setting (inactive) [Solved]

Post by kris-kris » Wed Sep 30, 2020 20:10

The firewall is set this way after booting up the system

Code: Select all

$ sudo ufw status
Hasło: 
Status: inactive
I enter this command

Code: Select all

$ sudo ufw enable
Firewall is active and enabled on system startup
And after restart, the firewall is inactive again. I think there is some bug in the kernel, because this command should make permanent changes and the firewall should be active after restart.

Code: Select all

$ uname -r
5.4.0-sabayon
System up to date. Until today all updates have been uploaded.
Last edited by kris-kris on Thu Oct 01, 2020 12:01, edited 1 time in total.

joost
Sagely Hen
Posts: 2822
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands
Contact:

Re: Firewall - after restarting the system returns to the previous setting (inactive)

Post by joost » Wed Sep 30, 2020 22:04

Not very good at the subject, but have you looked into firewalld?
My blog | Mastodon | Please support Sabayon: Become a Patron

User avatar
sabayonino
Sagely Hen
Posts: 3569
Joined: Sun Sep 21, 2008 1:12
Location: Italy
Contact:

Re: Firewall - after restarting the system returns to the previous setting (inactive)

Post by sabayonino » Thu Oct 01, 2020 11:20

UFS has its own service

Code: Select all

sudo systemctl enable ufw

Code: Select all

Created symlink /etc/systemd/system/multi-user.target.wants/ufw.service → /lib/systemd/system/ufw.service.
Firewalld service must be enabled and running.

kris-kris
Young Hen
Posts: 24
Joined: Mon May 04, 2020 19:45
Location: Poland, Warsaw

Re: Firewall - after restarting the system returns to the previous setting (inactive)

Post by kris-kris » Thu Oct 01, 2020 11:58

sabayonino wrote:
Thu Oct 01, 2020 11:20
UFS has its own service

Code: Select all

sudo systemctl enable ufw

Code: Select all

Created symlink /etc/systemd/system/multi-user.target.wants/ufw.service → /lib/systemd/system/ufw.service.
Firewalld service must be enabled and running.
thanks, now it works. :)

kellyma53
Baby Hen
Posts: 1
Joined: Sun Oct 25, 2020 4:18
Contact:

Re: Firewall - after restarting the system returns to the previous setting (inactive) [Solved]

Post by kellyma53 » Sun Oct 25, 2020 4:26

Sinceramente me parece de gran utilidad, aunque no se mucho de ello

Post Reply