How to setup the locales? [Solved]

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

msdobrescu
Old Dear Hen
Posts: 867
Joined: Sun Aug 21, 2011 8:48

Re: How to setup the locales? [Solved]

Post by msdobrescu » Tue May 12, 2020 5:58

Fitzcarraldo wrote:
Tue May 12, 2020 1:00
The KDE edition of SL (Sabayon Linux).
Is there a specific package or meta?
What do you recommend?
Last edited by msdobrescu on Sat Jun 13, 2020 8:18, edited 1 time in total.

Fitzcarraldo
Sagely Hen
Posts: 8217
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom
Contact:

Re: How to setup the locales?

Post by Fitzcarraldo » Tue May 12, 2020 7:40

Yes, the Daily ISO: http://sabayonlinux.mirror.garr.it/mirr ... 64_KDE.iso

I suggest you make a backup of your documents, music, pictures etc. from the home directory, then install SL KDE from the latest ISO.

Also have a look in the file /home/msdobrescu/.config/plasma-localerc to make sure it contains the locale:

Code: Select all

$ cat ~/.config/plasma-localerc
[Formats]
LANG=en_GB.UTF-8
You could try editing it to add the other desired settings in there as well:

Code: Select all

[Formats]
LANG=en_GB.UTF-8
LC_CTYPE=en_GB.UTF-8
LC_NUMERIC=ro_RO.UTF-8
LC_TIME=en_GB.UTF-8
LC_COLLATE=en_GB.UTF-8
LC_MONETARY=ro_RO.UTF-8
LC_MESSAGES=en_GB.UTF-8
LC_PAPER=en_GB.UTF-8
LC_NAME=en_GB.UTF-8
LC_ADDRESS=en_GB.UTF-8
LC_TELEPHONE=en_GB.UTF-8
LC_MEASUREMENT=en_GB.UTF-8
LC_IDENTIFICATION=en_GB.UTF-8
useDetailed=true
Alternatively, deleting that file should make KDE Plasma pick up the values of these variables from the system settings (see my previous posts).

msdobrescu
Old Dear Hen
Posts: 867
Joined: Sun Aug 21, 2011 8:48

Re: How to setup the locales?

Post by msdobrescu » Sat Jun 13, 2020 8:17

Hi, I have found the problem in /etc/env.d/02locale, there was a character introduced probably by mistake.
Works fine now, thanks.

Post Reply