Wine doesn't work [Solved]

Discussions Regarding Software

Moderator: Moderators

Post Reply
Duskmourn
Baby Hen
Posts: 14
Joined: Thu Dec 19, 2019 1:08

Wine doesn't work [Solved]

Post by Duskmourn » Fri Feb 21, 2020 20:40

So I have a fresh install of Sabayon here, installed from a daily iso, and wine doesn't seem to work at all. I get this error when I try to run just "wine" in the terminal

Code: Select all

/usr/bin/wine: line 2: /usr/lib/wine-staging-5.0/bin/wine: No such file or directory
And then running "winecfg" gives me this error

Code: Select all

/usr/lib/wine-staging-5.0/bin/winecfg: line 47: /usr/lib/wine-staging-5.0/bin/wine: No such file or directory
I have wine 0-r7 and wine-staging 5.0-0 packages installed from the sabayon-weekly repo for reference. Anyone else having this issue or is something on my system just broken?
Last edited by Duskmourn on Tue Feb 25, 2020 0:23, edited 1 time in total.

Stupot
Sagely Hen
Posts: 1799
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: Wine doesn't work

Post by Stupot » Fri Feb 21, 2020 20:44

I do not have that problem, although I have app-emulation/wine-staging-4.16 instead of wine-stanging-5.0-0 installed. Try seeing if wine-staging-4.16 runs for you. If so, maybe the problem is wine-staging-5 ?

Duskmourn
Baby Hen
Posts: 14
Joined: Thu Dec 19, 2019 1:08

Re: Wine doesn't work

Post by Duskmourn » Fri Feb 21, 2020 20:54

No, that didn't work either.

Code: Select all

/usr/bin/wine: line 2: /usr/lib/wine-staging-4.16/bin/wine: No such file or directory

Code: Select all

/usr/lib/wine-staging-4.16/bin/winecfg: line 47: /usr/lib/wine-staging-4.16/bin/wine: No such file or directory

Stupot
Sagely Hen
Posts: 1799
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: Wine doesn't work

Post by Stupot » Mon Feb 24, 2020 15:38

If you attempt to cd to get to e.g. /usr/lib/wine-staging-4.16/bin can you? If not, where do you get stuck? If you don't get stuck, what is in that directory? Do an

Code: Select all

ls -la
if you get there.

Duskmourn
Baby Hen
Posts: 14
Joined: Thu Dec 19, 2019 1:08

Re: Wine doesn't work

Post by Duskmourn » Tue Feb 25, 2020 0:22

The daily iso I installed from turned out to have a broken symlink between /lib32 and /lib64, so multilib was broken, which caused wine, a 32 bit program, to not work in turn. Enlik helped me figure this out and added it to the bug tracker. Marking as solved.

Stupot
Sagely Hen
Posts: 1799
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: Wine doesn't work [Solved]

Post by Stupot » Tue Feb 25, 2020 19:35

That's exactly what I was wondering was happening. Glad you got things sorted out.

User avatar
sabayonino
Sagely Hen
Posts: 3545
Joined: Sun Sep 21, 2008 1:12
Location: Italy
Contact:

Re: Wine doesn't work [Solved]

Post by sabayonino » Tue Feb 25, 2020 20:23

New daily was build from stage3 and new profile 17.1 , so /lib is not a symlink points to /lib64 anymore.
Some applications could be rebuild

see https://groups.google.com/forum/#!topic ... 3zfbFJcGls

toyarmo
Baby Hen
Posts: 1
Joined: Wed Aug 26, 2020 4:39
Contact:

Re: Wine doesn't work [Solved]

Post by toyarmo » Wed Aug 26, 2020 4:45

Que buen post, tuvbe el mismo problema y tu post me ayudo

Post Reply