Entropy equo upgrade/downgrade cups issue/question

Anything that pertains to Entropy, Equo or Sulfur

Moderator: Moderators

Post Reply
HadwinHohenzollern
Baby Hen
Posts: 2
Joined: Thu Jan 23, 2020 16:39

Entropy equo upgrade/downgrade cups issue/question

Post by HadwinHohenzollern » Fri Jan 24, 2020 12:24

Index
mybackground

Blabla to my issue

The Question


[Just my knowlegde background]
Hello Sabayon Board,
I am pretty new and learning my first ever IT-job.
As part of training I was to look into Gentoo to get some experience with the Linux world as I was only using casually my computer for playing so I wanted to take a small dive into the sabayon plattform and the entropy package manager.


blabla to my issue

My issue is,
After setting up everything up. I want to connect and authenticate with a windows print server and use my credentials it works,
but after

"equo upgrade"

and going from net-print/cups-2.2.1-r1 to 2.3.1
I get an error message NT_STATUS_ACCESS_DENIED

My printers.conf also changes and adds a line that was not there before.
I have both printer.conf files at the end of the post.
I can't change or remove AuthInfoRequired negotiate or remove it it keeps appearing.
Yes I turned off the cups services before making changes to the printers.conf file also.
I feel a bit clueless.....

Before anyone says I should post it somewhere else.

The Question

My Question is
How can I use entropy/equo to install a older version of cups? When I try to install the version before it obviously isn’t in the repository as there is only the newest.
Do I have to learn to create my own Repo?
Or are there older ones maintaned for stability sake?
Otherwise I can only use the basic version that comes with the ISO, if I want to print over the network?

preUpdate

Code: Select all

# Printer configuration file for CUPS v2.2.8
# Written by cupsd on 2020-01-22 15:19
# DO NOT EDIT THIS FILE WHEN CUPSD IS RUNNING
<Printer Name>
UUID urn:uuid:this:is:right:too
Info Unknown
Location everywhere
MakeModel PrinterModel 
DeviceURI smb://workgroup/username:[email protected](hostname)/printername
State Idle
StateTime 1579702736
ConfigTime 1579702729
Type 8433756
Accepting Yes
Shared No
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
OpPolicy default
ErrorPolicy stop-printer
</Printer
>
Postupdate

Code: Select all

# Printer configuration file for CUPS v2.2.8
# Written by cupsd on 2020-01-24 12:26
# DO NOT EDIT THIS FILE WHEN CUPSD IS RUNNING
<Printer Name>
UUID urn:uuid:this:is:right:too
AuthInfoRequired negotiate
Info Unknown
Location everywhere
MakeModel PrinterModel
DeviceURI smb://workgroup/username:[email protected](hostname)/printername
State Idle
StateTime 1579865176
ConfigTime 1579702729
Type 8433756
Accepting Yes
Shared No
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
OpPolicy default
ErrorPolicy stop-printer
</Printer>

Stupot
Sagely Hen
Posts: 1758
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: Entropy equo upgrade/downgrade cups issue/question

Post by Stupot » Fri Jan 24, 2020 16:17

Well, I can't say I've found a good solution to the problem without downgrading packages, but I found this arch thread where they're exploring the problem: https://bbs.archlinux.org/viewtopic.php?id=245658

It seems like the problem has more to do with samba than cups? Or maybe a combination of the two. Samba was last updated for Sabayon in December.

Stupot
Sagely Hen
Posts: 1758
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: Entropy equo upgrade/downgrade cups issue/question

Post by Stupot » Fri Jan 24, 2020 16:21

This redhat thread too: https://bugzilla.redhat.com/show_bug.cgi?id=1706316

Can you try to edit the printer.conf to have this line instead:
AuthInfoRequired username,password

(use username,password, the literal words, don't replace with your actual username and password).

HadwinHohenzollern
Baby Hen
Posts: 2
Joined: Thu Jan 23, 2020 16:39

Re: Entropy equo upgrade/downgrade cups issue/question

Post by HadwinHohenzollern » Wed Jan 29, 2020 13:28

Stupot thanks for the reply.
I already tried to edit the printer.conf to that line and I terminated the cups service too before editing. It just resets itself back to "negotiate".
I will look into the issue on the arch forum and see if that helps in someway, thanks for sharing this link. :)
If I find a solution somehow. I will def update this thread.

Post Reply