Sound pops and cracks

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

msdobrescu
Old Dear Hen
Posts: 700
Joined: Sun Aug 21, 2011 8:48

Sound pops and cracks

Post by msdobrescu » Mon Dec 31, 2018 6:29

Hello,

I have a SB X-Fi Surround 5.1 Pro and a Hauppauge WinTV HVR-930C, I use KDE, VLS, Clementine.
I watch TV in VLC, listen music in Clementine or VLC.
I see in KDE settings having Phonon VLC only (indeed, many alsa related packages are not installed).
My issue started when I have re-installed Sabayon Linux.
The sound is crackling a popping randomly. As I have a dual boot, I have observed it happening in Sabayon Linux only.
What can I do to debug and maybe fix it?
Is there a known driver issue, are there settings to improve the sound? Maybe to set the sample rate?

Thank you.
Last edited by msdobrescu on Sat Mar 09, 2019 0:17, edited 2 times in total.

Stupot
Sagely Hen
Posts: 1715
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: Sound pops and cracks

Post by Stupot » Tue Jan 01, 2019 8:11

Try installing media-libs/phonon-gstreamer and switching the audio backend from VLC to gstreamer.

Even if it that doesn't fix it, it helps narrow down the problem.

msdobrescu
Old Dear Hen
Posts: 700
Joined: Sun Aug 21, 2011 8:48

Re: Sound pops and cracks

Post by msdobrescu » Tue Jan 01, 2019 13:29

How does it help narrowing the problem? Could be the VLC? Or phonon itself?
Done, still popping, but how am I sure it uses one backend and not another?

Stupot
Sagely Hen
Posts: 1715
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: Sound pops and cracks

Post by Stupot » Wed Jan 02, 2019 0:26

System settings -> Multimedia -> Audio and Video -> Backend (tab)

That is where you can set which phonon backend to prefer. And it helps narrow it down because if switching to GStreamer doesn't fix it, then you know that Phonon VLC most likely isn't the problem, rather it lies outside of that. Process of elimination. It doesn't tell you where the problem is, but it tells you where it isn't.

If that really makes no difference, we'll have to look at your drivers, but you haven't really provided any information there. What's the output of

aplay --list-devices

msdobrescu
Old Dear Hen
Posts: 700
Joined: Sun Aug 21, 2011 8:48

Re: Sound pops and cracks

Post by msdobrescu » Wed Jan 02, 2019 0:40

I haven't because I don't know how.

Code: Select all

aplay --list-devices
**** List of PLAYBACK Hardware Devices ****
card 0: Pro [SB X-Fi Surround 5.1 Pro], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Pro [SB X-Fi Surround 5.1 Pro], device 1: USB Audio [USB Audio #1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: Intel [HDA Intel], device 0: AD1989B Analog [AD1989B Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: Intel [HDA Intel], device 1: AD1989B Digital [AD1989B Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: Intel [HDA Intel], device 2: AD1989B Alt Analog [AD1989B Alt Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 3: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 3: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 3: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 3: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Stupot
Sagely Hen
Posts: 1715
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: Sound pops and cracks

Post by Stupot » Wed Jan 02, 2019 22:04

Are you using USB speakers?

msdobrescu
Old Dear Hen
Posts: 700
Joined: Sun Aug 21, 2011 8:48

Re: Sound pops and cracks

Post by msdobrescu » Wed Jan 02, 2019 22:50

No, only the soundcard is USB. The speakers are analog, not digital.

joost
Sagely Hen
Posts: 2732
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands
Contact:

Re: Sound pops and cracks

Post by joost » Thu Jan 03, 2019 14:08

Think this is a Pulseaudio related issue. Have you tried this:

https://elementaryos.stackexchange.com/ ... pulseaudio
Image
My blog | Twitter | Please support Sabayon: Image

msdobrescu
Old Dear Hen
Posts: 700
Joined: Sun Aug 21, 2011 8:48

Re: Sound pops and cracks

Post by msdobrescu » Fri Jan 04, 2019 5:59

Hi, it seemed to work for a few hours.
I've listened in Clementine, for two hours, without problems.
Then watched TV, in VLC. It started to crackle aggressively.
I have stopped VLC, opened it again. It popped now and then, not so often.

msdobrescu
Old Dear Hen
Posts: 700
Joined: Sun Aug 21, 2011 8:48

Re: Sound pops and cracks

Post by msdobrescu » Sat Jan 26, 2019 10:30

Hi, as the issue continues and it's very annoying, where is the reason?
I see several points:
- Phonon bugs
- bad sound drivers for Creative
- it's a USB card, I play music from an external USB drive, mouse and keyboard on USB, a Wacom L tablet on USB, some additional USB external hard drives, a TV tunner on USB... Could be the USB overloaded?

What do you think?

Post Reply