Can't install virtualbox-bin on new installation

Discussion in general that pertains to Sabayon Linux - Must Pertain to Sabayon Linux

Moderator: Moderators

Post Reply
andreios
Simple Hen
Posts: 88
Joined: Fri May 30, 2014 17:17

Can't install virtualbox-bin on new installation

Post by andreios » Fri Dec 14, 2018 0:42

After upgrade I tried installing virtualbox-bin I got this. Can't recreate this on other installs. Everything else seems to work.

Code: Select all

equo i --ask virtualbox-bin    
@@ Calculating dependencies...
@@ Dependencies not found:
!!! Every package matching =sys-kernel/linux-sabayon-4.19.2~-1 is masked.
  # Masking reason: repository general packages.db.mask
  <> atom: sys-kernel/linux-sabayon-4.19.2 in sabayonlinux.org

User avatar
sabayonino
Sagely Hen
Posts: 3368
Joined: Sun Sep 21, 2008 1:12
Location: Italy
Contact:

Re: Can't install virtualbox-bin on new installation

Post by sabayonino » Fri Dec 14, 2018 17:19

you have linux-sabayon-4.19.2 kernel masked

andreios
Simple Hen
Posts: 88
Joined: Fri May 30, 2014 17:17

Re: Can't install virtualbox-bin on new installation

Post by andreios » Sat Dec 15, 2018 14:53

I have nothing done. As in an other thread here described kernel 4.19.2 should be masked because of a bug. But this is a fresh install and I have nothing masked, it's from sabayon. Kernel 4.18.19 is installed! On an other a bit older install I can install virtualbox-bin without problem.

User avatar
sabayonino
Sagely Hen
Posts: 3368
Joined: Sun Sep 21, 2008 1:12
Location: Italy
Contact:

Re: Can't install virtualbox-bin on new installation

Post by sabayonino » Sat Dec 15, 2018 18:17

if you're running 4.18 kernel you should (re)install virtualbox-modules for that kernel

Code: Select all

equo i app-emulation/virtualbox-modules-5.2.22#4.18.0-sabayon

Code: Select all

$ equo s virtualbox-modules -qv
app-emulation/virtualbox-modules-5.2.22#4.14.0-sabayon
app-emulation/virtualbox-modules-5.2.22#4.18.0-sabayon
app-emulation/virtualbox-modules-5.2.22#4.19.0-sabayon
app-emulation/virtualbox-modules-5.2.22#4.4.0-sabayon
app-emulation/virtualbox-modules-5.2.22#4.9.0-sabayon

andreios
Simple Hen
Posts: 88
Joined: Fri May 30, 2014 17:17

Re: Can't install virtualbox-bin on new installation

Post by andreios » Sun Dec 16, 2018 0:16

Well there are no virtualbox-modules installed. It's not much installed at all it's a fresh installation.

Code: Select all

uname -a
Linux sab-pc 4.18.0-sabayon #1 SMP Sun Nov 18 09:52:03 UTC 2018 x86_64 Intel(R) Core(TM) i7-3770 CPU @ 3.40GHz GenuineIntel GNU/Linux
equo i --ask virtualbox-modules
╠  @@ Calculating dependencies...
☢  @@ Dependencies not found:
☛  !!! Every package matching =sys-kernel/linux-sabayon-4.19.2~-1 is masked.
☛     # Masking reason: repository general packages.db.mask
☛      <> atom: sys-kernel/linux-sabayon-4.19.2 in sabayonlinux.org
equo i --ask virtualbox-bin
╠  @@ Calculating dependencies...
☢  @@ Dependencies not found:
☛  !!! Every package matching =sys-kernel/linux-sabayon-4.19.2~-1 is masked.
☛     # Masking reason: repository general packages.db.mask
☛      <> atom: sys-kernel/linux-sabayon-4.19.2 in sabayonlinux.org

User avatar
sabayonino
Sagely Hen
Posts: 3368
Joined: Sun Sep 21, 2008 1:12
Location: Italy
Contact:

Re: Can't install virtualbox-bin on new installation

Post by sabayonino » Sun Dec 16, 2018 12:08

read my previous message once again.

andreios
Simple Hen
Posts: 88
Joined: Fri May 30, 2014 17:17

Re: Can't install virtualbox-bin on new installation

Post by andreios » Sun Dec 16, 2018 13:33

Oh it works with exact version specified. But why not without? Should I do a bug report?

Code: Select all

equo i app-emulation/virtualbox-modules-5.2.22#4.18.0-sabayon 
╠  @@ Calculating dependencies...
╠  ## [N] [sabayonlinux.org] app-emulation/virtualbox-modules-5.2.22#4.18.0-sabayon#4.18.0-sabayon|0
╠  @@ Packages needing to be installed/updated/downgraded: 1
╠  @@ Packages needing to be removed: 0
╠  @@ Download size: 225.1kB
╠  @@ Used disk space: 1.2MB
╠  @@ You need at least: 1.7MB of free space
╠  ::: >>>  (1/1) 1 package
╠    ## Downloading: 1 package
╠    ## ( mirror #1 ) [app-emulation:virtualbox-modules-5.2.22#4.18.0-sabayon.0ffe0c9bf8528490a9b7d613b8c9fb2d3051b0e8~0.tbz2] @ http://ftp.surfnet.nl
╠   ## Aggregated download: 1 item
╠    # [1] ftp.surfnet.nl => app-emulation:virtualbox-modules-5.2.22#4.18.0-sabayon.0ffe0c9bf8528490a9b7d613b8c9fb2d3051b0e8~0.tbz2
╠    ## Checking package checksum...
╠       : [app-emulation:virtualbox-modules-5.2.22#4.18.0-sabayon.0ffe0c9bf8528490a9b7d613b8c9fb2d3051b0e8~0.tbz2] GPG validated
╠       : SHA1 disabled
╠       : [app-emulation:virtualbox-modules-5.2.22#4.18.0-sabayon.0ffe0c9bf8528490a9b7d613b8c9fb2d3051b0e8~0.tbz2] SHA256 validated
╠       : SHA512 disabled
╠    ## ( mirror #1 ) [app-emulation:virtualbox-modules-5.2.22#4.18.0-sabayon.0ffe0c9bf8528490a9b7d613b8c9fb2d3051b0e8~0.tbz2] success @ http://ftp.surfnet.nl
╠    ##  Aggregated transfer rate: 2.2MB/second
╠  +++ >>>  (1/1) app-emulation/virtualbox-modules-5.2.22#4.18.0-sabayon
╠    ## Unpacking: app-emulation:virtualbox-modules-5.2.22#4.18.0-sabayon.0ffe0c9bf8528490a9b7d613b8c9fb2d3051b0e8~0.tbz2
╠    ## Package phase: setup
 * Checking for suitable kernel configuration options...                                                                                                                                                                                                                 [ ok ]
╠    ## Package phase: preinstall
╠    ## Installing package: app-emulation/virtualbox-modules-5.2.22#4.18.0-sabayon
╠    ## [Kernel Modules for Virtualbox]
╠    ## Updating installed packages repository: app-emulation/virtualbox-modules-5.2.22#4.18.0-sabayon
╠    ## Package phase: postinstall
 * Updating module dependencies for 4.18.0-sabayon ...                                                                                                                                                                                                                   [ ok ]
 * Adding module to moduledb.
╠    ## Cleaning: app-emulation/virtualbox-modules-5.2.22#4.18.0-sabayon
╠  @@ Installation complete.
╠ Found update: /etc/._cfg0000_locale.gen
╠ Found update: /etc/default/._cfg0000_grub
☛ There are 2 configuration files needing update
☛ Please run: equo conf update

User avatar
sabayonino
Sagely Hen
Posts: 3368
Joined: Sun Sep 21, 2008 1:12
Location: Italy
Contact:

Re: Can't install virtualbox-bin on new installation

Post by sabayonino » Sun Dec 16, 2018 14:00

andreios wrote:
Sun Dec 16, 2018 13:33
Oh it works with exact version specified. But why not without? Should I do a bug report?
Linux-sabayon 4.19 is available but masked for Ext4 bug. If you want install this kernel just unmask it. Not all users have Ext4 as filesystem :mrgreen:

andreios
Simple Hen
Posts: 88
Joined: Fri May 30, 2014 17:17

Re: Can't install virtualbox-bin on new installation

Post by andreios » Sun Dec 16, 2018 21:05

Well, the kernel 4.19 is masked because of a bug, that's okay I know it. But I have and had only 4.18. I don't even want 4.19.2. (By the way it has only a bug if you activated mq scheduler by grub (scsi_mod.use_blk_mq=1) or in the kernel config has CONFIG_SCSI_MQ_DEFAULT=y, which is not the case with last sabayon kernel config I know of. In 4.19.8 this is fixed!)

- I have kernel 4.18! Never tried to install anything other.
- I have to specify the kernel version for VirtualBox Modules just because I want to install VirtualBox on this machine? So equo wants to pull in 4.19 while ONLY 4.18 is installed?
Sounds like a bug to me.

andreios
Simple Hen
Posts: 88
Joined: Fri May 30, 2014 17:17

Re: Can't install virtualbox-bin on new installation

Post by andreios » Thu Dec 20, 2018 16:59

Right now there is no masked kernel in repository anymore so i can't recreate the problem. But I think the bug could still be there, so I don't know if this is solved.

Post Reply