Booting Problems [Likely Solved]

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :)

Moderator: Moderators

Post Reply
Advanced Hen
Posts: 239
Joined: Sun Mar 31, 2013 5:34

Booting Problems [Likely Solved]

Post by VolvoBirkenstock » Sun Apr 08, 2018 19:57

Hello, Sabayon Gurus.
I don't believe this is a Sabayon or a Linux problem, but I am hoping for an explanation.

I have a system that is dual-bootable to Win7 and Sabayon. Last time I was in Win7, I was abused by the BSOD and could hear the hard drive buzzing/vibrating in a strange manner. Subsequent to this event, the machine will not boot in the usual manner. I can boot it using a Sabayon Live DVD. I can boot it using a Win7 DVD. But here is the strange part:

If I insert the Win7 DVD and boot, I am prompted with a message something like "press any key to run the DVD......" If I do nothing, in a few moments I am greeted with the choice provided by grub, and I can boot into either Win7 or Sabayon. I guess this work-flow must allow the system to work-around a damaged area of the disk.

Can you explain this behavior to someone who really doesn't know much about the intricate details of the boot process?

I note that if I insert the Sabayon Live DVD and boot, I am not prompted with this message but instead load the DVD.

One more thing: I see the following message returned by "dmesg" in Linux:

Code: Select all

[   20.591304] udisks-lvm-pv-e[2298]: segfault at 0 ip 0000557b73d7d069 sp 00007fff5939cb30 error 4 in udisks-lvm-pv-export[557b73d7c000+2000]
Shall I assume that my hard drive is truly hosed? I did run the Sabayon Live DVD, mounted the hard drive, and backed everything up from both Win7 and Sabayon onto an external hard drive.

Edited to add: I should mention that the SMART Data is providing the overall assessment of "Disk is OK".

Thank you very much in advance.
Last edited by VolvoBirkenstock on Wed Apr 18, 2018 1:29, edited 1 time in total.

Advanced Hen
Posts: 239
Joined: Sun Mar 31, 2013 5:34

Re: Booting Problems

Post by VolvoBirkenstock » Mon Apr 09, 2018 15:23

I suspect that WinBlowz 7 overwrote an important region of my hard drive, thereby damaging the normal boot process. Here are the results from an extended multi-hour smartctl run with output displayed with "smartctl -x":

Code: Select all

smartctl 6.6 2017-11-05 r4594 [x86_64-linux-4.9.0-sabayon] (local build)
Copyright (C) 2002-17, Bruce Allen, Christian Franke,

Model Family:     Seagate Barracuda 7200.14 (AF)
Device Model:     ST2000DM001-1CH164
Serial Number:    S1E1QQYN
LU WWN Device Id: 5 000c50 060f0d614
Firmware Version: CC26
User Capacity:    2,000,398,934,016 bytes [2.00 TB]
Sector Sizes:     512 bytes logical, 4096 bytes physical
Rotation Rate:    7200 rpm
Form Factor:      3.5 inches
Device is:        In smartctl database [for details use: -P show]
ATA Version is:   ATA8-ACS T13/1699-D revision 4
SATA Version is:  SATA 3.0, 6.0 Gb/s (current: 6.0 Gb/s)
Local Time is:    Sun Apr  8 21:26:24 2018 CDT
SMART support is: Available - device has SMART capability.
SMART support is: Enabled
AAM feature is:   Unavailable
APM level is:     128 (minimum power consumption without standby)
Rd look-ahead is: Enabled
Write cache is:   Enabled
DSN feature is:   Unavailable
ATA Security is:  Disabled, NOT FROZEN [SEC1]
Wt Cache Reorder: Unavailable

SMART overall-health self-assessment test result: PASSED

General SMART Values:
Offline data collection status:  (0x00)	Offline data collection activity
					was never started.
					Auto Offline Data Collection: Disabled.
Self-test execution status:      (   0)	The previous self-test routine completed
					without error or no self-test has ever 
					been run.
Total time to complete Offline 
data collection: 		(  584) seconds.
Offline data collection
capabilities: 			 (0x73) SMART execute Offline immediate.
					Auto Offline data collection on/off support.
					Suspend Offline collection upon new
					No Offline surface scan supported.
					Self-test supported.
					Conveyance Self-test supported.
					Selective Self-test supported.
SMART capabilities:            (0x0003)	Saves SMART data before entering
					power-saving mode.
					Supports SMART auto save timer.
Error logging capability:        (0x01)	Error logging supported.
					General Purpose Logging supported.
Short self-test routine 
recommended polling time: 	 (   1) minutes.
Extended self-test routine
recommended polling time: 	 ( 226) minutes.
Conveyance self-test routine
recommended polling time: 	 (   2) minutes.
SCT capabilities: 	       (0x3085)	SCT Status supported.

SMART Attributes Data Structure revision number: 10
Vendor Specific SMART Attributes with Thresholds:
  1 Raw_Read_Error_Rate     POSR--   117   099   006    -    164778032
  3 Spin_Up_Time            PO----   096   096   000    -    0
  4 Start_Stop_Count        -O--CK   098   098   020    -    2445
  5 Reallocated_Sector_Ct   PO--CK   100   100   010    -    0
  7 Seek_Error_Rate         POSR--   077   060   030    -    8705203714
  9 Power_On_Hours          -O--CK   091   091   000    -    8627
 10 Spin_Retry_Count        PO--C-   100   100   097    -    0
 12 Power_Cycle_Count       -O--CK   098   098   020    -    2446
183 Runtime_Bad_Block       -O--CK   100   100   000    -    0
184 End-to-End_Error        -O--CK   100   100   099    -    0
187 Reported_Uncorrect      -O--CK   100   100   000    -    0
188 Command_Timeout         -O--CK   100   100   000    -    0 0 0
189 High_Fly_Writes         -O-RCK   100   100   000    -    0
190 Airflow_Temperature_Cel -O---K   072   062   045    -    28 (0 4 31 18 0)
191 G-Sense_Error_Rate      -O--CK   100   100   000    -    0
192 Power-Off_Retract_Count -O--CK   100   100   000    -    54
193 Load_Cycle_Count        -O--CK   092   092   000    -    16654
194 Temperature_Celsius     -O---K   028   040   000    -    28 (128 0 0 0 0)
197 Current_Pending_Sector  -O--C-   100   100   000    -    0
198 Offline_Uncorrectable   ----C-   100   100   000    -    0
199 UDMA_CRC_Error_Count    -OSRCK   200   200   000    -    0
240 Head_Flying_Hours       ------   100   253   000    -    8468h+44m+52.817s
241 Total_LBAs_Written      ------   100   253   000    -    11318677974
242 Total_LBAs_Read         ------   100   253   000    -    24174106536
                            ||||||_ K auto-keep
                            |||||__ C event count
                            ||||___ R error rate
                            |||____ S speed/performance
                            ||_____ O updated online
                            |______ P prefailure warning

General Purpose Log Directory Version 1
SMART           Log Directory Version 1 [multi-sector log support]
Address    Access  R/W   Size  Description
0x00       GPL,SL  R/O      1  Log Directory
0x01           SL  R/O      1  Summary SMART error log
0x02           SL  R/O      5  Comprehensive SMART error log
0x03       GPL     R/O      5  Ext. Comprehensive SMART error log
0x06           SL  R/O      1  SMART self-test log
0x07       GPL     R/O      1  Extended self-test log
0x09           SL  R/W      1  Selective self-test log
0x10       GPL     R/O      1  NCQ Command Error log
0x11       GPL     R/O      1  SATA Phy Event Counters log
0x21       GPL     R/O      1  Write stream error log
0x22       GPL     R/O      1  Read stream error log
0x80-0x9f  GPL,SL  R/W     16  Host vendor specific log
0xa1       GPL,SL  VS      20  Device vendor specific log
0xa2       GPL     VS    4496  Device vendor specific log
0xa8       GPL,SL  VS     129  Device vendor specific log
0xa9       GPL,SL  VS       1  Device vendor specific log
0xab       GPL     VS       1  Device vendor specific log
0xb0       GPL     VS    5176  Device vendor specific log
0xbe-0xbf  GPL     VS   65535  Device vendor specific log
0xc0       GPL,SL  VS       1  Device vendor specific log
0xc1       GPL,SL  VS      10  Device vendor specific log
0xc4       GPL,SL  VS       5  Device vendor specific log
0xe0       GPL,SL  R/W      1  SCT Command/Status
0xe1       GPL,SL  R/W      1  SCT Data Transfer

SMART Extended Comprehensive Error Log Version: 1 (5 sectors)
No Errors Logged

SMART Extended Self-test Log Version: 1 (1 sectors)
Num  Test_Description    Status                  Remaining  LifeTime(hours)  LBA_of_first_error
# 1  Extended offline    Completed without error       00%      8627         -
# 2  Short offline       Completed without error       00%      8623         -

SMART Selective self-test log data structure revision number 1
    1        0        0  Not_testing
    2        0        0  Not_testing
    3        0        0  Not_testing
    4        0        0  Not_testing
    5        0        0  Not_testing
Selective self-test flags (0x0):
  After scanning selected spans, do NOT read-scan remainder of disk.
If Selective self-test is pending on power-up, resume after 0 minute delay.

SCT Status Version:                  3
SCT Version (vendor specific):       522 (0x020a)
SCT Support Level:                   1
Device State:                        Active (0)
Current Temperature:                    29 Celsius
Power Cycle Min/Max Temperature:     18/31 Celsius
Lifetime    Min/Max Temperature:     13/38 Celsius
Under/Over Temperature Limit Count:   0/0

SCT Data Table command not supported

SCT Error Recovery Control command not supported

Device Statistics (GP/SMART Log 0x04) not supported

Pending Defects log (GP Log 0x0c) not supported

SATA Phy Event Counters (GP Log 0x11)
ID      Size     Value  Description
0x000a  2           12  Device-to-host register FISes sent due to a COMRESET
0x0001  2            0  Command failed due to ICRC error
0x0003  2            0  R_ERR response for device-to-host data FIS
0x0004  2            0  R_ERR response for host-to-device data FIS
0x0006  2            0  R_ERR response for device-to-host non-data FIS
0x0007  2            0  R_ERR response for host-to-device non-data FIS
I've read "man smartctl" but the interpretation of some of the above output is not intuitively obvious to me. Is there something wrong here? Is the hard drive too old to be reliable? Seriously? Am I being warned about "prefailure" as though the drive is about to degrade or die?

Also please let me know if there are any potential security issues with my release of the above smartctl output.

Thank you very much in advance.

Sagely Hen
Posts: 8214
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Booting Problems

Post by Fitzcarraldo » Fri Apr 13, 2018 1:46

Please provide some information on your installation.

2. MBR or GPT HDD?
3. Is /boot directory on same partition as / (root)?
4. What partitions are used (/dev/sda, /dev/sdb and so on)), and what is on them (/, /boot, /home, etc.) Use the blkid command as root user to see.

Advanced Hen
Posts: 239
Joined: Sun Mar 31, 2013 5:34

Re: Booting Problems

Post by VolvoBirkenstock » Fri Apr 13, 2018 5:07

Hello, Fitzcarraldo. Thank you for your response.

Answers to your questions in your order.
Information obtained using Linux utilities, where needed.
1. UEFI.
2. The partition table is "msdos", so I assume that is "MBR".
3. /boot is on a different partition than "/". (If I recall correctly, this was the default Sabayon configuration when I performed the LFC approximately 1.5 years ago.)

Code: Select all

From "fdisk -l" output: 
Device     Boot     Start        End    Sectors   Size Id Type
/dev/sda1  *         2048     206847     204800   100M  7 HPFS/NTFS/exFAT
/dev/sda2          206848  614402047  614195200 292.9G  7 HPFS/NTFS/exFAT
/dev/sda3       614402048  615426047    1024000   500M 83 Linux
/dev/sda4       615426048 3907028991 3291602944   1.5T  5 Extended
/dev/sda5       615430144 3907028991 3291598848   1.5T 8e Linux LVM

Code: Select all

# From "df -h" output: 
Filesystem                           Size  Used Avail Use% Mounted on
none                                 7.9G  1.4M  7.9G   1% /run
udev                                  10M     0   10M   0% /dev
tmpfs                                7.9G   39M  7.8G   1% /dev/shm
/dev/mapper/sabayon_fuutkraamp-root  100G   29G   72G  29% /
tmpfs                                7.9G     0  7.9G   0% /sys/fs/cgroup
tmpfs                                7.9G   12K  7.9G   1% /tmp
/dev/mapper/sabayon_fuutkraamp-home  1.5T  326G  1.2T  23% /home
/dev/sda3                            494M  107M  388M  22% /boot
tmpfs                                1.6G   12K  1.6G   1% /run/user/1000

Code: Select all

From "lvdisplay" output: 
  --- Logical volume ---
  LV Path                /dev/sabayon_fuutkraamp/root
  LV Name                root
  VG Name                sabayon_fuutkraamp
  LV UUID                LhZFeB-Vr18-ru0f-fXJ2-AF0a-mFxK-jxBEKY
  LV Write Access        read/write
  LV Creation host, time Fuutkraamp, 2016-12-03 14:29:04 -0600
  LV Status              available
  # open                 1
  LV Size                100.00 GiB
  Current LE             25600
  Segments               1
  Allocation             inherit
  Read ahead sectors     auto
  - currently set to     256
  Block device           251:0
  --- Logical volume ---
  LV Path                /dev/sabayon_fuutkraamp/swap
  LV Name                swap
  VG Name                sabayon_fuutkraamp
  LV UUID                B8K0ln-JzXu-Stdm-yaqg-6L4C-XHSr-svF4fG
  LV Write Access        read/write
  LV Creation host, time Fuutkraamp, 2016-12-03 14:29:05 -0600
  LV Status              available
  # open                 2
  LV Size                16.00 GiB
  Current LE             4095
  Segments               1
  Allocation             inherit
  Read ahead sectors     auto
  - currently set to     256
  Block device           251:1
  --- Logical volume ---
  LV Path                /dev/sabayon_fuutkraamp/home
  LV Name                home
  VG Name                sabayon_fuutkraamp
  LV UUID                A0MfkN-SY1k-FWsV-MBmE-e5Vx-APda-qw5WUa
  LV Write Access        read/write
  LV Creation host, time Fuutkraamp, 2016-12-03 14:29:06 -0600
  LV Status              available
  # open                 1
  LV Size                1.42 TiB
  Current LE             372111
  Segments               1
  Allocation             inherit
  Read ahead sectors     auto
  - currently set to     256
  Block device           251:2

Code: Select all

From "blkid" output: 
/dev/mapper/sabayon_fuutkraamp-root: UUID="795bdbfa-4a7c-4cab-901b-5791e4652712" TYPE="xfs"
/dev/sda1: LABEL="System Reserved" UUID="E03E98303E980228" TYPE="ntfs" PARTUUID="782fd0b0-01"
/dev/sda2: UUID="6E46A0AD46A0780B" TYPE="ntfs" PARTUUID="782fd0b0-02"
/dev/sda3: UUID="b4018fe8-f4a6-47da-9c7e-4fab9d30c052" TYPE="xfs" PARTUUID="782fd0b0-03"
/dev/sda5: UUID="kekKvx-p5mU-XKfI-PRdi-AxfT-mtHB-2hhVn3" TYPE="LVM2_member" PARTUUID="782fd0b0-05"
/dev/mapper/sabayon_fuutkraamp-swap: UUID="923c94c4-dd49-447d-8386-1784dcdd4080" TYPE="swap"
/dev/mapper/sabayon_fuutkraamp-home: UUID="4e1bd30f-5d19-4997-8a6e-35cf71aaba7d" TYPE="xfs"
I believe that "/" is on the logical volume /dev/sabayon_fuutkraamp/root, /home is on the logical volume /dev/sabayon_fuutkraamp/home, and /boot is on the /dev/sda3 partition. I believe this was the Sabayon default when I performed the LFC.

I know that XFS is not the Sabayon default file system, but I chose to use this based on past experience and the recommendation of several people I know well.

Again, thank you very much for your time and expertise, Fitzcarraldo. Does this provide you with all of the information you need?

User avatar
Sagely Hen
Posts: 3515
Joined: Sun Sep 21, 2008 1:12
Location: Italy

Re: Booting Problems

Post by sabayonino » Fri Apr 13, 2018 11:52

/dev/sda3 494M 107M 388M 22% /boot


/dev/sda3: UUID="b4018fe8-f4a6-47da-9c7e-4fab9d30c052" TYPE="xfs" PARTUUID="782fd0b0-03"

You've formatted /boot partition with XFS filesystem .

Please read :
RHEL 7.0, released in June 2014, uses XFS as its default file system, including support for using XFS for the /boot partition, which previously was not practical due to bugs in the GRUB bootloader.
and ... ith_XFS.3F
Q: Does GRUB work with XFS?

There is native XFS filesystem support for GRUB starting with version 0.91 and onward. Unfortunately, GRUB used to make incorrect assumptions about being able to read a block device image while a filesystem is mounted and actively being written to, which could cause intermittent problems when using XFS. This has reportedly since been fixed, and the 0.97 version (at least) of GRUB is apparently stable.
(for Grub-legacy and Grub2)

So there are some patches provided by RHEL for /boot partition XFS formatted. Not sure if Grub is patched for this.

I'm running XFS on my sabayon system (for my /home and backup LVM partitions) and my partitions layout is :

Code: Select all

/dev/mapper/VG00-system: UUID="e66c9ff4-5872-4479-99e6-4d4c50254bf5" TYPE="ext4"
/dev/sda1: UUID="21B2-49B5" TYPE="vfat" PARTUUID="7413321e-9413-4ca5-a377-50acae0bbdc0"
/dev/sda2: UUID="7ccfc056-86d3-4710-97c0-6ef0e3fbc8e9" TYPE="ext4" PARTUUID="8d9f77b2-7b22-4732-9a39-536be6fec4bf"
/dev/sda3: UUID="e66dff34-4a5d-43dd-a08e-cc3d33de87b5" TYPE="swap" PARTUUID="bc3d93d9-9208-4600-8223-fcd8e707ca05"
/dev/sda4: UUID="wIR3x9-hxoa-4HbD-rXCn-Vh3x-VYka-VBq8wA" TYPE="LVM2_member" PARTUUID="8c672141-ebee-498b-9ed7-eebc48163ab4"
/dev/sdb1: UUID="t4SSss-MZmU-sZMA-nO8S-1f5Q-9Ssk-72Kl9J" TYPE="LVM2_member" PARTUUID="3a15fe35-45a5-4f49-b9ee-09f042d51c5c"
/dev/mapper/VG00-home: UUID="107300fa-1473-4414-b6ba-9082d0af94eb" TYPE="xfs"
/dev/mapper/VG00-data: UUID="52b334f5-b135-4644-ad21-e20732b5423e" TYPE="ext4"
/dev/mapper/VG00-backup: UUID="2d3f040a-1217-42d7-8296-8b3e93700ffa" TYPE="xfs"
sda1 is the EFI partition (mounted on /boot/efi)
sda2 is the /boot partition (mounted on .... /boot :mrgreen: )

Advanced Hen
Posts: 239
Joined: Sun Mar 31, 2013 5:34

Re: Booting Problems

Post by VolvoBirkenstock » Sat Apr 14, 2018 20:37

Thank you for your response, Sabayonino. I do not claim to fully understand what you are telling me.

I am apparently running grub 2.02_beta3-r1.

Are you telling me that the BSOD seen in Windows which resulted in an inability to directly boot from grub into either Windows or Linux is because my /boot partition is XFS?

I still do not understand why placing a Windows Live DVD into the DVD drive, allowing it to spin up during system power-on, and then waiting for it to time out, subsequently allows grub to present a choice of Windows or Sabayon Linux.

My motherboard provides UEFI. When I first loaded Sabayon Linux onto this system with an ISO image loaded on a USB memory stick, it imposed /boot/efi on the system, and I had great difficulty attempting to dual boot. I eventually gave up on that, and instead loaded Sabayon Linux from Live DVD. I note that the installation from Live DVD did not impose a /boot/efi. /boot/efi does not exist on my Linux system.

I am apparently unable to repair the apparent damage caused during the Windows BSOD using the Windows repair mechanism on the Windows installation disk.

I would like to know/understand root cause before taking action. I would like to know if my hard drive has been irreparably damaged. I would like to know if I need to reinstall a dual bootable configuration on a new hard drive. The information you provided concerning XFS implies that grub and XFS might not have any issues given that grub 2.02_beta3-r1 greatly exceeds legacy 0.97. However, if I need to rebuild a dual bootable configuration, are you telling me to NOT use XFS for /boot?

This raises another question: Is there any simple cook-book recipe for dual-booting with UEFI? Again, as I wrote above, I had significant difficulty but found a method that worked by performing load-from-cold with only Live/Installation DVDs.

Thank you very much in advance.

User avatar
Sagely Hen
Posts: 3515
Joined: Sun Sep 21, 2008 1:12
Location: Italy

Re: Booting Problems

Post by sabayonino » Sun Apr 15, 2018 7:23

UEFI implies a FAT32 /boot/efi partition and GPT to boot >=Windows8

Advanced Hen
Posts: 239
Joined: Sun Mar 31, 2013 5:34

Re: Booting Problems

Post by VolvoBirkenstock » Tue Apr 17, 2018 2:08

I have been dual booting between Linux and Win7. The motherboard is UEFI.

1. Based on this information, are you now saying that I incorrectly formatted the hard drive?
2. Are you now saying that I still needed a FAT32 /boot/efi partition?

If I performed task 1 and 2 listed above incorrectly, then why did the Sabayon Live DVD load-from-cold _not_ force these rules or instruct me that it could not pursue load from cold until I resolved this? Again, other than the choice of XFS, pretty much everything I recall doing used the Sabayon defaults.

Installing from a memory stick forced /boot/efi, but I could not get dual-boot to work, so I fell back upon an install from Live DVD.

Understand that I have had no problems with booting since that load from cold late in 2016, and I've only experienced a problem with dual boot subsequent to a BSOD inside Win7. Are you implying that the BSOD was due to XFS used on /boot? If so, how does Win7 impact data on /boot?

Sorry, I'm not trying to be obtuse. I don't mean to frustrate or anger anyone. I'm just trying to understand what really went wrong so I can correct the issue.

Advanced Hen
Posts: 239
Joined: Sun Mar 31, 2013 5:34

Re: Booting Problems

Post by VolvoBirkenstock » Wed Apr 18, 2018 1:28

I am marking this as "Likely Solved". I apologize for wasting everyone's time, but I suspect that I now know at least part of the root cause.

You may recall that I mentioned that there was a BSOD while in Win7, and that there was a vibrating/buzzing sound. I assumed that the hard drive had been damaged or a portion of the boot sector had been overwritten. It turns out that was not the cause.

I tried to boot today in the usual new way, using the Win7 DVD for load from cold (LFC) and waiting for it to time out, and then failing over to grub on the hard drive. Today it did not do that. Today it hung at a screen before it got to grub. The screen very slowly reported something like:

Code: Select all

AMD AHCI BIOS Version 3.0.5
AHCI Drive Init ...
ID  Device Attached
<listed the DVD drive here>
<listed the hard drive here>
and then no progress was made. So maybe I am seeing some motherboard or other hardware/functional degradation. But I digress...

I then attempted to reboot, but I forced the UEFI graphical display to open, and then I observed the device boot order. I was very surprised to see that the order had changed from my previous settings. I suspect (but do not know) that this reordering occurred during all the buzzing/vibrating during the Win7 BSOD.

The configuration for boot order was supposed to be (1) DVD drive, (2) hard drive, (3) EFI shell. Instead it had been reordered to (1) DVD drive, (2) EFI shell, (3) hard drive. Returning the boot order to the former configuration now allows me to dual boot without using the Win7 LFC DVD and waiting for it to fail over to the hard drive.

Even so, I suspect that there is still an issue, either with the motherboard, or wiring connectivity, or a failing hard drive, but at least I don't need to depend on the DVD for a fail-over event.

Again, I apologize for consuming your time with this.

User avatar
Sagely Hen
Posts: 3515
Joined: Sun Sep 21, 2008 1:12
Location: Italy

Re: Booting Problems [Likely Solved]

Post by sabayonino » Wed Apr 18, 2018 12:17

I don't know about Windows BSOD , it's not Sabayon related.

If you're thinking you've hardware failures (hdd ? ) before to buy/change the harddrive check all data connections (data cable) or try to change sata port and check the power supply.

Post Reply