Fresh install doesn't boot on UEFI

Installer Issues via Installer -- Not for global upgrades or upgrading individual packages -- ONLY ISSUES WITH INSTALLATION OF THE OS -- Can't get Sabayon installed, than post here, otherwise use correct forums

Moderator: Moderators

Post Reply
Baby Hen
Posts: 1
Joined: Thu Sep 15, 2016 4:06

Fresh install doesn't boot on UEFI

Post by bjk » Thu Sep 15, 2016 4:20

I don't know if I'm missing something, but after the installing process, I reboot the computer and all I get is a screen saying "Default boot device missing or boot failed", it's like grub is not getting installed at all, I don't know, I'm not an expert.

I'm trying to install on an Acer Aspire E5-573, the partitions are made automatically by the installer and I'm using the Sabayon_Linux_DAILY_amd64_GNOME

There's something I can do?

Sagely Hen
Posts: 1749
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: Fresh install doesn't boot on UEFI

Post by Stupot » Sat Sep 17, 2016 21:36

Do you have multiple harddrives? Try switching the boot order in your BIOS if you do.

User avatar
Simple Hen
Posts: 64
Joined: Fri Aug 22, 2014 1:29

Re: Fresh install doesn't boot on UEFI

Post by mudler » Sun Sep 18, 2016 0:05

There was a known bug with UEFI, it has been solved today. Tomorrow dailies will be fine ... b3535f64bf

Baby Hen
Posts: 4
Joined: Wed Oct 12, 2016 0:44

Re: Fresh install doesn't boot on UEFI

Post by mr_y82 » Wed Oct 12, 2016 1:38

Dern... wish I had downloaded the daily instead of 16.07! I posted on another site about my issue... and unfortunately just installed Mint after my failed attempts... Here is what I wrote:

Hello, I am trying to install Sabayon to my Acer Aspire One Cloudbook with eMMC “hard drive.”

The installation looks a little different than the more typical one I see pictured, but I was able to navigate through it just fine, or so I thought…

When I get to the partitioning/mounting part the following drives show up (in addition to my flash drive):

mmcblk0rpmb – 4mb – (I assume this is the master boot record area or whatever)

mmcblk0 – 60gb, partitioned as follows:

100mb – /boot/efi (and formatted as EFI partition)
10gb – / (root, formatted as ext4)
48gb – /home (formatted as ext4)
2gb – swap

After selected said partitions as such, and triple checking their selection, I return to the “install page” and it still displays the following for storage devices:

“error checking storage configuration”

It also seems that the install button is grayed out, but I clicked it anyway, not expecting it to work, but it appeared to install correctly, and everything was partitioned as stated above when it finished, but on reboot it would not boot, but instead displayed “No Bootable Device.”

I have had other distros installed successfully (Antergos and Mint XFCE) on this eMMC drive with UEFI, but for some reason even after setting “secure boot” on and selecting the files for Sabayon (I tried all three that show up on the boot/efi partition; “grub,” “boot,” and whatever the 3rd one was…), it still says no bootable device…

My theory is as follows… The one thing I typically see in Linux installations that I did not notice for this very unique Sabayon setup, is selection of where the bootloader should go… which I assume would be “mmcblk0″… Did I miss something? Why can’t the installer still look like the one I know and love above!? (Salix and Zenwalk installers have their own charm too).

I have currently reverted back to Mint (I prefer rolling distros, but Sabayon was the only one that met all the criteria I wanted without various small issues that caused me to rule them out… I won’t bore you with the details…), but if anyone has a suggestion I would be happy to try the Sabayon installation again!


Post Reply