InstallDVD ACPI failure

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

InstallDVD ACPI failure

Postby sam445 » Fri Aug 01, 2014 2:30

Hello, i'm trying to install Sabayon 14 for the first time on my laptop, but I keep running into a wall.
When I get to the menu of the installation DVD, I can choose any options (well, "Start Sabayon", "Installation" and "Safe mode"), but all will fail during the initial loading.

I usually get a first ACPI write/parse error at about mid-loading followed by 4 ACPI errors about buffers (sorry, it scrolls too fast out of sight to be able to re-write them). After that, the loading stops and I am dropped to a loging in console mode and the installation/loading process stops. After a short time, my screen goes black and all that remains is a tiny white bar at top-left corner of the screen, which stays this way until I shutdown the computer.

I have tried with the amd64-KDE monthly and daily (29 July 2014) releases on both a USB stick and on DVDs, the same errors still happen at the same time.

I have an MSI GE70 with the following hardware:
64 bits CPU: Intel i7 3610QM
GPU: Nvidia GeForce GTX 660M / 2GB GDDR5
RAM: 8 GB DDR3.
Memory: 1 TB hard-drive

I have Windows 7 on partitions sda3 with it's boot sector in sda2. I still have 500 GB left of non-partitionned disk space.

EDIT2: The console mode works, but no logs (apart from the boot.log, which says everything went OK) have been generated for the problem. So i'm start to re-write it by hand. Here are the first errors that are thrown right before the first ACPI error:

- Disabling lock debugging due to kernel taint
- NVRM: loading NVIDIA UNIX x86_64 Kernel module 337.25 Tue May 27 11:05:28


EDIT3: I have tried removing the nvidia driver, as suggested here: https://wiki.sabayon.org/index.php?titl ... ng_process, but it didn't fix it. I am led to believe that the error (or other, undisplayed error) happens during the loading of the display manager, since when I restarted it, I have been brought to the same black screen.
sam445
Baby Hen
 
Posts: 2
Joined: Fri Aug 01, 2014 1:57

Re: InstallDVD ACPI failure

Postby Fitzcarraldo » Sun Aug 03, 2014 12:10

Have you tried pressing F5 at the LiveDVD menu and appending one of the following kernel boot parameters and then hitting Enter?

Code: Select all
xdriver=vga

Code: Select all
xdriver=nvidia

Code: Select all
xdriver=nv

Code: Select all
xdriver=nouveau


Edited 5 Aug. 2014 12:00 BST to correct typo.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7977
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: InstallDVD ACPI failure

Postby sam445 » Mon Aug 04, 2014 20:41

I have tried to no avail the nvidia.
Code: Select all
xriver=vga


I'll try the next one.
sam445
Baby Hen
 
Posts: 2
Joined: Fri Aug 01, 2014 1:57

Re: InstallDVD ACPI failure

Postby Fitzcarraldo » Tue Aug 05, 2014 12:00

Sorry, that should, of course, have been "xdriver=vga", not "xriver=vga". I've edited my post to correct the typo.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7977
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom


Return to Beginners|Newbies Area

Who is online

Users browsing this forum: No registered users and 2 guests

cron