Unmasked package does not install

Anything that pertains to Portage

Moderator: Moderators

Unmasked package does not install

Postby deusr » Sun Jul 13, 2014 22:56

I'm trying to install this package that is masked, unmasked him, but keeps showing the same message, can anyone help me?

Code: Select all
neit package.mask # emerge -av unity-meta

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy "x11-libs/libaccounts-qt[qt5]" have been masked.
!!! One of the following masked packages is required to complete your request:
- x11-libs/libaccounts-qt-1.12_p0_p01::unity-gentoo (masked by: package.mask, missing keyword)
/etc/portage/package.mask/00-sabayon.package.mask:
# 2013-11-13 Sławomir Nizio: this package (v. 2013.1.4, 2013.2)
# depends directly or indirectly on packages older than we already
# provide. It cannot be supported properly (easily), and seems to
# be unpopular.


(dependency required by "unity-base/signon-ui-0.16_p0_p01-r2::unity-gentoo" [ebuild])
(dependency required by "unity-base/gnome-control-center-signon-0.1.7_p0_p04-r2::unity-gentoo" [ebuild])
(dependency required by "x11-misc/webaccounts-browser-extension-0.5a_p0_p02::unity-gentoo" [ebuild])
(dependency required by "unity-base/unity-meta-14.10::unity-gentoo[webapps]" [ebuild])
(dependency required by "unity-meta" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

neit package.mask # cat /etc/portage/package.mask/00-sabayon.package.mask |grep unity-gentoo
>=x11-libs/libaccounts-qt-1.12_p0_p01::unity-gentoo
Last edited by deusr on Mon Jul 14, 2014 3:16, edited 1 time in total.
deusr
Growing Hen
 
Posts: 168
Joined: Mon Feb 23, 2009 7:23

Re: Unmasked package does not install

Postby deusr » Mon Jul 14, 2014 3:00

I found that I did wrong, should unmask put in, but I did and still the same thing!

Code: Select all
neit package.mask # echo -e "\n#Ambiente Unity do Ubuntu\n>=x11-libs/libaccounts-qt-1.12_p0_p01::unity-gentoo" >> /etc/portage/package.unmask/00-sabayon.package.unmask
neit package.mask # cat /etc/portage/package.unmask/00-sabayon.package.unmask |grep unity
>=x11-libs/libaccounts-qt-1.12_p0_p01::unity-gentoo
neit package.mask # emerge -av unity-meta

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy "x11-libs/libaccounts-qt[qt5]" have been masked.
!!! One of the following masked packages is required to complete your request:
- x11-libs/libaccounts-qt-1.12_p0_p01::unity-gentoo (masked by: missing keyword)

(dependency required by "unity-base/signon-ui-0.16_p0_p01-r2::unity-gentoo" [ebuild])
(dependency required by "unity-base/gnome-control-center-signon-0.1.7_p0_p04-r2::unity-gentoo" [ebuild])
(dependency required by "x11-misc/webaccounts-browser-extension-0.5a_p0_p02::unity-gentoo" [ebuild])
(dependency required by "unity-base/unity-meta-14.10::unity-gentoo[webapps]" [ebuild])
(dependency required by "unity-meta" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
deusr
Growing Hen
 
Posts: 168
Joined: Mon Feb 23, 2009 7:23

Re: Unmasked package does not install

Postby albfneto » Mon Jul 14, 2014 16:27

is masked by missing keyword, regular, common mask:,

masked by: package.mask, missing keyword


remove the modifications that you carried out in the packages.unmask file... return it to the default...


then, try editing the /etc/portage/package.keywords file, and unmask all versions of the package that you want,by adding this line:

Code: Select all
x11-libs/libaccounts-qt



http://www.iml.ece.mcgill.ca/~stephan/autounmask
I advise that the aplication "autounmask" no more exists, but manual editing the file /etc/portage/package.keywords works.



or you may try the automatic unmasking, as:

Code: Select all
# emerge -av --autounmask --autoumask-write  x11-libs/libaccounts-qt


All regular masked packages,can be treated in this manner. The method that you use, unmask in the package.unmask file, is better to be reserved only to "hardmasked" packages, not to the regular keyword masks:

https://wiki.gentoo.org/wiki/Knowledge_Base:Unmasking_a_package

if unmasking, masking procedures etc... and other procedures in Portage,
seems no more working, remember to update databases, environ., and files:

Code: Select all
# updatedb -v (if you use mlocate package and locate command)
# eix-update (if you use eix command and package)
# etc-update
# env-update
$ source /etc/profile (execute this last command as common user)
ALBERTO FEDERMAN NETO
albfneto
albfneto@fcfrp.usp.br
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1689
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Re: Unmasked package does not install

Postby deusr » Mon Jul 14, 2014 17:21

It did not work either, see below:

Code: Select all
neit talesam # emerge -av --autounmask --autounmask-write  x11-libs/libaccounts-qt

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] app-text/sgml-common-0.6.3-r5  126 kB
[ebuild  N     ] app-text/docbook-dsssl-stylesheets-1.79  272 kB
[ebuild  N     ] app-text/opensp-1.5.2-r3  USE="nls -doc -static-libs {-test}" 1,486 kB
[ebuild  N     ] dev-util/itstool-2.0.2  PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" 95 kB
[ebuild  N     ] app-text/openjade-1.3.2-r6  USE="-static-libs" 874 kB
[ebuild  N     ] app-text/docbook-sgml-dtd-3.0-r3:3.0  43 kB
[ebuild  N     ] app-text/yelp-tools-3.12.1  199 kB
[ebuild  NS    ] app-text/docbook-xml-dtd-4.3-r1:4.3 [4.2-r2:4.2] 82 kB
[ebuild  N     ] dev-util/gtk-doc-1.20  USE="-debug -doc -emacs -highlight {-test} -vim" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" 0 kB
[ebuild  N     ] dev-libs/libaccounts-glib-1.15_p0_p03:0/0.1.3::unity-gentoo  USE="-debug" PYTHON_TARGETS="python2_7 python3_3 -python3_4" 120 kB
[ebuild  N     ] x11-libs/libaccounts-qt-1.11_p0_p01-r1:0/1.1.4::unity-gentoo  USE="-doc (-qt5)" 66 kB


The version of "x11-libs/libaccounts-qt" I need it to 1.12 :/

That did not work!
Code: Select all
neit talesam # echo -e "\n#Ambiente Unity do Ubuntu\n>=x11-libs/libaccounts-qt-1.12_p0_p01::unity-gentoo ~amd64" >> /etc/portage/package.keywords/00-sabayon.package.keywords


See:
Code: Select all
neit portage # emerge -av --autounmask-write =x11-libs/libaccounts-qt-1.12_p0_p01::unity-gentoo

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] app-text/sgml-common-0.6.3-r5  126 kB
[ebuild  N     ] app-text/docbook-dsssl-stylesheets-1.79  272 kB
[ebuild  N     ] app-text/opensp-1.5.2-r3  USE="nls -doc -static-libs {-test}" 1,486 kB
[ebuild  N     ] dev-util/itstool-2.0.2  PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" 95 kB
[ebuild  N     ] app-text/openjade-1.3.2-r6  USE="-static-libs" 874 kB
[ebuild  N     ] app-text/docbook-sgml-dtd-3.0-r3:3.0  43 kB
[ebuild  N     ] app-text/yelp-tools-3.12.1  199 kB
[ebuild  NS    ] app-text/docbook-xml-dtd-4.3-r1:4.3 [4.2-r2:4.2] 82 kB
[ebuild  N     ] dev-util/gtk-doc-1.20  USE="-debug -doc -emacs -highlight {-test} -vim" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" 0 kB
[ebuild  N     ] dev-libs/libaccounts-glib-1.15_p0_p03:0/0.1.3::unity-gentoo  USE="-debug" PYTHON_TARGETS="python2_7 python3_3 -python3_4" 120 kB
[ebuild  N    *] x11-libs/libaccounts-qt-1.12_p0_p01:0/1.1.4::unity-gentoo  USE="-doc (-qt5)" 66 kB

Total: 11 packages (10 new, 1 in new slot), Size of downloads: 3,359 kB

The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by =x11-libs/libaccounts-qt-1.12_p0_p01::unity-gentoo (argument)
=x11-libs/libaccounts-qt-1.12_p0_p01 **

NOTE: The --autounmask-keep-masks option will prevent emerge
      from creating package.unmask or ** keyword changes.

Would you like to add these changes to your config files? [Yes/No]
deusr
Growing Hen
 
Posts: 168
Joined: Mon Feb 23, 2009 7:23

Re: Unmasked package does not install

Postby Stupot » Mon Jul 14, 2014 17:48

Just so you know, there are many complaints out there about how it's really hard to get unity to run right anywhere besides on Ubuntu.

Here's a gentoo thread on installing unity: http://forums.gentoo.org/viewtopic-t-930558.html

But be warned, what you are installing changes a good deal of underlying libraries used by KDE and GNOME. You will most likely break those and if you break unity, you could very well end up with an unusable graphical system if you use entropy for anything.

If you are only using portage, you shouldn't run into as much issues, except I'd still be surprised if unity works nicely.

Good luck!
Stupot
Sagely Hen
 
Posts: 1513
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA


Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: No registered users and 1 guest

cron