Googleearth 7 second and third releases crash [Solved]

Discussions Regarding Software

Moderator: Moderators

Googleearth 7 second and third releases crash [Solved]

Postby vincebarwinski » Sun Oct 13, 2013 8:43

About early June this year, while doing a standard weekly update of my Sabayon system from the first Google Earth 7 version which worked perfectly (I am not sure of the exact version), it upgraded to the defective 7.1.1.1581 which crashed with the following message:

0721/104221:ERROR:net_util.cc(2195)] Not implemented reached in bool net::HaveOnlyLoopbackAddresses()
[0721/104221:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0721/104221:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0721/104222:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0721/104222:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0721/104223:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0721/104224:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0721/104225:WARNING:backend_impl.cc(1875)] Destroying invalid entry.
[0721/104225:WARNING:backend_impl.cc(1875)] Destroying invalid entry.
[0721/104225:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0721/104225:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0721/104226:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.


Another crash happened while handling crash!

A month or so later, when doing another system update, it upgraded to 7.1.1.1871, but this crashed in identical fashion to the previous version, namely 7.1.1.1581. It seems lately that GoogleEarth on Linux is riddled with problems.

Since the very first GoogleEarth 7 version worked perfectly,I wonder if it would it be possible that we could roll back in the repos to the first GoogleEarth 7 version which worked perfectly? At present, I am forced to use the binary version 5.2 which I downloaded directly from Google. Unfortunately, it does not have street view, being such an old version. For that, I run Google Earth from Mint 13 Maya in Virtual Box,which uses version 6.2 I think.

Anyway, I wonder if a rollback to the very first GoolgeEarth 7 in the repos would be possible? It would beat having to still keep using the obsolete 5.2. My system isn Acer 5745 Aspire with and Nividia GeForce GT 420M GPU.
vincebarwinski
Baby Hen
 
Posts: 5
Joined: Sun Oct 13, 2013 8:13


Re: Googleearth 7 second and third releases crash

Postby vincebarwinski » Sun Jun 22, 2014 3:18

Last week I stumbled onto your blog about installing GE under wine, at

http://fitzcarraldoblog.wordpress.com/2 ... h-in-wine/

As I stated in your blog, I had complete success, although since then I have found one downside, being that the Search functionality for place names does not work.

Eg, type in say "London", and you get no results. It will only accept latitude and longitude. One other thing, it does not like being left idle for any real length of time.

Otherwise, it is working better than any native Linux version I ever used. The fact I am using an Nvidia card is not a problem.

Also, I had to add the following line to my /etc/hosts file:

220.244.223.163 kh.google.com

As lately I have had GE unable to locate the Google server as kh.google.com is a dead link.

Initially I thought the GE installation under wine failed, as I got the message that GE could not find the google server. Once I added this line to my /etc/hosts file, it worked.

Thanks for your suggestion, as I use GE extensively in my research.

Cheers
vincebarwinski
Baby Hen
 
Posts: 5
Joined: Sun Oct 13, 2013 8:13

Re: Googleearth 7 second and third releases crash

Postby Fitzcarraldo » Sun Jun 22, 2014 3:59

It's also possible to install the 32-bit Google Earth in 64-bit multilib Gentoo via a local overlay, as explained in another of my posts: Work-around if 64-bit Google Earth crashes in Gentoo Linux. That hack of mine is for 64-bit Gentoo, but might work in SL too.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Googleearth 7 second and third releases crash [Solved]

Postby albfneto » Wed Jun 25, 2014 15:04

In my system i use the version 7.1.1.1871:

https://packages.sabayon.org/show/googleearth,107221,sabayon-weekly,amd64,5,standard

this works good for me, except in machines with ATI proprietary drivers.
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1709
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil


Return to Software in General

Who is online

Users browsing this forum: No registered users and 3 guests