New Install: multiple serious issues

Installer Issues via Installer -- Not for global upgrades or upgrading individual packages -- ONLY ISSUES WITH INSTALLATION OF THE OS -- Can't get Sabayon installed, than post here, otherwise use correct forums

Moderator: Moderators

New Install: multiple serious issues

Postby dankasak » Thu Jun 05, 2014 2:09

Hi all.

I just tried the new Anaconda installer in Sabayon_Linux_14.06_amd64_GNOME.iso. I'm setting up a RAID1 BTRFS root install. It's not going well AT ALL.

-----------

1) I can get various options to at least boot from the USB disk I made. I have to select an option for Radeon users to get this far. X doesn't start by itself though. If I go 'systemctl start gdm' nothing happens. If I try 'startx', I get an instant lockup. Nice.

I can get into X by editing /etc/X11/xorg.conf and entering the 'fbdev' driver instead of the 'fglrx' driver, then using 'eselect' to switch to the xorg opengl implementation. Why is fglrx even provided for an installer? Surely the better way to go would be to use open-source drivers, or a framebuffer fallback? People can load up fglrx later. Having loaded the fglrx driver already, the open-source ATI driver is not able to initialise the hardware ( I think ... this is my 1st ATI graphics setup in a while ), though I think it could also be something to do with KMS ( possible also related to FGLRX ). Regardless, ATI users appear to have quite a challenge on their hands installing Sabayon.

So anyway, I can then get twm going ( coooool ) by typing 'startx' ... but instead I create a .xinitrc and put 'exec gnome-session' in it. Then I start X and gnome starts up, though with horrible resolution because I'm using fbdev.

From here, there is no obvious way of installing, but I know to type 'install' in the gnome search 'whatever it is'.

This is fine for me, but it's not fine for people not so comfortable with Linux. Is this the current state of the installer, or am I having a non-standard experience?

---

2) The installer appears to support BTRFS, including RAID1 mirroring. I noticed that the 'available space' that the installer was quoting was the TOTAL space of the 2 disks ( sda and sdb ) instead of half of this space. Anyway, the install completed without any obvious errors ( woohoo! ... it's been pretty hit-and-miss over the last year ... usually I get a segfault around when it's time to install grub ).

When rebooting, however, I received:

Code: Select all
iscsistart: transport class version 2.0-870. iscsid version 2.0-872
Could not get boot entry.
** No iSCSI initiator found
mount: mounting /dev/sda2 on /newroot failed: Invalid argument
!! Cannot mount /dev/sda2, trying with -t auto
mount: mounting /dev/sda2 on /newroot failed: Invalid argument
!! Cannot mount /dev/sda2 with -t auto, giving up
!! Could not mount specified ROOT, try again
!! Please file a bug report with this message


Are BTRFS installs "suported" in that they're supposed to work? Should I do an EXT4 install into a small partition, then create a bigger BTRFS partition after ( including RAID1 ), migrate my data, then reclaim the original partition?
dankasak
Baby Hen
 
Posts: 3
Joined: Thu Jun 05, 2014 1:42

Re: New Install: multiple serious issues

Postby Nilssab » Sun Jun 08, 2014 14:59

I'm also having some problems with the new anaconda.. I didn't get it to work at all with UEFI, but I have it working now on an old BIOS netbook.

The UI is *EXTREMELY* slow. a button click takes like 5 seconds. Now, I know it's a netbook, but I can use cinnamon on it and it's quite snappy, so there is some serious UI optimizations needed. The openbox UI is ofc superresponsive, only the UI elements of the installer are slow, not to say broken. EDIT: Seems the problem goes away after installation has started(Ironically, since it should have more to do), once it has started copying files, it's peppy and fast

Also the partitioner is just backwards..
Nilssab
Baby Hen
 
Posts: 17
Joined: Fri Apr 06, 2012 18:53


Return to Installer Issues - Calamares **Not for Package Manager Stuff**

Who is online

Users browsing this forum: No registered users and 1 guest