dracut broken with latest upgrade [Solved]

Discussion in general that pertains to Sabayon Linux - Must Pertain to Sabayon Linux

Moderator: Moderators

Post Reply
Baby Hen
Posts: 19
Joined: Wed Jan 18, 2012 5:08

dracut broken with latest upgrade [Solved]

Post by mohan43u » Fri May 23, 2014 5:00

After recent upgrade, I'm not able to boot, It seems dracut boot parameter I was using previously were not working. I have to change it as below to boot properly. If anyone using dracut + lvm (for root partition) and facing problem like me, then chang e the boot parameters as below,

linux /kernel-genkernel-x86_64-3.14.0-sabayon init=/sbin/init root=UUID=80b5a49b-4156-49b3-ab4d-71d1de2dca36 resume=UUID=7550843f-1e8a-4c8e-b9a3-3c9907164726 ro rd.auto rd.lvm.vg=vg_mohanlaptop rd.vconsole.keymap=us quiet splash
initrd /initramfs-dracut-x86_64-3.14.0-sabayon

It seems we have to explicitly specify which volume group to activate at boot time to reach root partition (rd.lvm.vg=vg_mohanlaptop).

Post Reply