AMD fglrx drivers (kmods) with 3.12 kernel

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

AMD fglrx drivers (kmods) with 3.12 kernel

Postby RJVB » Sat Jan 25, 2014 13:14

I have 2 AMD-based laptops, an less-recent HP G62 with an RV710 and a recent Aspire One 722 with a Radeon HD6290. The latter requires a recent fglrx driver, the former the legacy (12.4 or 12.6) version. Using the fglrx driver is especially important for the HP G62 as the free Radeon driver causes the graphics board to overheat, leading to a hardware shutdown of the computer.

Running Linux Mint Debian with a 3.10 kernel, I could install the required AMD Catalyst code on both machines, simply via the LMDE repositories (versions 13.4 and 12.6 "legacy"). The way things are set up, the kmods are compiled from source during the installation process, using dkms.
I then downloaded and built the Sabayon 3.12.6 kernel package, and managed to make the minimal change to the fglrx kmod code for it to build and install. This is really just a question to change a typedef.

By contrast, installing the AMD Catalyst 13.6 using equo on an otherwise uptodate Sabayon installation (on an external hdd) requires downgrading the kernel to 3.9 while this doesn't appear to be necessary given my experience described above.
Supposing I download the 13.6 installer from AMD in order to get the userland utilities, how would I go about installing the fglrx kmod, given Sabayon doesn't have the dkms utilities?
RJVB
Baby Hen
 
Posts: 3
Joined: Fri Jan 24, 2014 18:23
Location: France

Re: AMD fglrx drivers (kmods) with 3.12 kernel

Postby Provia » Wed Jan 29, 2014 8:20

Hi RJVB,
I think you are a bit confused. In Sabayon we have video driver modules compiled for every major release of the kernel.
For example you see that version 13.12 is available for each kernel( https://packages.sabayon.org/quicksearc ... 12&x=0&y=0 ). You have probably selected the version for 3.9 kernel.
If you want to install the newer driver for your card just download the version that match with your kernel. Follow this guide anyway:https://wiki.sabayon.org/index.php?title=HOWTO:_Get_AMD/ATI_or_Nvidia_Video_Cards_working_in_Sabayon#AMD_-_Open_Source_to_FGLRX

When you install a new kernel via Rigo, then Rigo will install the new kernel and all the related modules(including proprietary video drivers).
AMD Athlon(tm) II X2 250 Processor
4 GB DDR3 1600 Mhz
Nvidia Geforce 9800 GT
Sabayon Linux x64 KDE Limbo
Provia
Advanced Hen
 
Posts: 209
Joined: Mon Nov 26, 2012 23:15
Location: Italy

Re: AMD fglrx drivers (kmods) with 3.12 kernel

Postby RJVB » Wed Jan 29, 2014 17:36

THanks, the link to the update guide helped me install the 13.9 driver (I use the weekly repo), but for some reason I had to specify the exact version. Simply

Code: Select all
equo install ati-drivers


insisted on giving me the version for the 13.9 kernel.

Now I just have to figure out how to get Wine apps (Foobar2000, notably) to talk directly to my HDMI output ...
RJVB
Baby Hen
 
Posts: 3
Joined: Fri Jan 24, 2014 18:23
Location: France

Re: AMD fglrx drivers (kmods) with 3.12 kernel

Postby Provia » Wed Jan 29, 2014 21:24

RJVB wrote:THanks, the link to the update guide helped me install the 13.9 driver (I use the weekly repo), but for some reason I had to specify the exact version. Simply

Code: Select all
equo install ati-drivers


insisted on giving me the version for the 13.9 kernel.

Now I just have to figure out how to get Wine apps (Foobar2000, notably) to talk directly to my HDMI output ...


???
Sorry but this is not clear . You have said that your version of the kernel is 3.12 right? Then if you give
Code: Select all
sudo equo install ati-drivers

you will install the latest drivers...right?

So it's all ok now i suppose?
AMD Athlon(tm) II X2 250 Processor
4 GB DDR3 1600 Mhz
Nvidia Geforce 9800 GT
Sabayon Linux x64 KDE Limbo
Provia
Advanced Hen
 
Posts: 209
Joined: Mon Nov 26, 2012 23:15
Location: Italy

Re: AMD fglrx drivers (kmods) with 3.12 kernel

Postby anomaly65 » Tue Apr 22, 2014 0:36

try this:

Code: Select all
equo install =x11-drivers/ati-drivers-13.12#3.12.0-sabayon


which should match your 3.12 kernel.

Hope that helps,
andy
--
Use handrails on stairs. A nasty fall face first changes your point of view quickly, and mine permanently :-)
anomaly65
Technological Hen
 
Posts: 302
Joined: Sat Nov 17, 2007 15:37


Return to Hardware

Who is online

Users browsing this forum: No registered users and 2 guests