Gnome show up after 30 seconds [Solved]

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

Gnome show up after 30 seconds [Solved]

Postby skullbocks » Thu Apr 03, 2014 12:26

Hello everybody.
I installed sabayon 14.01 with Gnome Shell 3.10, and I have a strange iussue with gdm:
Code: Select all
Failed to set slave bus name on parent: Timeout was reached

so my gnome-shell shows up in 40 seconds.
I saw that this problem was firstly reported from lxnay on gnome mailing list a year ago (https://mail.gnome.org/archives/gdm-list/2013-February/msg00002.html).
Any Ideas?
Last edited by skullbocks on Thu May 08, 2014 22:13, edited 1 time in total.
skullbocks
Baby Hen
 
Posts: 19
Joined: Sun Dec 24, 2006 11:53

Re: Gnome show up after 30 seconds

Postby skullbocks » Tue Apr 08, 2014 16:14

Bump!
skullbocks
Baby Hen
 
Posts: 19
Joined: Sun Dec 24, 2006 11:53

Re: Gnome show up after 30 seconds

Postby Stupot » Tue Apr 08, 2014 16:43

Stupot
Sagely Hen
 
Posts: 1549
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: Gnome show up after 30 seconds

Postby skullbocks » Wed Apr 09, 2014 10:08

Thank you for your reply. I saw that but I haven't those lines in my system.conf. Even in gmane.org http://comments.gmane.org/gmane.comp.gnome.gdm.general/2574 there isn't an answer to my issue, only the report of the same behavior.
skullbocks
Baby Hen
 
Posts: 19
Joined: Sun Dec 24, 2006 11:53

Re: Gnome show up after 30 seconds

Postby lxnay » Wed Apr 09, 2014 11:35

This is how I fixed it at the time.
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3595
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Re: Gnome show up after 30 seconds

Postby skullbocks » Wed Apr 09, 2014 16:43

Thank you for your reply.
I have the same file in
Code: Select all
/etc/dbus-1/system.d/
but the issue still remain.
skullbocks
Baby Hen
 
Posts: 19
Joined: Sun Dec 24, 2006 11:53

Re: Gnome show up after 30 seconds

Postby sabayonino » Thu Apr 10, 2014 17:13

skullbocks wrote:Thank you for your reply.
I have the same file in
Code: Select all
/etc/dbus-1/system.d/
but the issue still remain.


remove follow lines from the file as Lxnay explained:
Code: Select all
<allow send_requested_reply="true"/>
<allow send_requested_reply="true"/>
<allow send_requested_reply="true"/>


After changes , you'll have
https://github.com/Sabayon/entropy/blob ... .Rigo.conf
Code: Select all
<!DOCTYPE busconfig PUBLIC
 "-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
 "http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
<busconfig>
        <policy user="root">
                <allow own="org.sabayon.Rigo"/>
                <allow send_destination="org.sabayon.Rigo"/>
        </policy>
        <policy group="entropy">
                <allow own="org.sabayon.Rigo"/>
                <allow send_destination="org.sabayon.Rigo"/>
        </policy>
        <policy context="default">
<deny send_destination="org.sabayon.Rigo"/>
        </policy>
</busconfig>
User avatar
sabayonino
Sagely Hen
 
Posts: 2583
Joined: Sun Sep 21, 2008 1:12
Location: Italy

Re: Gnome show up after 30 seconds

Postby skullbocks » Thu Apr 10, 2014 17:36

sabayonino wrote:
skullbocks wrote:Thank you for your reply.
I have the same file in
Code: Select all
/etc/dbus-1/system.d/
but the issue still remain.


remove follow lines from the file as Lxnay explained:
Code: Select all
<allow send_requested_reply="true"/>
<allow send_requested_reply="true"/>
<allow send_requested_reply="true"/>


After changes , you'll have
https://github.com/Sabayon/entropy/blob ... .Rigo.conf
Code: Select all
<!DOCTYPE busconfig PUBLIC
 "-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
 "http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
<busconfig>
        <policy user="root">
                <allow own="org.sabayon.Rigo"/>
                <allow send_destination="org.sabayon.Rigo"/>
        </policy>
        <policy group="entropy">
                <allow own="org.sabayon.Rigo"/>
                <allow send_destination="org.sabayon.Rigo"/>
        </policy>
        <policy context="default">
<deny send_destination="org.sabayon.Rigo"/>
        </policy>
</busconfig>


Thanks sabayonino but it is exactly the same file I already have.
skullbocks
Baby Hen
 
Posts: 19
Joined: Sun Dec 24, 2006 11:53

Re: Gnome show up after 30 seconds

Postby skullbocks » Thu May 08, 2014 22:13

Guys this problem disappeared with the newer version of Gnome (3.12).
Anyway many thanks to all!
skullbocks
Baby Hen
 
Posts: 19
Joined: Sun Dec 24, 2006 11:53


Return to 3D Desktops and Window Managers

Who is online

Users browsing this forum: No registered users and 2 guests