KDM Auto-Login no longer working and strange clock issue

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

KDM Auto-Login no longer working and strange clock issue

Postby Judge » Tue Apr 08, 2014 9:10

Hi everyone!

After the last system update 2 weeks ago, I'm experiencing two strange issues with my environment after each boot.

The first one: Clock.
Everytime my system boots, my desktop clock shows 2 hours earlier than local time (I'm in CEST which is due to daylight saving UTC+2). I have the following in /etc/conf.d/hwclock:

Code: Select all
clock="UTC"
#clock_hctosys="YES"
clock_systohc="YES"
clock_args=""


When I manually issue "ntpdate" on the shell or accept settings for ntp in KDE time settings, my clock is turned to the correct time.
As far as I understand the settings in /etc/conf.d/hwclock , the system should turn hwclock to UTC (clock_systohc=YES + clock="UTC") on shutdown and also know that the hwclock is set to UTC, isn't it?

The second one: KDE Auto-Login

I have searched for this in the forums but did not get the solution. The most recent other topic for example is about the setting in /usr/share/config/kdm/kdmrc is reseted on reboot, which isn't hapening on my system. It just doesn't work with the proper settings in place:

This is the (relevant?) part in my /usr/share/config/kdm/kdmrc file:

Code: Select all
[X-:0-Core]
AutoLoginEnable=true
AutoLoginLocked=true
AutoLoginUser=mr


This is set by the KDE GUI set to this:

Sorry for the german lables, but I guess you recognize the dialogues from your native languages ...

What happens is: ... nothing. No Auto-Login happens, I'm presented with a graphical password-prompt on system start.
Auto-Login worked just before this last update.

Can anyone tell me how I might get this working again please?
Judge
Baby Hen
 
Posts: 8
Joined: Tue Dec 18, 2012 12:26
Location: Ratingen

Re: KDM Auto-Login no longer working and strange clock issue

Postby OmegaSW » Tue Apr 08, 2014 10:17

For your clock, I fixed mine by going into the bios and changing my time (I had to change mine by ~8hours in PST) to get it to reflect properly in KDE. I'm sure there are other possible ways to fix this, but I didn't want to bother.

For KDM Autologin, could you do this command in the terminal and post it here?
Code: Select all
systemctl list-unit-files | grep enabled
Sabayon KDE 64Bit Edition
Samsung Galaxy Note 3
Steam User
User avatar
OmegaSW
Simple Hen
 
Posts: 41
Joined: Fri Feb 07, 2014 4:47

Re: KDM Auto-Login no longer working and strange clock issue

Postby Judge » Tue Apr 08, 2014 14:54

Hi OmegaSW,

thanks, that pointed me into the right direction: kdm.service was disabled, while lightdm.service was enabled. This resulted in the "wrong" DM to launch. As soon as I exchanged this like this, everything regarding the (K)DM-Auto-Login worked again. ... should have realized that ugly design of the login-window ... :oops:

Code: Select all
systemctl disable lightdm.service
systemctl enable kdm.service


Thank you so far.
Now I stil need a solution for my clock - issue :)
Judge
Baby Hen
 
Posts: 8
Joined: Tue Dec 18, 2012 12:26
Location: Ratingen

Re: KDM Auto-Login no longer working and strange clock issue

Postby OmegaSW » Tue Apr 08, 2014 18:16

You're welcome! :)

If you find the solution to the clock issue, please post it here. I haven't trouble shooted this issue myself yet. I just took the cheap way out by changing the clock in my MB bios to offeset the time.
Sabayon KDE 64Bit Edition
Samsung Galaxy Note 3
Steam User
User avatar
OmegaSW
Simple Hen
 
Posts: 41
Joined: Fri Feb 07, 2014 4:47

Re: KDM Auto-Login no longer working and strange clock issue

Postby OmegaSW » Mon Apr 14, 2014 11:09

I found out how to offset your time in the system using Systemd commands. By default, the system sets your Motherboard Bios Clock as UTC when in reality, it's probably your own timezone's clock.

Basically, it's like this:
1. timedatectl
2. timedatectl list-timezones
3. timedatectl set-timezone America/Los_Angeles
4. timedatectl set-time "2014-04-14 3:00:00"

Give it a few minutes, and KDE will adjust.
Sabayon KDE 64Bit Edition
Samsung Galaxy Note 3
Steam User
User avatar
OmegaSW
Simple Hen
 
Posts: 41
Joined: Fri Feb 07, 2014 4:47

Re: KDM Auto-Login no longer working and strange clock issue

Postby OmegaSW » Fri Apr 18, 2014 7:46

I forgot one little detail if you're a dual booter:
Windows uses Local, and Linux (Systemd) uses UTC by default. To get them to sync with each other you have two choices: Switch Linux to Local or Switch Windows to UTC.

Option 1: Open a terminal and do this command:
Code: Select all
timedatectl set-local-rtc true

to revert back to UTC, use the same command, but change true to false.

Option 2: Go into your windows registry (This is what I did because I think UTC is more logical)
Start->regedit
Go to: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation\
Create new DWORD entry called RealTimeIsUniversal (I used a 64 bit DWORD).
Double click RealTimeIsUniversal and change the hex to 1.
Reboot

I rebooted several times, and now Windows and Linux are now both in Sync.
Sabayon KDE 64Bit Edition
Samsung Galaxy Note 3
Steam User
User avatar
OmegaSW
Simple Hen
 
Posts: 41
Joined: Fri Feb 07, 2014 4:47

Re: KDM Auto-Login no longer working and strange clock issue

Postby Judge » Fri Apr 18, 2014 11:22

Hey, thank you for your efforts! I couldn't give this a try yet, since I was not at that system again since.

I'll provide feedback as soon as I have been.
Judge
Baby Hen
 
Posts: 8
Joined: Tue Dec 18, 2012 12:26
Location: Ratingen


Return to 3D Desktops and Window Managers

Who is online

Users browsing this forum: No registered users and 0 guests