Driver Nvidia non funzionano dopo cambio scheda video

Tutto ciò che è pertinente a Sabayon Linux, indipendentemente dall'architettura e dall'ambiente grafico

Moderator: Moderators

Re: Driver Nvidia non funzionano dopo cambio scheda video

Postby sabayonino » Thu Feb 20, 2014 19:58

potersti postare versione del kernel e versione dei drivers ?

Kernel
Code: Select all
# uname -r


Drivers
Code: Select all
# equo query installed nvidia-drivers


Repository
Code: Select all
# equo status
User avatar
sabayonino
Sagely Hen
 
Posts: 2583
Joined: Sun Sep 21, 2008 1:12
Location: Italy

Re: Driver Nvidia non funzionano dopo cambio scheda video

Postby anonimo » Thu Feb 20, 2014 20:52

Ecco qui i risultati:
kernel: 3.13.0-sabayon
drivers: x11-drivers/nvidia-drivers-331.38#3.13.0-sabayon
repo: #1 Sabayon Linux Official Repository sabayonlinux.org
User avatar
anonimo
Growing Hen
 
Posts: 108
Joined: Tue Feb 01, 2011 14:00

Re: Driver Nvidia non funzionano dopo cambio scheda video

Postby sabayonino » Thu Feb 20, 2014 21:21

anonimo wrote:Ecco qui i risultati:
kernel: 3.13.0-sabayon
drivers: x11-drivers/nvidia-drivers-331.38#3.13.0-sabayon
repo: #1 Sabayon Linux Official Repository sabayonlinux.org


ok. il problema con l'ACPI l'ho avuto anche io su gentoo con il kernel 3.13.X ...risolto con una patch per gli invidia.

potresti provare a switchare il kernel alla versione 3.12

Code: Select all
# kernel-switcher switch sys-kernel/linux-sabayon-3.12.9


dovrebbe tirarsi dietro anche i drivers relativi al kernel 3.12 , ma nel dubbio :
Code: Select all
# equo i nvidia-drivers#3.12.0-sabayon
User avatar
sabayonino
Sagely Hen
 
Posts: 2583
Joined: Sun Sep 21, 2008 1:12
Location: Italy

Re: Driver Nvidia non funzionano dopo cambio scheda video

Postby anonimo » Thu Feb 20, 2014 22:07

Purtroppo niente, ho provato a cambiare kernel, provando pure piú combinazioni di parametri kernel, ma non c’è stato verso. Visto che mi hai detto che poteva essere un problema dei drivers, ho provato ad istallare la versione 173.14.38, ma niente, in tutti i casi mi restituisce l’errore con piú dettagli.. :bom:
User avatar
anonimo
Growing Hen
 
Posts: 108
Joined: Tue Feb 01, 2011 14:00

Re: Driver Nvidia non funzionano dopo cambio scheda video

Postby sabayonino » Thu Feb 20, 2014 23:13

anonimo wrote:Purtroppo niente, ho provato a cambiare kernel, provando pure piú combinazioni di parametri kernel, ma non c’è stato verso. Visto che mi hai detto che poteva essere un problema dei drivers, ho provato ad istallare la versione 173.14.38, ma niente, in tutti i casi mi restituisce l’errore con piú dettagli.. :bom:


hai modo di provare la scheda precedente ?

o comunque questa scheda ha problemi anche con altri SO ?
User avatar
sabayonino
Sagely Hen
 
Posts: 2583
Joined: Sun Sep 21, 2008 1:12
Location: Italy

Re: Driver Nvidia non funzionano dopo cambio scheda video

Postby anonimo » Thu Feb 20, 2014 23:25

No, purtroppo la scheda precedente si è fusa. E la cosa veramente brutta, che sto sperimentando adesso, è che neanche i liveCd di altre distro (chakra e opensuse) non si avviano. Se non risolvo, l'unica prospettiva è tornare dopo 4 anni a windows.. :(
User avatar
anonimo
Growing Hen
 
Posts: 108
Joined: Tue Feb 01, 2011 14:00

Re: Driver Nvidia non funzionano dopo cambio scheda video

Postby sabayonino » Thu Feb 20, 2014 23:33

anonimo wrote:No, purtroppo la scheda precedente si è fusa. E la cosa veramente brutta, che sto sperimentando adesso, è che neanche i liveCd di altre distro (chakra e opensuse) non si avviano. Se non risolvo, l'unica prospettiva è tornare dopo 4 anni a windows.. :(


:mrgreen: prova .

spero non abbia problemi HW :shock:
(non mi sorprenderei ... dopo 4 mesi mi si è fuso un processore nuovo ...)
User avatar
sabayonino
Sagely Hen
 
Posts: 2583
Joined: Sun Sep 21, 2008 1:12
Location: Italy

Re: Driver Nvidia non funzionano dopo cambio scheda video

Postby anonimo » Thu Feb 20, 2014 23:59

Per fortuna non devo avvelenarmi con windows, ho casualmente scoperto a casa un cd di 3 anni fa con sabayon 6, e parte regolarmente! Per ora mi installo anche questo sul pc! :twisted: Non è un problema d'hardware, per fortuna. Non vorrei però che il problema fosse dovuto a qualche servizio successivo al 2011 e condiviso da piú distro (tipo Systemd, anche se ho tirato a caso che so solo che interagisce col kernel). Ora finisco l'installazione e vado a dormire. Domani ricomicerò le ricerche!! :pirat:
User avatar
anonimo
Growing Hen
 
Posts: 108
Joined: Tue Feb 01, 2011 14:00

Re: Driver Nvidia non funzionano dopo cambio scheda video

Postby sabayonino » Fri Feb 21, 2014 1:43

il tuo problema ad ACPI potrebbe essere questo : https://devtalk.nvidia.com/default/topi ... rc1-kernel

vedi anche https://forums.gentoo.org/viewtopic-t-9 ... patch.html

e la patch per acpi : https://forums.gentoo.org/viewtopic-p-7 ... ml#7490382

io ho utilizzato queste in gentoo per risolvere il problema di ACPI come scritto prima.

non so . forse è il caso di segnalarlo. al momento non ho nvidia per sabayon a disposizione ma solo intel.

resta da vedere se sei un caso sporadico :mrgreen:

io sto utilizzando Gentoo kernel 3.13.3 con nvidia-drivers-331.38 patchati ... altrimenti bel schermo nero (su GTX780)
User avatar
sabayonino
Sagely Hen
 
Posts: 2583
Joined: Sun Sep 21, 2008 1:12
Location: Italy

Re: Driver Nvidia non funzionano dopo cambio scheda video

Postby anonimo » Fri Feb 21, 2014 19:33

Ho letto dalla pagina del forum di nvidia che mi hai suggerito che il problema ai driver potrebbe riguardare anche altre versioni dei driver, anche se ho notato che ad alcuni utenti non è servito. La mia prossima strategia di attacco ( più che altro mi attacco ad una speranza..) al problema sarà quella di installarmi tramite portage il kernel e i drivers e poi applicare la o le patch, come suggerito dal forum gentoo. È dai tempi del forum innominabile(sto editando il post perché questo forum modifica in automatico il suo nome in google!, incredibile!) con tutte le guide che non uso portage, non ricordo bene, dimmi se dimentico qualcosa nella procedura:
aggiorno portage:
Code: Select all
emerge --sync

installo layman, aggiungo gli overlay sabayon e sabayon-distro e poi aggiorno (ho visto su zugaina che c'è il kernel per sabayon)
Code: Select all
emerge layman
layman -a sabayon
layman -a sabayon-distro
layman -S

emergo il kernel per sabayon e i suoi sorgenti
Code: Select all
emerge linux-sabayon-3.13.3
emerge sabayon-sources-3.13.3

emergo i drivers nvidia e userspace
Code: Select all
emerge nvidia-userspace-331.38
emerge nvidia-drivers-331.38

Poi seguo la pagina del forum con le patch
È giusto?
Grazie mille sabayonino per il supporto che mi stai dando, speriamo di risolvere! :)
User avatar
anonimo
Growing Hen
 
Posts: 108
Joined: Tue Feb 01, 2011 14:00

PreviousNext

Return to Sabayon Linux Discussioni Generali

Who is online

Users browsing this forum: No registered users and 1 guest

cron