Problem with fglrx

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

Problem with fglrx

Postby agge92 » Fri Feb 14, 2014 2:53

After a frash installation of Sabayon 14 x64 KDE I followed the guide: https://wiki.sabayon.org/index.php?titl ... in_Sabayon
for the installation of the proprietary catalyst driver(for my HD 7770), and after the reboot, Kwin crashed and after this it wasnt possible to set correctly the compositor opengl 2.0 or above and I can't run Steam! with my games =_= (on the opening of steam a message of error pop-up: glXChooseVisual failed :( ) so, I tried to install the driver linux x64 from the site of amd (before I removed amdcccle) and seems nothing changed, the compositor of opengl is still broken, and the amd catalyst control center after the launching of the application, it does nothing....Now I want to try to come back to the open drivers, but I still prefer in some way run the steam games with my gpu totally. And I dont know how to remove the fglrx that I installed from the site of AMD...Someone can help me in both this task?(1st try to set correctly the proprietary driver, and if persist the malfunction,(2nd) try to get back to opensource drivers :( ) :cry:
agge92
Baby Hen
 
Posts: 14
Joined: Fri Jul 19, 2013 10:41

Re: Problem with fglrx

Postby imaginasys » Mon Feb 17, 2014 20:25

Have a look at thsi:

https://wiki.sabayon.org/index.php?title=HOWTO:_Get_AMD/ATI_or_Nvidia_Video_Cards_working_in_Sabayon

Check if you booted with kernel option : nomodeset

And be prepared to work from the console without any graphic environment...

Regards,
BT :mrgreen:
imaginasys
Simple Hen
 
Posts: 51
Joined: Sat Nov 23, 2013 6:59

Re: Problem with fglrx

Postby batvink » Mon Feb 17, 2014 22:52

Is "fglrx" specified as the driver in Xorg?

This will modify an existing xorg.conf to use the fglrx driver with a single screen:
Code: Select all
aticonfig --initial --input=/etc/X11/xorg.conf


For dual-head configuration use this instead (where the second screen is [left|right|above|below]):
Code: Select all
aticonfig --initial=dual-head --input=/etc/X11/xorg.conf --screen-layout=[left|right|above|below]


Set the OpenGL driver to use fglrx:
Code: Select all
eselect opengl set ati


Don't have a xorg.conf?
You can simply create one in /etc/X11/ or let Xorg create one for you:
Code: Select all
X -configure

Location of the generated xorg.conf is: /root/xorg.conf.new
Code: Select all
cp /root/xorg.conf.new /etc/X11/xorg.conf
User avatar
batvink
Old Dear Hen
 
Posts: 495
Joined: Sun Oct 28, 2007 11:44
Location: the netherlands

Re: Problem with fglrx

Postby agge92 » Tue Feb 18, 2014 18:33

yes I followed all that thinks that you say and booted with nomoeset...
and tha eselect opengl set ati seems dont work after kwin crash with opengl impostations
agge92
Baby Hen
 
Posts: 14
Joined: Fri Jul 19, 2013 10:41

Re: Problem with fglrx

Postby batvink » Tue Feb 18, 2014 19:05

hmmmm.
eselect mesa set to gallium ?
    eselect mesa list
    i915 (Intel 915, 945)
    [1] classic
    [2] gallium *
    i965 (Intel GMA 965, G/Q3x, G/Q4x, HD)
    [1] classic *
    r300 (Radeon R300-R500)
    [1] gallium *
    r600 (Radeon R600-R700, Evergreen, Northern Islands)
    [1] gallium *
    sw (Software renderer)
    [1] classic
    [2] gallium *
User avatar
batvink
Old Dear Hen
 
Posts: 495
Joined: Sun Oct 28, 2007 11:44
Location: the netherlands

Re: Problem with fglrx

Postby agge92 » Wed Feb 19, 2014 22:16

batvink wrote:hmmmm.
eselect mesa set to gallium ?
    eselect mesa list
    i915 (Intel 915, 945)
    [1] classic
    [2] gallium *
    i965 (Intel GMA 965, G/Q3x, G/Q4x, HD)
    [1] classic *
    r300 (Radeon R300-R500)
    [1] gallium *
    r600 (Radeon R600-R700, Evergreen, Northern Islands)
    [1] gallium *
    sw (Software renderer)
    [1] classic
    [2] gallium *

eh?
(however, I reinstalled again the os without adding the closed source driver, because it seems dont work properly because of the crash of Kwin)
agge92
Baby Hen
 
Posts: 14
Joined: Fri Jul 19, 2013 10:41

Re: Problem with fglrx

Postby Darksurf » Thu Feb 20, 2014 13:14

When you booted from the live disk, did you go to advanced options and disable KMS for FGLRX?

Then you may install the distro.
~ Y </0 5+Up1</ P30p[Ez +Ry 2 R34</ D1s? ~
Darksurf
Old Dear Hen
 
Posts: 782
Joined: Sat Sep 16, 2006 4:01


Return to Hardware

Who is online

Users browsing this forum: No registered users and 0 guests

cron