Dependency not found in equo [Solved]

Anything that pertains to Entropy, Equo or Sulfur

Moderator: Moderators

Dependency not found in equo [Solved]

Postby Conrad » Tue Jan 28, 2014 11:56

Greetings to all.

I am having problems updating Sabayon, or installing certain packages because of problems with media-video/ffmpeg. For example, when trying to update or install digikam I get the following:

Code: Select all
PsychStat conrad # equo upgrade --ask
╠ @@ Calculating System Updates:
╠ @@ Calculating dependencies...
☢ @@ Dependencies not found:
☢ # Not found: >=media-video/ffmpeg-0.10.8:0[X,encode,gsm,jpeg2k,mp3,sdl,speex,theora,threads,truetype,vaapi,vdpau,x264,abi_x86_32,abi_x86_64]
PsychStat conrad # equo install digikam --ask
╠ @@ Calculating dependencies...
☢ @@ Dependencies not found:
☢ # Not found: >=media-video/ffmpeg-0.10.8:0[X,encode,gsm,jpeg2k,mp3,sdl,speex,theora,threads,truetype,vaapi,vdpau,x264,abi_x86_32,abi_x86_64]
Code: Select all


I have made limited changes in order to get blender and R from portage so that they are working as I want them as follows
/etc/portage/package.use/01-mypackages
Code: Select all
# The following use flags are set to ensure latest blender works
media-gfx/blender bullet ffmpeg game-engine cycles player
dev-python/numpy python_targets_python3_3
dev-python/setuptools python_targets_python3_3


# The following use flags are set to allow simon to work
=app-accessibility/julius-4.2.2 alsa -pulseaudio

# The following use flag is set to test tcltk problem with R
dev-lang/R X bash-completion cairo jpeg nls openmp perl png readline tiff tk


/etc/entropy/package.mask
Code: Select all
media-gfx/blender
<media-video/libav-9.10


Any suggestions on how I can troubleshoot this problem?
Last edited by Conrad on Wed Feb 05, 2014 8:01, edited 1 time in total.
Conrad
Baby Hen
 
Posts: 3
Joined: Tue Jan 21, 2014 9:21

Re: Dependency not found in equo

Postby wolfden » Wed Jan 29, 2014 12:44

do you have ffmpeg masked?

Code: Select all
wolflappy wolfden # equo install ffmpeg --ask
╠  @@ Calculating dependencies...
╠  @@ These are the packages that would be installed:
╠  ## [R] [sabayon-limbo->sabayonlinux.org] virtual/ffmpeg-0.10.8|0   [0.10.8|0]
╠  @@ Packages needing to be installed/updated/downgraded: 1
╠  @@ Packages needing to be removed: 0
╠  @@ Packages needing to be installed: 0
╠  @@ Packages needing to be reinstalled: 1
╠  @@ Packages needing to be updated: 0
╠  @@ Packages needing to be downgraded: 0
╠  @@ Download size: 0b
╠  @@ Freed disk space: 0.0b
╠  @@ You need at least: 39.3kB of free space
     Would you like to continue ? [Yes/No] 5

wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: Dependency not found in equo

Postby Conrad » Fri Jan 31, 2014 8:47

Thanks for the reply wolfden,

I see that media-video/ffmpeg is masked in /etc/portage/package.mask/00-sabayon.package.mask:
Code: Select all
...
# 2013-01-13 Fabio Erculiani: we use media-video/libav
media-video/ffmpeg


How should I proceed?
Conrad
Baby Hen
 
Posts: 3
Joined: Tue Jan 21, 2014 9:21

Re: Dependency not found in equo

Postby wolfden » Sun Feb 02, 2014 23:21

seems weird if I do a fresh install of digikam, it doesn't depend on ffmpeg at all

how did you install it? are u mixing portage and entropy? maybe uninstall it and reinstall it
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: Dependency not found in equo

Postby Conrad » Wed Feb 05, 2014 8:00

The problem seems to have been with masking <media-video/libav-9.10
The newer versions are needed by Blender 2.88 which still hasn't made its way into the Sabayon-weekly repository (see the request here https://bugs.sabayon.org/show_bug.cgi?id=4330). But a system upgrade and digikam downgrade the package to media-video/libav-0.8.9-r1

Thank you for your help Wolfden
Conrad
Baby Hen
 
Posts: 3
Joined: Tue Jan 21, 2014 9:21


Return to Entropy|Equo|Rigo Package Managers

Who is online

Users browsing this forum: No registered users and 1 guest

cron