Installazione Draftsight [Risolto]

Tutto ciò che è pertinente a Sabayon Linux, indipendentemente dall'architettura e dall'ambiente grafico

Moderator: Moderators

Installazione Draftsight [Risolto]

Postby negus73 » Sat Oct 22, 2011 1:01

Da qualche giorno sto impazzendo con DraftSIght.
Infatti ho necessità di installare questo programma di cad freeware di cui , purtroppo, non si trovano i sorgenti ma solamente pacchetti .rpm e .deb.
In qualche caso mi è capitato di riuscire ad installare software scompattando il pacchetto e seguendo le istruzioni in esso contenute, ma questo caso si sta rivelando assai ostico per le mie capacità.
Nel pacchetto deb, vi è uno shell script che lancia l'installazione ma che dopo un po' si blocca con questo messaggio:
Code: Select all
phantom DEBIAN # ./preinst
access control disabled, clients can connect from any host
Gtk-Message: Failed to load module "globalmenu-plugin"
Gtk-Message: Failed to load module "canberra-gtk-module"
access control enabled, only authorized clients can connect


Ho provato poi a installare con i tools dai pacchetti, seguendo qualche indicazione reperita qua e là, ma senza successo.
In particolare con il pacchetto deb l'errore restituito è il seguente:

Code: Select all
phantom DraftSight.5 # dpkg -i DraftSight.deb
dpkg: error: apertura del file di informazioni sui pacchetti "/var/lib/lib/dpkg/status" in lettura non riuscita: File o directory non esistente


Con il pacchetto rpm invece vengono elencate molte dipendenze:
Code: Select all
phantom negus # rpm -i DraftSight.rpm
errore: Dipendenze fallite:
   /bin/bash necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   /bin/sh necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libGL.so.1 necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libGLU.so.1 necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libICE.so.6 necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libSM.so.6 necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libX11.so.6 necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libXext.so.6 necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libXrender.so.1 necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libXt.so.6 necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libasound.so.2 necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libasound.so.2(ALSA_0.9) necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libasound.so.2(ALSA_0.9.0rc4) necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libaudio.so.2 necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libc.so.6 necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libc.so.6(GLIBC_2.0) necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libc.so.6(GLIBC_2.1) necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libc.so.6(GLIBC_2.1.2) necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libc.so.6(GLIBC_2.1.3) necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libc.so.6(GLIBC_2.10) necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libc.so.6(GLIBC_2.2) necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libc.so.6(GLIBC_2.2.4) necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libc.so.6(GLIBC_2.3) necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libc.so.6(GLIBC_2.3.2) necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libc.so.6(GLIBC_2.3.4) necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libc.so.6(GLIBC_2.4) necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libc.so.6(GLIBC_2.7) necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libc.so.6(GLIBC_2.9) necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libcups.so.2 necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libdl.so.2 necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libdl.so.2(GLIBC_2.0) necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libdl.so.2(GLIBC_2.1) necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libfontconfig.so.1 necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libgcc_s.so.1 necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libgcc_s.so.1(GCC_3.0) necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libgcc_s.so.1(GLIBC_2.0) necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libglib-2.0.so.0 necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libgobject-2.0.so.0 necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libgthread-2.0.so.0 necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libm.so.6 necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libm.so.6(GLIBC_2.0) necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libm.so.6(GLIBC_2.1) necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libm.so.6(GLIBC_2.2) necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libpthread.so.0 necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libpthread.so.0(GLIBC_2.0) necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libpthread.so.0(GLIBC_2.1) necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libpthread.so.0(GLIBC_2.2) necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libpthread.so.0(GLIBC_2.2.3) necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libpthread.so.0(GLIBC_2.3.2) necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libresolv.so.2 necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   librt.so.1 necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   librt.so.1(GLIBC_2.2) necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libstdc++.so.6 necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libstdc++.so.6(CXXABI_1.3) necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libstdc++.so.6(CXXABI_1.3.1) necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libstdc++.so.6(GLIBCXX_3.4) necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libstdc++.so.6(GLIBCXX_3.4.11) necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libstdc++.so.6(GLIBCXX_3.4.9) necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libuuid.so.1 necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libuuid.so.1(UUID_1.0) necessario a dassault-systemes-draftsight-2011.5.1081-2.i386
   libz.so.1 necessario a dassault-systemes-draftsight-2011.5.1081-2.i386



Come posso procedere? :roll:
La cosa che mi fa rabbia è che qualche tempo fa sono riuscito a installare il software ma ... non mi ricordo come ho fatto :oops:
Siccome c'è stato il passaggio dalla release 1.2 alla 1.3 vorrei provare.

PS Non c'è la possibilità di inserirlo nei repository in modo da usare Entropy?
Grazie
Last edited by negus73 on Sun Nov 06, 2011 11:36, edited 1 time in total.
negus73
Young Hen
 
Posts: 25
Joined: Mon Dec 13, 2010 1:27

Re: Installazione Draftsight

Postby sabayonino » Sat Oct 22, 2011 13:17

Code: Select all
sudo touch /var/lib/lib/dpkg/status


Code: Select all
sudo touch /var/lib/lib/dpkg/available



poi non so come contiunuare in quanto la mia architettura è a 64 bit

questo il mio oputput
Code: Select all
sudo dpkg -i DraftSight.deb
dpkg: errore nell'elaborare DraftSight.deb (--install):
 l'architettura del pacchetto (i386) non corrisponde a quella del sistema (amd64)
Si sono verificati degli errori nell'elaborazione:
 DraftSight.deb


dopo aver eseguito i due comandi sopra ritenta e posta eventuali errori
User avatar
sabayonino
Sagely Hen
 
Posts: 2515
Joined: Sun Sep 21, 2008 1:12
Location: Italy

Re: Installazione Draftsight

Postby negus73 » Sat Oct 22, 2011 13:30

sabayonino wrote:
Code: Select all
sudo touch /var/lib/lib/dpkg/status


Code: Select all
sudo touch /var/lib/lib/dpkg/available



poi non so come contiunuare in quanto la mia architettura è a 64 bit

questo il mio oputput
Code: Select all
sudo dpkg -i DraftSight.deb
dpkg: errore nell'elaborare DraftSight.deb (--install):
 l'architettura del pacchetto (i386) non corrisponde a quella del sistema (amd64)
Si sono verificati degli errori nell'elaborazione:
 DraftSight.deb


dopo aver eseguito i due comandi sopra ritenta e posta eventuali errori

Grazie, avendo pure io AMD64 ho i tuoi stessi identici output. Tuttavia dalla pagina del download non c'è possibilità di scegliere l'architettura, per questo ho pensato che fosse ininfluente; infatti l'altra volta (maledetta memoria che comincia a cileccare!!) ricordo di aver usato gli script contenuti nel pacchetto.
Oggi riprovo e poi vi aggiorno!
negus73
Young Hen
 
Posts: 25
Joined: Mon Dec 13, 2010 1:27

Re: Installazione Draftsight

Postby sabayonino » Sat Oct 22, 2011 16:34

prova con :

Code: Select all
# dpkg -i --force-architecture DraftSight.deb


ma temo che otterrai errori su librerie con versioni non combacianti

inoltre forzando tutte le opziuoni , vengono anche richiesti pacchetti *buntu

Code: Select all
# dpkg -i --force-all DraftSight.deb



Se questi "vampiri" hanno rilasciato .deb e .rpm da qualche parte dovranno pur tenere il codice sorgente :mrgreen: ...
User avatar
sabayonino
Sagely Hen
 
Posts: 2515
Joined: Sun Sep 21, 2008 1:12
Location: Italy

Re: Installazione Draftsight

Postby negus73 » Sun Nov 06, 2011 11:36

Sono riuscito attraverso l'installazione di
emul-linux-x86-gtklibs
scompattato il pacchetto .deb, ho lanciato prima
./preinst
e
./postinst

nel menù grafica è comparsa l'icona e tutto funziona.
negus73
Young Hen
 
Posts: 25
Joined: Mon Dec 13, 2010 1:27

Re: Installazione Draftsight

Postby sabayonino » Sun Nov 06, 2011 22:07

negus73 wrote:Sono riuscito attraverso l'installazione di
emul-linux-x86-gtklibs
scompattato il pacchetto .deb, ho lanciato prima
./preinst
e
./postinst

nel menù grafica è comparsa l'icona e tutto funziona.


ottimo.complimenti :D
User avatar
sabayonino
Sagely Hen
 
Posts: 2515
Joined: Sun Sep 21, 2008 1:12
Location: Italy

Re: Installazione Draftsight [Risolto]

Postby specialworld83 » Sun Nov 06, 2011 23:12

Ho scritto una guida per chi necessita di installarlo su sabayon, eccone il link : http://www.codelinsoft.it/sito/?wpwtds_ ... in-sabayon
Image
Image
specialworld83
Simple Hen
 
Posts: 97
Joined: Sat Nov 10, 2007 11:16

Re: Installazione Draftsight [Risolto]

Postby vincshinigami » Fri Oct 18, 2013 9:30

salve a tutti,
io c'ho provato con l'istallazione di DraftSight, ma al comando ./preinst mi appare:



vinc-AcerB113 deb # ./preinst
access control disabled, clients can connect from any host
access control disabled, clients can connect from any host
access control disabled, clients can connect from any host

(ShowLicence:10407): Gtk-WARNING **: Impossibile trovare il motore del tema in module_path: «oxygen-gtk»,

(ShowLicence:10407): Gtk-WARNING **: Impossibile trovare il motore del tema in module_path: «oxygen-gtk»,
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 70: non-double matrix element
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 70: non-double matrix element
Fontconfig warning: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 78: saw unknown, expected number
access control enabled, only authorized clients can connect
access control enabled, only authorized clients can connect
access control enabled, only authorized clients can connect
vinc-AcerB113 deb #



...chi potrebbe aiutarmi?!
vincshinigami
Baby Hen
 
Posts: 1
Joined: Fri Oct 18, 2013 9:23

Re: Installazione Draftsight [Risolto]

Postby axelaxel6 » Fri Jan 10, 2014 17:09

hai installato ?
emul-linux-x86-gtklibs

io scompatto in una cartella draftsight.deb e poi come utente root copio le directory OPT USR e VAR nella cartella radice / del sistema, in seconda fase avvio gli script presenti nella cartella DEBIAN preinst e postinst (sempre come utente root), a me finora funziona
fai sapere
axelaxel6
Simple Hen
 
Posts: 64
Joined: Mon Mar 09, 2009 11:38


Return to Sabayon Linux Discussioni Generali

Who is online

Users browsing this forum: No registered users and 1 guest