How to set my keyboard right?

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

Re: How to set my keyboard right?

Postby Fitzcarraldo » Sat Jan 04, 2014 19:07

Try deleting the keyboard section from your xorg.conf file. Here's what my /etc/X11/xorg.conf file looks like on one of my laptops running SL Xfce (Don't copy it, use it as a reference only):

Code: Select all
Section "Module"
    SubSection  "extmod"
       Option    "omit xfree86-dga"
    EndSubSection
    Load    "i2c"
    Load    "ddc"
    Load    "vbe"
    Load    "dri"
    Load    "glx"
    Load    "synaptics"
EndSection

Section "ServerFlags"
     Option    "AllowMouseOpenFail"    "true"
EndSection

Section "Monitor"
    Identifier    "Generic Monitor"
    VertRefresh    43 - 60
    HorizSync      28 - 80
EndSection

Section "Device"
    Identifier  "SabayonVga0"
    Driver      "ati"
    Option "LogoPath" "/usr/share/backgrounds/sabayonlinux.png"
EndSection
   
Section "Screen"

    Identifier    "Screen 0"
    Device        "SabayonVga0"
    Monitor       "Generic Monitor"
    #Option       "AddARGBGLXVisuals" "true"

    DefaultDepth 24

    SubSection "Display"
        Depth      8
        ViewPort   0 0
        #Modes      "1024x768" "800x600" "640x480"
    EndSubsection

    SubSection "Display"
        Depth           16
        ViewPort        0 0
        #Modes      "1024x768" "800x600" "640x480"
    EndSubsection

    SubSection "Display"
        Depth           24
        ViewPort        0 0
        #Modes      "1024x768" "800x600" "640x480"
    EndSubsection

EndSection

Section "DRI"
    Mode 0666
EndSection

Section "ServerLayout"
    Identifier   "Main Layout"
    Screen 0    "Screen 0"
EndSection

Section "Extensions"
   #Option "Composite" "Enable"
EndSection

Notice there is no mention of the keyboard in my xorg.conf. Obviously keep the file /etc/X11/xorg.conf.d/00-keyboard.conf:

Code: Select all
Section "InputClass"
       Identifier "keyboard"
       MatchIsKeyboard "yes"
       Option "XkbLayout" "us,nl"
       Option "XkbVariant" ""
       Option  "XkbOptions" "grp:alt_shift_toggle"
EndSection
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7985
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: How to set my keyboard right?

Postby nomko » Tue Jan 07, 2014 9:14

I haven't checked the above yet, but i found out it has something to do with the Cinnamon desktop environment. Under Xfce i can set my keyboard right but under Cinnamon this is not possible.

I'm trying out Razor-QT at this moment. Lovely desktop environment, looks great!
ASUS P5KPL-AM SE*Intel Core2 Quad CPU Q8200*4 GiB ram*nVidia GeForce 9500GT*Realtek RTL8101/8102E*Optiarc DVD-RW AD-7200A*HDD:Samsung HD501LJ/HD103SI*Sitecom X5-N600 Router
nomko
Young Hen
 
Posts: 37
Joined: Fri Dec 27, 2013 21:57
Location: The Netherlands

Re: How to set my keyboard right?

Postby nomko » Wed Jan 08, 2014 9:17

Even under Razor-QT my keyboard is not set correct. I'll have to run the instructions given by Fitzcarraldo but as far as I can judge it, this issue is not good for Sabayon....
ASUS P5KPL-AM SE*Intel Core2 Quad CPU Q8200*4 GiB ram*nVidia GeForce 9500GT*Realtek RTL8101/8102E*Optiarc DVD-RW AD-7200A*HDD:Samsung HD501LJ/HD103SI*Sitecom X5-N600 Router
nomko
Young Hen
 
Posts: 37
Joined: Fri Dec 27, 2013 21:57
Location: The Netherlands

Re: How to set my keyboard right?

Postby nomko » Thu Jan 16, 2014 10:43

I've re-installed Sabayon and using the Xfce desktop. I quite this exercise of getting my keyboard right under other desktop environments. I have to accept it's a Sabayon thing.
ASUS P5KPL-AM SE*Intel Core2 Quad CPU Q8200*4 GiB ram*nVidia GeForce 9500GT*Realtek RTL8101/8102E*Optiarc DVD-RW AD-7200A*HDD:Samsung HD501LJ/HD103SI*Sitecom X5-N600 Router
nomko
Young Hen
 
Posts: 37
Joined: Fri Dec 27, 2013 21:57
Location: The Netherlands

Re: How to set my keyboard right?

Postby batvink » Thu Jan 16, 2014 14:45

Reinstall wasn't needed, and brought you nothing new, except a fresh Environment,
and still not able to use that key like it should.
You can change that with systemd's localectl
open terminal, and su
now, to change the keyboard-settings, layouts, etc... the syntaxes are:
Code: Select all
localectl set-locale variant

Code: Select all
localectl set-keymap layout

Code: Select all
localectl set-x11-keymap LAYOUT [MODEL] [VARIANT] [OPTIONS]

The Dutch uses US QWERTY keyboards by default, mostly pc105 models.

Based on your post, you should do something like:
Code: Select all
localectl set-locale LANG=en_US.UTF-8

Code: Select all
localectl set-keymap us

and then, either:
Code: Select all
localectl set-x11-keymap us

or:
Code: Select all
localectl set-x11-keymap us [trust] [102_qwerty_comma_nodead] [numpad:pc]

For a overview of all possible options, please see:
Code: Select all
localectl --help

Please make sure to reboot, or at least log off for the changes to take effect.
User avatar
batvink
Old Dear Hen
 
Posts: 495
Joined: Sun Oct 28, 2007 11:44
Location: the netherlands

Re: How to set my keyboard right?

Postby albfneto » Thu Jan 16, 2014 21:13

you may "force" your Keyboard to work good, using the command setxkbmap, as below

Code: Select all
 setxkbmap -model X -layout Y -variant Z


For "X", "Y" anf "Z", please search in the Internet for suitable model, layout and variant for Nederlands-NL Keyboards.

I dont know, because I'm Brazilian, In Brazil, We use this:

Code: Select all
 setxkbmap -model abnt2 -layout br -variant abnt2
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1725
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Previous

Return to Hardware

Who is online

Users browsing this forum: No registered users and 1 guest

cron